Project

General

Profile

Bug #68700

11.2-RELEASE-U1 will *NOT BOOT* on a HP Microserver N40L

Added by John Pierce 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Ryan Moeller
Category:
Hardware
Target version:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Booting a clean fresh USB stick gets as far as ..

FreeBSD/x86 Bootstrap loader, Revision 1.1
(Thu Dec 20 16:09:28 EST 2018 )

then the box hard locks. Tried over and over, with different sticks and stuff, same thing every time.

FreeBSD 11.2-U1-memstick.img boots fine on the same system. FreeNAS-11.1-U1.iso boots fine, too.

of potential note, this is a BIOS system, not UEFI. mine has 16GB ECC ram, it passed memtest for 24 hours without a fault.


Related issues

Is duplicate of FreeNAS - Bug #65994: Merge in FreeBSD boot loader fixesReady for Testing

History

#1 Updated by Disk Didler 5 months ago

John Pierce wrote:

Booting a clean fresh USB stick gets as far as ..

FreeBSD/x86 Bootstrap loader, Revision 1.1
(Thu Dec 20 16:09:28 EST 2018 )

then the box hard locks. Tried over and over, with different sticks and stuff, same thing every time.

FreeBSD 11.2-U1-memstick.img boots fine on the same system. FreeNAS-11.1-U1.iso boots fine, too.

of potential note, this is a BIOS system, not UEFI. mine has 16GB ECC ram, it passed memtest for 24 hours without a fault.

I have 11.2 (not U1) working on my machine. Is this your first time trying FreeNAS on this machine? I didn't do the most recent update. I can kick it off remotely and try. (however, we have many Microserver users, so I'd expect to hear something if this U1 release was dead)

#2 Updated by John Pierce 5 months ago

Disk Didler wrote:

I have 11.2 (not U1) working on my machine. Is this your first time trying FreeNAS on this machine? I didn't do the most recent update. I can kick it off remotely and try. (however, we have many Microserver users, so I'd expect to hear something if this U1 release was dead)

nope, ran 9.3 -> 9.10 -> 11.0 -> 11.1 and all incrementals in between, although I never messed with 10.

I clean installed 11.1-U1 and am restoring my last saved config backup now...

#4 Updated by Disk Didler 5 months ago

I'm upgrading on mine right now, from 11.2 to 11.2 U1.

How do I pull this DMI stuff?

#5 Updated by John Pierce 5 months ago

Disk Didler wrote:

I'm upgrading on mine right now, from 11.2 to 11.2 U1.

How do I pull this DMI stuff?

from shell, dmidecode ... it spews a whole pile of stuff w/o options, if you specify -t0, you get that first block, and -t1, the 2nd...

#7 Updated by John Pierce 5 months ago

so, you have the latest bios, mine is from 2011. unluckily, without an active warranty or service contract, I apparently can't download the update from HPE anymore :(

#8 Updated by Disk Didler 5 months ago

If you check out forums.overclockers.com.au there's a massive thread of N54L Microserver owners.
Better option is to search for "Microserver SATA hack rom" or "N54L Sata bios hack" etc.

Some of those forums, someone will still have the file.

Also I THINK I just found it here for you.
http://www.infralib.com/download/hp-proliant-g7-n54l-microserver-system-rom-o41/

But probably not the nice hacked one (gives SATA port 5/6 full 300MB speed, not 150)

#9 Updated by Disk Didler 5 months ago

Ok sorry about the bad news, it's either the bios (I don't think it is) or something else. It's working here fore me, I'm now fully up to date with the latest release.

Note, it's an N54L - but the hardware is identical (even that BIOS I sent you, will work on 36 / 40 and 54L)

#10 Updated by John Pierce 5 months ago

I found the stock 10/01/2013 HP patch at an overseas site, and have applied it, and am waiting for the reboot to finish.

I'm not using sata 5/6 anyways, just the 4 main bays... looks like it booted and its good to go.

tomorrow I'll try the 11.2 boot again, i've been at this for too many hours now.

#11 Updated by Disk Didler 5 months ago

Good luck, if you need anything else let me know.

Make sure your USB key has free space to install it too I guess, perhaps 11.2 uses a lot more space.

I know my N54L Has a couple of small issues with USB (very old keys) and so the update process /literally/ takes at least 60 minutes.

#12 Updated by John Pierce 5 months ago

before I even try the upgrade, I'll just try booting an 11.2-RELEASE-U1 stick, that was crashing. the odd thing is, on the 5th, I upgraded my 11.1-U6.3 to 11.2-U1 (I skipped 11.1) and it worked fine, ran for about a day, then we had a power failure on the evening the 6th, and when the power came back on, and I reset the UPS, it wouldn't boot. it froze very early on, without any meaningful output. I didn't get serious about debugging it until today, yesterday was spent getting my firewall rebuilt.

#13 Updated by Dru Lavigne 5 months ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

Let us know the results of your next testing.

#14 Updated by John Pierce 5 months ago

sorry it took a couple days to get back here...

I burned a fresh download of 11.2-RELEASE-U1.iso on the same stick I've used for the other OS installs, and tried cold booting the Microserver w/o any other USB sticks in it, and it hung in the same place, even with the latest 10/01/2013 BIOS...

It displays...

FreeBSD/x86 Bootstrap loader, Revision 1.1
(Thu Dec 20 16:09:28 EST 2018 )

and locks up. Booting stock BSD 11.2, and it almost immediately displays the line about /boot/loader.conf right after that, and continues with the /|\ spinner and loads up to where it asks what to do re install vs whatever. ...

#15 Updated by Disk Didler 5 months ago

Can you unplug EVERYTHING except the USB key?

I've got a lot on this weekend but I will try and replicate this for you, can you link to the exact ISO file you used and the tool to burn the key?

#16 Updated by John Pierce 5 months ago

I need to leave the keyboard plugged into USB, and the VGA monitor plugged in to see whats going on. I powered off and unplugged my normal mirrored USB sticks before I did this test. do you want me to also remove my 4 x SATA zpool ?

I downloaded https://download.freenas.org/11.2/STABLE/U1/x64/FreeNAS-11.2-RELEASE-U1.iso
and burned it to a sandisk ultra 16GB, and a ultra Fit 32GB usb3, using win32DiskImager on my windows 10 system, exactly like I burned the other images...

01/28/2018 12:29 PM 772,208,128 FreeBSD-11.1-RELEASE-amd64-memstick.img <= works
01/08/2019 10:16 AM 771,695,104 FreeBSD-11.2-RELEASE-amd64-memstick.img <= works
01/20/2018 05:22 PM 626,601,984 FreeNAS-11.1-U1.iso <= works
01/07/2019 02:44 PM 603,412,480 FreeNAS-11.2-RELEASE-U1.iso <= crashes

#17 Updated by Dru Lavigne 5 months ago

John: to clarify, a fresh install of 11.2-RELEASE works? If so, does it crash after updating to 11.2-RELEASE-U1?

#18 Updated by John Pierce 5 months ago

I can't do a fresh install because I can't boot a 11.2 USB stick.

I originally did an upgrade from 11.1-U6.3 to 11.2-U1, this rebooted and worked for a couple days, then the next reboot it hard crashed.

I haven't tried the upgrade again (its disruptive to have my NAS down), but since the USB stick won't boot, I'm guessing the upgrade will have the same problem.

#19 Updated by Dru Lavigne 5 months ago

Is the system currently booting into U6.3? If so, a debug created there will give more details about the hardware.

If not, a fresh install of U6.3 should get you back to where you started (be sure to upload a config from U6.3, not one from when you were on 11.2).

#21 Updated by Dru Lavigne 5 months ago

System -> Advanced -> Save debug.

#22 Updated by John Pierce 5 months ago

  • File debug-hognas-20190120125201.tgz added

i noted that block of errors above is talkign about jails. fyi, i've got a couple jail artifacts I can't seem to delete, the only important jail is the mysql one, which is running a small mysql server my weather station uses to record its readings, inserts once every 2 minutes.

anyways, here's the debug file.

#23 Updated by Dru Lavigne 5 months ago

  • Status changed from Blocked to Unscreened
  • Assignee changed from Release Council to Alexander Motin
  • Private changed from No to Yes
  • Reason for Blocked deleted (Need additional information from Author)

#24 Updated by Alexander Motin 5 months ago

  • Assignee changed from Alexander Motin to Ryan Moeller

#25 Updated by Ryan Moeller 5 months ago

  • Status changed from Unscreened to Screened

John I see that you tried "sandisk ultra 16GB, and a ultra Fit 32GB usb3" to boot from. Do you have any other USB sticks you could try? There are some SanDisk USB sticks that have a quirk which is incompatible with our bootloader. Note that the FreeBSD memstick image is a slightly different bootloader version than the FreeNAS ISO bootloader. Please see the related ticket for additional details.

#26 Updated by Ryan Moeller 5 months ago

  • Related to Bug #65994: Merge in FreeBSD boot loader fixes added

#27 Updated by John Pierce 5 months ago

hmmm. the one I did the most testing with is a lightly used older generation SanDisk Ultra 32GB SDCZ45-032G, which is strictly USB 2, these have been totally compatible and reliable with everything else I've ever done.

I'll have to really dig to find a non-sandisk USB stick around here, because I've been burned by nearly every other brand.

The UltraFIT very-short usb sticks have been my goto for both boot sticks and music sticks for the car stereo for years now, and have been the components of my normal mirrored boot.

#28 Updated by John Pierce 5 months ago

Do you have a preferred brand/version USB stick in the 16gb-32gb range ?

#29 Updated by Ryan Moeller 5 months ago

John Pierce wrote:

Do you have a preferred brand/version USB stick in the 16gb-32gb range ?

I normally prefer SanDisk so it is troubling to discover these issues. If possible I strongly recommend an SSD. Small ones have become incredibly cheap, in the same ballpark as a USB stick of the same size. A 64GB SSD should be plenty for the boot pool. I can't really recommend a USB stick.

#30 Updated by John Pierce 5 months ago

I still need a USB stick to boot in order to install. I've ordered one each Samsung, Lexar, and Kingston so I'll try them when they arrive.

to add a SSD to the microserver, I would need to put it in the 5.25" CD bay, ugh. I don't think I have any 5.25-2.5 adapters.... and I've heard the extra SATA port for the CD bay is just SATA 1, not SATA 2 like the main 4 hard drive bays, so it won't even be very fast, but I suppose that doesn't matter.

what bugs me, is this Microserver has run rock solid fine for 3-4 years now, using a mirrored pair of USB sticks as its boot.

#31 Updated by Sean Fagan 5 months ago

https://freenas.org/blog/sata-doms-over-usb-drive/

Thumb drives are invariably awful. The goal is to minimize the awfulness. In particular, whenever possible, use a pair of mirrored devices, check the status of the pool on every scrub, and try to rotate them out (that is, either add a third one and then remove one of the other two, or -- less safe -- remove one and replace it with a new one).

#32 Updated by John Pierce 5 months ago

yup, I've been doing exactly that. about once a year, I swap out one of the mirrored sticks, alternatingly, and each time, used a newer generation stick than the previous.

i was in fact looking at the sata port and thinking sata dom, but I don't think there's room in the chassis for one, there's barely room for a right angle connector.

nah, I'll ahve to get a sata ssd and mount it in the CD bay.

but this still doesn't answer the 'how do I install' question. if some SanDisk USB drives are suspect, I need to knwo what I can use. currently, I have a couple older USB 2 Ultra SDCZ45's, I have a couple UltraFIT USB 3.1 SDCZ430's, and right now its booting from UltraFIT USB 3.0 SDCZ43's

#33 Updated by Ryan Moeller 5 months ago

On the related ticket it was reported that a "TDK LoR Micro flash-disk" worked, and on the forum thread linked in the notes on that ticket someone has mentioned success with Kingston.

#34 Updated by John Pierce 5 months ago

found a 500GB Crucial SSD lying around here, and the cables to connect it in the CD bay, so hooked it up. mirrored it to my USB sticks, then took them out of the mirror, rebooted, and did the upgrade to 11.2, and yes, it works.

I noted that the upgrade rebooted, did a bunch of stuff, rebooted again still using Grub, and installed the new boot loader, then came up. so it was the /next/ reboot that was broken with my Sandisk UltraFIT's as well as any attempt at a USB boot of the 11.2 iSO...

when I get some more sticks in, I'll be loading a bunch of them with Freenas 11.2 and trying each one, and reporting my results.

#35 Updated by John Pierce 5 months ago

ok, with updated 2013 bios, my microserver n40l booted 11.2-U1-RELEASE.ISO off both a Samsung USB 3.1 32GB 'FIT" style stick, and a Kingston Data Traveler G4 32gb.

I don't recommend the samsung FIT, however, as it doesn't fit well into two different USB slots, has to be wiggled before it slides in.

#36 Updated by Ryan Moeller 5 months ago

  • Related to deleted (Bug #65994: Merge in FreeBSD boot loader fixes)

#37 Updated by Ryan Moeller 5 months ago

  • Is duplicate of Bug #65994: Merge in FreeBSD boot loader fixes added

#38 Updated by Ryan Moeller 5 months ago

  • Status changed from Screened to Closed
  • Target version deleted (Backlog)
  • Reason for Closing set to Duplicate Issue
  • Needs Merging changed from Yes to No

Thanks John. I'm closing this as a duplicate of the other ticket then.

#39 Updated by Dru Lavigne 5 months ago

  • File deleted (debug-hognas-20190120125201.tgz)

#40 Updated by Dru Lavigne 5 months ago

  • Target version set to N/A
  • Private changed from Yes to No

Also available in: Atom PDF