Project

General

Profile

Bug #68934

System crashes when booting Linux in bhyve

Added by Daniel shsh 8 days ago. Updated 5 days ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Not Applicable
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

An OS crash occurs everytime I start a Linux VM in graphical UI like trying Ubuntu 18.04 instead of starting the installer.

Tried latest Centos7, the VM boots to grub boot loader, selecting the install option it takes a bit without showing anything on the VNC screen then the session disconnects and the system is restarting.

I've been running FreeNAS without issues otherwise. My suspicion is that some bios settings are causing this. The /data/crash info file details a MCE panic is occurring.

History

#1 Updated by Daniel shsh 8 days ago

  • File debug-Bigboi-20190109182213.txz added
  • Private changed from No to Yes

#2 Updated by Daniel shsh 8 days ago

  • File debug2.tgz added

I have made some more tests. Tried an Ubuntu server minimal for the text installer suspecting a bad video card. Behavior persists but shows in a different way.

Booting the command-line install works but after approximately 10-20 seconds it crashes the VM only and the system remains up. If I retry the system crashes fully and reboots.

I have added a tarball of all of /data/crash. Next step is to do a fresh install of 11.1-U6.3 to see if the crash occurs there as well.

#3 Updated by Dru Lavigne 7 days ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

Daniel: when you're finished your testing, update this ticket with the results.

#4 Updated by Daniel shsh 5 days ago

Please close this bug report. The issue was with a core that was buggy. I've disabled core 9 on my CPU from bios and I can run VMs just fine now. This is FreeNAS unrelated. Tested with VMware ESXi that was crashing just the same. Just had to run-crash several times to notice it's the same core raising the MCE.

It is weird that the system was stable before running VMs. Just a point to consider, I guess. I'm really puzzled but this is what you get from buying second-hand xeons from ebay.

From my tests FreeNAS 11.-U6.3 was crashing just the VM but it doesn't matter now. I know that MCE = Hardware issue.

#5 Updated by Dru Lavigne 5 days ago

  • File deleted (debug-Bigboi-20190109182213.txz)

#6 Updated by Dru Lavigne 5 days ago

  • File deleted (debug2.tgz)

#7 Updated by Dru Lavigne 5 days ago

  • Status changed from Blocked to Closed
  • Target version changed from Backlog to N/A
  • Private changed from Yes to No
  • Reason for Closing set to Not Applicable
  • Reason for Blocked deleted (Need additional information from Author)

Thanks for the followup.

Also available in: Atom PDF