Project

General

Profile

Bug #6907

AD/CIFS fails on 9.2.1.9 (after upgrade from 9.2.1.6) please help

Added by Thomas Stather almost 6 years ago. Updated over 5 years ago.

Status:
Closed: Cannot reproduce
Priority:
Nice to have
Assignee:
John Hixson
Category:
OS
Target version:
-
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hello

I just upgraded from 9.2.1.6 where everything worked fine.
Now in 9.2.1.9 i am not able anymore to start the Directory services, the log is attached.
Thus its not possible anymore to browse to my CIFS shares (which is obvious). Please help, this is ciritcal :(

Best,

Thomas

History

#1 Updated by Thomas Stather almost 6 years ago

When i try to join the domain manually from the CLI i get:

[root@storage] ~# net -k ads join kuk.local -S 192.168.0.34 -p 389
Host is not configured as a member server.
Invalid configuration. Exiting....
Failed to join domain: This operation is only allowed for the PDC of the domain.

However during the failed start, when i type "klist" i get a kerberos ticket.

#2 Updated by Jordan Hubbard almost 6 years ago

  • Category set to 36
  • Assignee set to John Hixson
  • Priority changed from Important to Nice to have

Any idea why this would happen, John?

#3 Updated by John Hixson almost 6 years ago

  • Status changed from Unscreened to Screened

Can you follow the instructions for debugging here:

https://forums.freenas.org/index.php?threads/upgrading-to-9-2-b2-breaks-ad.16897/

Let me know where it breaks.

#4 Updated by Thomas Stather almost 6 years ago

OK but what about the service "ix-pre-samba". What does it do and when (during the troubleshooting procedure you mentioned in the post) should it be started?

#5 Updated by John Hixson almost 6 years ago

Thomas Stather wrote:

OK but what about the service "ix-pre-samba". What does it do and when (during the troubleshooting procedure you mentioned in the post) should it be started?

I had forgotten about that. I have edited the post for FreeNAS 9.2.1.9. If you could please look at it and follow the instructions and report back here what happens, that would be great ;-)

#6 Updated by Thomas Stather almost 6 years ago

No problem.
I reverted by productive setup back to 9.2.1.6 where it works now (like it did before) and setup a test setup. In this, i upgraded from 9.2.1.6 to 9.2.19 and could reproduce the issue.

Now going through your steps and testing...

#7 Updated by Thomas Stather almost 6 years ago

A few results:

Doing your steps, everything works until the

service service "ix-activedirectory start" command. Here i get on the FreeNAS console (VMWare):

[root@storage-test] ~# service ix-activedirectory start
Failed to join domain: failed to lookup DC info for domain 'KuK.local' over rpc: Logon failure
Failed to leave domain: Unable to fetch domain sid: are we joined?
Stopping winbindd.
Waiting for PIDS: 6856.
Stopping smbd.
Waiting for PIDS: 6853.
Stopping nmbd.
Waiting for PIDS: 6850.

and then:

[root@storage-test] ~# service ix-activedirectory status
ads_connect: No logon servers
ads_connect: No logon servers

#8 Updated by Thomas Stather almost 6 years ago

  • File FreeNAS 9.2.1.9.txt added

Attached is the log

#9 Updated by Thomas Stather almost 6 years ago

Same issue in 9.2.1.8 (downgraded from 9.2.1.9)

It works in 9.2.1.7 (downgraded from 9.2.1.8 or upgraded from 9.2.1.6)

So there must be something between 9.2.1.7 and 9.2.1.8

#10 Updated by Jordan Hubbard almost 6 years ago

Does this happen in 9.3-BETA? I ask simply because even if we find that we broke something in 9.2.1.8 (and I appreciate your work in binary-searching your way to the broken release), we aren't going to do any more 9.2.1.x releases and won't have a release vehicle for the fix other than 9.3.

#11 Updated by Thomas Stather almost 6 years ago

I'll give the last 9.3 beta a try....

#12 Updated by Thomas Stather almost 6 years ago

I upgraded from 9.2.1.7 to the latest 9.3-Beta.

Then i selected "Enabled" under "Directory Service" -> "Active Directory". However after a while i got the message "the service failed to start". There is nothing in the log i can use to troubleshoot, where is the logging gone which was active in 9.2.1.7?

#13 Updated by Thomas Stather almost 6 years ago

I just updated to 9.3-RELEASE but this is still the same:

Failed to leave domain: Unable to fetch domain sid: are we joined?

Where do you need more details to troubleshoot this issue?

#14 Updated by Jeroen Geusebroek almost 6 years ago

I'm having the exact same issues after upgrading to 9.3 release. 9.2.1.7 worked fine?

#15 Updated by Jeroen Geusebroek almost 6 years ago

When inspecting /usr/local/smb4.conf one thing that stands out is:

server role = standalone

This should of course be:

server role = member server

#16 Updated by Josh Paetzel almost 6 years ago

If you edit that setting in smb4.conf then do service samba_server forcerestart does it work?

#17 Updated by Steven Price almost 6 years ago

I am having the same issue and I tried to change smb4.conf from 'standalone' to 'member server' with no joy. I also had this issue in BETA however I am pretty sure that I had the A/D services working in one of the earlier version but I don't remember particulars - sorry :( - Is there anyway I could get a early beta before some of the patches were applied perhaps?

#18 Updated by Rickard Olsson almost 6 years ago

Same or similar issue in 9.3_Release and nightly build from a few days ago. My twist is I get

[root@freenas] ~# service ix-activedirectory restart
Traceback (most recent call last):
  File "/usr/local/bin/adtool", line 607, in <module>
    main()
  File "/usr/local/bin/adtool", line 593, in main
    adts = ADToolShell()
  File "/usr/local/bin/adtool", line 36, in __init__
    self.adc = ActiveDirectoryConfig(flags=FLAGS_DBINIT)
  File "/usr/local/www/freenasUI/common/freenasldap.py", line 2061, in __init__
    super(FreeNAS_ActiveDirectory, self).__init__(**kwargs)
  File "/usr/local/www/freenasUI/common/freenasldap.py", line 1429, in __init__
    self.site = self.locate_site()
  File "/usr/local/www/freenasUI/common/freenasldap.py", line 1590, in locate_site
    site_dn = s[1]['siteObject'][0]
KeyError: 'siteObject'
[: -lt: argument expected

Other than that wbinfo works fine, I get a Kerberos ticket and everything looks good except the domain users don't show up in FreeNAS or getent.

#19 Updated by John Hixson over 5 years ago

  • Status changed from Screened to Closed: Cannot reproduce

#20 Updated by Dru Lavigne over 2 years ago

  • File deleted (FreeNAS fail.txt)

#21 Updated by Dru Lavigne over 2 years ago

  • File deleted (FreeNAS 9.2.1.9.txt)

Also available in: Atom PDF