Project

General

Profile

Bug #69112

FreeNAS 11.2-RELEASE-U1 S3 service failed to start.

Added by Hans ch 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
Services
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I installed Freenas
Added a dataset
Configured a CA
Configured a certificate
Added S3 settings
Started S3
Result: S3 service failed to start.

Last item in /var/log/messages:
Jan 8 10:49:20 freenas root: /usr/local/etc/rc.d/minio: WARNING: failed precmd routine for minio

(It repeats itself when I try to start s3)

root@freenas[/usr/local/etc/minio]# ls -al

total 6
drwxrwxr-x 3 minio minio 64 Jan 8 10:22 .
drwxr-xr-x 37 root wheel 6016 Jan 8 10:51 ..
dr-xr-xr-x 3 root minio 192 Jan 8 10:22 certs

(I have found a topic on wrong ACLs but this seems to be OK.)


Related issues

Is duplicate of FreeNAS - Bug #67602: Fix bug that prevented S3 service from startingDone

History

#1 Updated by Dru Lavigne 7 months ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Hans: please reproduce then attach a debug (System -> Advanced -> Save debug) to this ticket.

#2 Updated by Hans ch 7 months ago

  • File debug-freenas-20190111092738.tgz added

#3 Updated by Hans ch 7 months ago

This seems to be addressed here: https://redmine.ixsystems.com/issues/67602

As I am new to FreeNAS I am not sure how to apply the patch.

#4 Updated by Dru Lavigne 7 months ago

  • Is duplicate of Bug #67602: Fix bug that prevented S3 service from starting added

#5 Updated by Dru Lavigne 7 months ago

  • File deleted (debug-freenas-20190111092738.tgz)

#6 Updated by Dru Lavigne 7 months ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Private changed from Yes to No
  • Reason for Blocked deleted (Need additional information from Author)

Hans: the fix will be in the next update (U2), slated forthe end of the month (https://redmine.ixsystems.com/projects/freenas/roadmap).

Also available in: Atom PDF