Project

General

Profile

Bug #69186

Remove LUN ID auto-assign from new UI

Added by Miguel Martín 7 months ago. Updated 5 months ago.

Status:
Done
Priority:
No priority
Assignee:
Lola Yang
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Adding an associated target with LUN ID 0 fails (Assuming there is another LUN with ID 0).

The reported error is:

LUN ID is already being used for this target.

But according to the LUN ID help, it should select the next available ID:

Select the value or enter a value between 0 and 1023. Some initiators expect a value below 256. Using 0 statically assigns the next available ID.

History

#1 Updated by Dru Lavigne 7 months ago

  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-U3

#2 Updated by Erin Clark 7 months ago

  • Assignee changed from Erin Clark to Lola Yang

#3 Updated by Lola Yang 7 months ago

  • Status changed from Unscreened to In Progress

#4 Updated by Lola Yang 7 months ago

Hi Miguel,

Unfortunately, 11.2 doesn't support the LUN ID auto assign. Please input the correct one. we will correct the tooltip. thanks.
11.3 will support it :)

#5 Updated by Miguel Martín 7 months ago

Lola Yang wrote:

Hi Miguel,

Unfortunately, 11.2 doesn't support the LUN ID auto assign. Please input the correct one. we will correct the tooltip. thanks.
11.3 will support it :)

It's strange, was it supported by previous versions? I am asking because in my local installation I have 2 targets and 2 extents and in the associated targets I have the following:

Target LUN ID Extent
target1 0 extent1
target1 0 extent2
target2 0 extent1
target2 0 extent2

I thought it could be because of the new web UI but I tried to add another extent to the associated targets with LUN ID 0 and it doesn't work either.

#6 Updated by Lola Yang 7 months ago

Miguel Martín wrote:

Lola Yang wrote:

Hi Miguel,

Unfortunately, 11.2 doesn't support the LUN ID auto assign. Please input the correct one. we will correct the tooltip. thanks.
11.3 will support it :)

It's strange, was it supported by previous versions? I am asking because in my local installation I have 2 targets and 2 extents and in the associated targets I have the following:

Target LUN ID Extent
target1 0 extent1
target1 0 extent2
target2 0 extent1
target2 0 extent2

I thought it could be because of the new web UI but I tried to add another extent to the associated targets with LUN ID 0 and it doesn't work either.

Yes, it was supported long ago. it was removed because it caused confusion.

#9 Updated by Dru Lavigne 6 months ago

  • Subject changed from New Web UI: iSCSI Associated Targets do not select the correct LUN ID automatically to Remove LUN ID auto-assign from new UI
  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#14 Avatar?id=55038&size=24x24 Updated by Zackary Welch 6 months ago

Are multiple associated targets with a LUN ID of 0 supposed to be allowed?

#15 Avatar?id=55038&size=24x24 Updated by Zackary Welch 6 months ago

  • Status changed from Ready for Testing to Blocked
  • Reason for Blocked set to Waiting for feedback

#16 Updated by Dru Lavigne 6 months ago

  • Needs Doc changed from Yes to No

#17 Updated by Lola Yang 5 months ago

Zackary Welch wrote:

Are multiple associated targets with a LUN ID of 0 supposed to be allowed?

yes. for each target, only one associated target with LUN ID of 0 is allowed.

#18 Avatar?id=55038&size=24x24 Updated by Zackary Welch 5 months ago

  • Status changed from Blocked to Passed Testing
  • Needs QA changed from Yes to No

Confirmed removed in 11.2-U3, in both the old and new UI.

#19 Avatar?id=55038&size=24x24 Updated by Zackary Welch 5 months ago

  • Reason for Blocked deleted (Waiting for feedback)

#20 Updated by Dru Lavigne 5 months ago

  • Needs Doc changed from No to Yes

#21 Updated by Timothy Moore II 5 months ago

#22 Updated by Dru Lavigne 5 months ago

  • Status changed from Passed Testing to Done
  • Needs Doc changed from Yes to No

Also available in: Atom PDF