Project

General

Profile

Bug #69211

Can't disable UPS service if ups is unreachable

Added by Sean Vetter 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
Services
Target version:
Severity:
New
Reason for Closing:
Cannot Reproduce
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I have a apc sua2200rm ups plugged into my freenas server via usb. It's been setup like this for years. I needed to use that usb port for a keyboard so I unplugged the UPS. I then got console spam about stale data so I just figured I'll turn off the UPS service in the GUI. Well when you go to shut it off you get service unreachable errors and it can't actually turn off upsd.

You should probably be able to turn off the upsd even if the ups is not connected.

Freenas 11.2-U1

History

#1 Updated by Dru Lavigne 6 months ago

  • Status changed from Unscreened to Blocked
  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Sean: please reproduce then attach a debug (System -> Advanced -> Save debug) to this ticket.

#2 Updated by Sean Vetter 6 months ago

Dru Lavigne wrote:

Sean: please reproduce then attach a debug (System -> Advanced -> Save debug) to this ticket.

False alarm, I can't seem to reproduce the issue. Feel free to close.

UPSD running just fine
root@tubby:~ # ps auxw| grep ups
uucp 2859 0.0 0.0 6748 2840 - Ss 17:48 0:06.39 /usr/local/libexec/nut/usbhid-ups -a apcsmartups
uucp 2861 0.0 0.0 104888 2632 - Ss 17:48 0:01.23 /usr/local/sbin/upsd
uucp 2864 0.0 0.0 6560 2592 - Is 17:48 0:00.06 /usr/local/bin/upslog -s apcsmartups -l /var/log/ups.log -i
root 2867 0.0 0.0 6576 2580 - Is 17:48 0:00.00 /usr/local/sbin/upsmon localhost
uucp 2868 0.0 0.0 6576 2596 - S 17:48 0:00.83 /usr/local/sbin/upsmon localhost
root 35582 0.0 0.0 6704 2676 3 S+ 10:19 0:00.00 grep ups Disconnect ups via unplug usb
an 14 10:19:58 tubby ugen0.3: <American Power Conversion Smart-UPS 2200 RM FW665.6.D USB FW7.4> at usbus0 (disconnected)
Jan 14 10:20:00 tubby upsd2861: Data for UPS [apcsmartups] is stale - check driver
Jan 14 10:20:03 tubby upsmon2868: Poll UPS [apcsmartups] failed - Data stale
Jan 14 10:20:03 tubby upsmon2868: Communications with UPS apcsmartups lost
Jan 14 10:20:08 tubby upsmon2868: Poll UPS [apcsmartups] failed - Data stale
Jan 14 10:20:13 tubby upsmon2868: Poll UPS [apcsmartups] failed - Data stale turned off ups service in freenas Everything seems OK.
root@tubby:~ # ps auxw | grep ups
root 35950 0.0 0.0 6704 2676 3 S+ 10:20 0:00.00 grep ups Tried to start ups with ups disconnected Fails like expected
Jan 14 10:20:35 tubby upsmon2867: upsmon parent: read
Jan 14 10:20:35 tubby upsd2861: mainloop: Interrupted system call
Jan 14 10:21:11 tubby root: /usr/local/etc/rc.d/nut: WARNING: failed precmd routine for nut
Jan 14 10:21:11 tubby upsmon36132: UPS [apcsmartups]: connect failed: Connection failure: Connection refused
Jan 14 10:21:11 tubby upsmon36132: Communications with UPS apcsmartups lost
Jan 14 10:21:16 tubby upsmon36132: UPS [apcsmartups]: connect failed: Connection failure: Connection refused
Jan 14 10:21:16 tubby upsmon36132: UPS apcsmartups is unavailable
Jan 14 10:21:21 tubby upsmon36132: UPS [apcsmartups]: connect failed: Connection failure: Connection refused
Jan 14 10:21:26 tubby upsmon36132: UPS [apcsmartups]: connect failed: Connection failure: Connection refused
Jan 14 10:21:31 tubby upsmon36132: UPS [apcsmartups]: connect failed: Connection failure: Connection refused Plugged in ups and restarted ups
Jan 14 10:21:34 tubby ugen0.3: <American Power Conversion Smart-UPS 2200 RM FW665.6.D USB FW7.4> at usbus0
Jan 14 10:21:34 tubby ums0 on uhub5
Jan 14 10:21:34 tubby ums0: <vendor 0x0557 product 0x2419, class 0/0, rev 1.10/1.00, addr 5> on usbus0
Jan 14 10:21:34 tubby ums0: 3 buttons and [Z] coordinates ID=0
Jan 14 10:21:36 tubby upsmon36132: UPS [apcsmartups]: connect failed: Connection failure: Connection refused
Jan 14 10:21:41 tubby upsmon36132: UPS [apcsmartups]: connect failed: Connection failure: Connection refused
Jan 14 10:21:46 tubby upsmon36132: UPS [apcsmartups]: connect failed: Connection failure: Connection refused

Jan 14 10:21:51 tubby upsmon36132: Communications with UPS apcsmartups established

#3 Updated by Dru Lavigne 6 months ago

  • Status changed from Blocked to Closed
  • Target version changed from Backlog to N/A
  • Private changed from Yes to No
  • Reason for Closing set to Cannot Reproduce
  • Reason for Blocked deleted (Need additional information from Author)

Thanks for the update Sean!

Also available in: Atom PDF