Project

General

Profile

Bug #69562

Fix "unscheduled system reboot" alert after update

Added by Disk Didler almost 3 years ago. Updated over 2 years ago.

Status:
Ready for Testing
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I believe the update process should be writing the "ok.2.reboot.ini" file (whatever method you opted for)

I've got 2 entirely different systems which both told me unsheduled reboot for my server, despite the reboot simply being a requested update.


Related issues

Has duplicate FreeNAS - Bug #83275: FreeNAS complains of unscheduled reboot after updatingClosed
Copied to FreeNAS - Bug #83539: Getting "unscheduled system reboot" still for updates.Done

History

#1 Updated by Dru Lavigne almost 3 years ago

  • Category changed from OS to Middleware
  • Assignee changed from Release Council to William Grzybowski

#2 Updated by William Grzybowski almost 3 years ago

  • Assignee changed from William Grzybowski to Vladimir Vinogradenko
  • Seen in changed from TrueNAS 11.2-U3 to 11.2-RELEASE

Disk can you please attach a Save Debug?

#3 Updated by Disk Didler over 2 years ago

Regardless or when this happens?
You don't release updates too often, so I've rebooted since it occurred.

If you want it regardless, I can send one through for both systems. However I guess this is easily tested on a test machine installing 11.1 or something?

#4 Updated by Bob Paul over 2 years ago

  • File debug-hammer-20190215185026.tgz added
  • File debug-hammer-20190215192651.tgz added

I received this email just now when updating from 11.1-U6 to 11.1-U7. And again when updating from 11.1-U7 to 11.2-RELEASE-U1

I didn't notice it back in Jan, but searching my email it looks like I also received this email when updating our other system from 11.1-U6.3 to 11.2-RELEASE-U1. The secondary system has very little configured as it's basically just there to receive snapshots from the main system.

I rebooted the backup system to the 11.1-U6.3 environment and downloaded a debug (attached). Upgrading that system to 11.1-U7 triggered the email again. I saved a second debug (attached) after 11.1-U7 booted up and emailed about the reboot.

#5 Updated by Disk Didler over 2 years ago

Thanks for the debug Bob, I was gonna ask if you could do it since I forgot. Buy I see you have done it

Thanks

#6 Updated by Vladimir Vinogradenko over 2 years ago

  • Status changed from Unscreened to Screened

#7 Updated by Marco . over 2 years ago

  • Seen in changed from 11.2-RELEASE to 11.2-U2

Can confirm this on a FreeNAS-11.2-U2 system. A reboot caused by a deliberate upgrade is hardly unscheduled.

#8 Updated by Mike Ely over 2 years ago

Happening for us as well.

#9 Updated by Disk Didler over 2 years ago

U2 to minor release U2.1 still doing it.

#10 Updated by William Grzybowski over 2 years ago

  • Target version changed from Backlog to 11.2-U4

#11 Updated by Gavin Penney over 2 years ago

  • File debug-nas1-20190313204750.tgz added
  • File debug-nas2-20190313204810.tgz added

hoping I'm doing this right, there doesn't seem to be any "Reply" button to add an entry?
just updated 2 systems and got the unscheduled reboot email from both. got a debug dump for them, in case it helps

it looks like I also got this for previous updates as well based on emails from dec24/29/30.
nas1 11.1-U6.3 - 11.2-RELEASE-U1
nas1 11.2-RELEASE-U1 - 11.2-U2.1

nas2 11.1-U6 - 11.2-RELEASE
nas2 11.2-RELEASE - 11.2-RELEASE-U1
nas2 11.2-RELEASE-U1 - 11.2-U2.1

#12 Updated by Dru Lavigne over 2 years ago

  • Private changed from No to Yes

#13 Updated by Bug Clerk over 2 years ago

  • Status changed from Screened to In Progress

#14 Updated by Vladimir Vinogradenko over 2 years ago

Acceptance Criteria

Install FreeNAS 11.2-U2, set up e-mail system there.

Update it to 11.2-U2.1.

Wait 11 minutes after system boots after upgrade. You will receive this e-mail.

Update it to 11.2-U3

Wait 11 minutes after system boots after upgrade. You should not receive "unscheduled system reboot" e-mail anymore.

#15 Updated by Dru Lavigne over 2 years ago

  • Has duplicate Bug #83275: FreeNAS complains of unscheduled reboot after updating added

#16 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-hammer-20190215185026.tgz)

#17 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-hammer-20190215192651.tgz)

#18 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-nas1-20190313204750.tgz)

#19 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-nas2-20190313204810.tgz)

#20 Updated by Dru Lavigne over 2 years ago

  • Private changed from Yes to No

#21 Updated by Bug Clerk over 2 years ago

  • Copied to Bug #83539: Getting "unscheduled system reboot" still for updates. added

#22 Updated by Bug Clerk over 2 years ago

  • Status changed from In Progress to Ready for Testing

#23 Updated by Dru Lavigne over 2 years ago

  • Subject changed from Getting "unscheduled system reboot" still for updates. to Fix "unscheduled system reboot" alert after update
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

Also available in: Atom PDF