Project

General

Profile

Bug #69589

Can not replicate pool on local

Added by Song Zou 2 months ago. Updated 2 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I have two pools created and just want to copy the data from one to another, I make sure there is no snap on source pool and use the command to create the snap: zfs snapshot -r PinkTank@PP4

The destination pool is empty and run the command to replicate: zfs send -Rv PinkTank@PP4 | zfs recv -F PurpleTank

It started and eventually prompt the error :

cannot receive new filesystem stream: destination has snapshots (eg. PurpleTank/iocage@PP4)

I never snap the PurpleTank, how it shows "destination has snapshots (eg. PurpleTank/iocage@PP4)"?

Please fix this basic bug ASAP

thx

History

#1 Updated by Dru Lavigne 2 months ago

  • Category changed from Build system to Middleware
  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue

Song: closing this ticket as it is not a bug, but more likely a usage syntax error. I notice that noone has responded to your forum post, but there should be other forum posts on how to replicate to a local pool as it has been discussed on the forums before.

Also available in: Atom PDF