Project

General

Profile

Bug #69616

Editing an Init or Shutdown script in the GUI renders it inoperable

Added by Shawn Brenneman 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Steps to reproduce:

1. Create a test script somewhere. Mine was

#!/bin/bash
echo `date` >> /mnt/tank/some/logfile.txt

2. From the GUI: Tasks > Init/Shutdown Scripts, Add

Type: Script
Script: <select script file above>
When: Post Init
Enabled: true

3. You can estart to verify that it works, it's not a very exciting script.

4. Back in the GUI, open the edit script page. Re-select all of the same options.

Expected result:

The script should keep working.

Actual result:

The script no longer works.
Seemingly related, on the script overview page, the values for "Type" and "When" are now listed as all-uppercase values, SCRIPT and POSTINIT. (See screenshot)

The same thing appears to happen with SHUTDOWN scripts.

modified-init-script.png (45.5 KB) modified-init-script.png Init scripts after modifying the top script: note that the values are now uppercased. Shawn Brenneman, 01/12/2019 09:20 PM
48574

Related issues

Is duplicate of FreeNAS - Bug #60936: Fix bug in Init/Shutdown scripts create and edit modesDone

History

#1 Updated by Shawn Brenneman 7 months ago

It looks like my searching wasn't thorough enough, and that this is likely a duplicate of bug #60936.

#2 Updated by Dru Lavigne 7 months ago

  • Is duplicate of Bug #60936: Fix bug in Init/Shutdown scripts create and edit modes added

#3 Updated by Dru Lavigne 7 months ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue

Shawn: this should be fixed on the related ticket for U2 (due out in a few weeks). Please leave a comment on this ticket should the issue persist for you after updating to that version once it is available.

Also available in: Atom PDF