Project

General

Profile

Bug #6967

Mount "failed with error 2" after install.

Added by Joe Miller almost 6 years ago. Updated about 3 years ago.

Status:
Closed: Duplicate
Priority:
Nice to have
Assignee:
Josh Paetzel
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I put together a new Supermicro system today with 16GB RAM. I was able to install 9.3 to USB. However, it fails to boot. The error is: "Mounting from zfs:freenas-boot/ROOT/default failed with error 2."

History

#1 Updated by Joe Miller almost 6 years ago

UPDATE: I had moved the USB to a USB3 port. Moving it back to a USB2 port allowed it to boot properly.

I'm not sure if this is a bug or if not being able to boot from USB3 is an expected behavior?

#2 Updated by Jordan Hubbard almost 6 years ago

  • Status changed from Unscreened to Closed: Behaves correctly

Yep, USB 3.0 is disabled in FreeNAS due to interoperability problems with FreeBSD.

#3 Updated by Brandon Miller almost 6 years ago

Hi, I to am having this error. ThinkServer 140. I have a 4gb installer USB drive with 9.3 Stable installed. I load up the installer and install to a 8gb USB drive. I can get the server to boot no problem with both USB drives plugged in, but once I pull out the installer (4gb) drive I get the error Joe Miller points out. I have swapped USB ports. There are only 2 USB ports on the 140, as the rest are USB 3.

#4 Updated by Sean Fagan almost 6 years ago

Are you saying that you can boot into the installer, and install onto the second thumb drive, but that when you pull out the installation thumb drive, it does not complete booting?

Or are you saying that it does boot properly if you have both thumb drives in?

#5 Updated by Brandon Miller almost 6 years ago

The former Sean. As soon as I remove the install USB stick it gives me the error above. Thank you for the assistance on this! I choose the 8gb USB drive as the boot priority, and it appears to start fine, but hangs at the error.

#6 Updated by Sean Fagan almost 6 years ago

I'm stymied here, then. ENOENT is a strange error to get in this case.

Do you get the grub menu when you install? If so, can you: press enter to select the default boot, and then select single user mode?

If that works, we can try some more troubleshooting.

#7 Updated by Brandon Miller almost 6 years ago

Correct Sean, I am able to boot the Grub Menu then select default boot. After selecting default, I get the error. Am I to select single user mode? I have default, singleuser mode and verbose.

#8 Updated by Sean Fagan almost 6 years ago

When you select the default (it should be the only boot environment option for you at this point), you should then get a screen with three options -- "Normal Bootup", "Single User Mode", and "Verbose Mode". These will only come up if you select it before the boot from the grub menu before the timer counts down to 0.

If you get the first grub menu, but can't get to the second level, that means the grub.cfg file is corrupt, which would also, I think, explain the mount failure later on. But let's make sure that is what's going on -- so let's make sure you can, or can not, get to the second level menus. Thanks!

#9 Updated by Brandon Miller almost 6 years ago

I get to the second level. I'm sorry I used the wrong term "default" instead of "normal". I'm not at my house right now, currently at work. I get to the 2nd screen no problem. What else can I try to troubleshoot at this time?

Thanks again for the assistance Sean.

#10 Updated by Sean Fagan almost 6 years ago

As I said, try booting to single user mode from the menu.

That may not work, however. What I would want from you at that point would be the grub.cfg file, which is going to be tricky to get to.

#11 Updated by Brandon Miller almost 6 years ago

Roger that, Sean. I'll get that to you tonight when I get home. thank you!

#12 Updated by Albino Toad almost 6 years ago

I had the same issue when installing 9.3 from USB 2.0 to USB 2.0 on an HP Gen 7 Microserver and was able to resolved it by cleaning target USB key using gdisk. Odd, I usually run the clean disk command from Diskpart in Windows. I'm not saying this is the only method of resolving this but it worked for me.

Please see.

https://forums.freenas.org/index.php?threads/mountroot-assistance-needed.25411/

Well... this only worked from the external USB port in the front. The internal one still gives the message......

#13 Updated by Albino Toad over 5 years ago

But manual mount with path that it can't find the works. Mount Root> zfs:freenas-boot/ROOT/default
Also, if I switch it back to the external USB port it will work also.

#14 Updated by Brandon Miller over 5 years ago

Thank you, Sean and Albino Toad for the help. I was able to get everything up and running. I created a dvd boot disk and installed to a usb key. I had a feeling perhaps my USB drive was partitioned funny and gdisk was needed.

Thanks for the help gents and Merry Christmas!

#15 Updated by Idont Say over 5 years ago

I run into the same error after a fresh installation.

I could fix it by just creating a new partition table on the target USB device with gparted, format to fat32 and installing freeNAS again

#16 Updated by damian stewart over 5 years ago

Having the same error here. A second or two after the manual mount prompt shows up I get log messages showing that da0 has been registered - seems just like the mount root needs to wait a few seconds more?

As with Albino Toad, manually entering zfs:freenas-boot/ROOT/default at the prompt boots successfully.

#17 Updated by Joe Miller over 5 years ago

It sounds like others are having issues different than mine. But, if you're having a USB2 vs USB3 issue, this is the solution I found:

Install with the drive plugged into a USB2 port.
Boot up the server and add a tunable: "xhci_load" with the value "YES".
Shut down and switch drive to the USB3 port.
It should now boot from there without this error.

More info here: http://doc.freenas.org/9.3/freenas_intro.html?highlight=usb#compact-or-usb-flash

#18 Updated by Josh Paetzel over 5 years ago

  • Status changed from Closed: Behaves correctly to Closed: Duplicate
  • Assignee set to Josh Paetzel
  • Target version set to Unspecified

This was fixed in an SU update last weekend. Please update your system.

The boot now waits for 30 seconds for the root device to appear if it isn't available when it tries to mount root.

See ticket 7254 for the commit and more details. (My phone won't let me link them)

#19 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Category set to 129
  • Target version changed from Unspecified to N/A
  • Seen in changed from 9.3-BETA to N/A

Also available in: Atom PDF