Project

General

Profile

Bug #6972

After Upgrade from 9.2.1.9 to 9.3 Beta jails don't autostart anymore

Added by luke roth almost 6 years ago. Updated about 3 years ago.

Status:
Closed: Duplicate
Priority:
Nice to have
Assignee:
John Hixson
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After gui upgrade from FreeNAS-9.3-BETA-201412050249.GUI_Upgrade.txz and being on release FreeNAS-9.3-BETA-201412060221.GUI_Upgrade.txz now caused my jails to don't autostart anymore.
Manually they start fine. The workaround from Bug #6617 doesn't work in my case.

warden list -v.rtf (2.47 KB) warden list -v.rtf luke roth, 12/06/2014 11:19 PM

Related issues

Has duplicate FreeNAS - Bug #7166: Jails do not autostart Closed: Duplicate2014-12-16

History

#1 Updated by Jordan Hubbard almost 6 years ago

  • Category set to 38
  • Assignee set to John Hixson
  • Target version set to 9.3-RELEASE

#2 Updated by John Hixson almost 6 years ago

  • Status changed from Unscreened to Screened

#3 Updated by John Hixson almost 6 years ago

When you reboot, can you go do a "warden list -v" from the command line and post the output here?

#4 Updated by luke roth almost 6 years ago

Done, in the meantime i will try to install the latest iso, maybe that does the trick...

1 hour later.....installed latest iso and loaded latest still working config. That didn't help, same issue

#5 Updated by luke roth almost 6 years ago

Maybe good to now. I deleted the plugin firefly and installed it afterwards again. With the jail template from the url http://cdn.freenas.org/jails/9.3/x64. Same issue, no autostart.

#6 Updated by luke roth almost 6 years ago

Same behavior in this case as in Bug #6998. all of them don't get an ip with dhcp enabled.

#7 Updated by John Hixson almost 6 years ago

Do you see any errors while the system is booting ?

#8 Updated by luke roth almost 6 years ago

I'm afraid not, no obvious error messages. I don't know what to look for though. Shouldn't, after the decryption of the pool pop up some kind of jail start command? Well, at leaset i don't see anything like this.....

#9 Updated by John Hixson almost 6 years ago

  • Target version changed from 9.3-RELEASE to Unspecified

ok. I did not realize this was happening on an encrypted pool. I believe there is a bug open regarding this already. Either way, this isn't a release blocker, so I'm moving the target.

#10 Updated by John Lucas almost 6 years ago

Hi,

I also have problems with the jails. They will not start at all, auto or manually.

My setup is:
- one volume, not encrypted for jails root and system data.
- one encrypted volume, for my data.

I had 9.2.1.8, and the jails worked fine. I upgraded to 9.3 nightly from 2014.12.05 (I don't remember the revision).
After the upgrade the jails would not start.
I saved the config and installed a clean os from iso; restored the config.
Nothing was changed.
I have deleted and created the jails many times; same problem.

I have upgraded to 9.3 RELEASE and the problem is not fixed.

The jails that I tried are: transmission, owncloud and plex media server.

@
nas# warden list -v

id: 1
host: transmission_1
iface:
ipv4: 192.168.10.204/16
alias-ipv4:
bridge-ipv4:
alias-bridge-ipv4:
defaultrouter-ipv4:
ipv6:
alias-ipv6:
bridge-ipv6:
alias-bridge-ipv6:
defaultrouter-ipv6:
autostart: Enabled
vnet: Enabled
nat: Disabled
mac: 02:fc:a9:00:06:0b
status: Running
type: pluginjail
flags: allow.raw_sockets=true

nas# warden start transmission_1
Mounting user-supplied file-systems
jail -c path=/mnt/Data/Jails/transmission_1 name=transmission_1 host.hostname=transmission_1 allow.raw_sockets=true persist vnet=new
jexec: jail "ifconfig" not found
Setting IPv4 address: 192.168.10.204/16
inet6_enable: YES -> YES
ip6addrctl_enable: YES -> YES
add net default: gateway 192.168.10.1
Starting jail with: /etc/rc
jexec 4 /usr/pbi/transmission-amd64/control start 192.168.10.204 12346

nas# ps ax
PID TT STAT TIME COMMAND
0 ?? DLs 11:19.91 [kernel]
1 ?? ILs 0:00.07 /sbin/init --
2 ?? DL 0:00.00 [crypto]
3 ?? DL 0:00.00 [crypto returns]
4 ?? DL 0:00.01 [ctl]
5 ?? DL 0:00.00 [mpt_recovery0]
6 ?? DL 0:11.31 [zfskern]
7 ?? DL 0:00.00 [xpt_thrd]
8 ?? DL 0:00.03 [pagedaemon]
9 ?? DL 0:00.00 [vmdaemon]
10 ?? DL 0:00.00 [audit]
11 ?? RL 1995:49.63 [idle]
12 ?? WL 11:05.01 [intr]
13 ?? DL 0:00.00 [ng_queue]
14 ?? DL 0:19.40 [geom]
15 ?? DL 0:01.76 [yarrow]
16 ?? DL 0:00.00 [pagezero]
17 ?? DL 0:00.14 [bufdaemon]
18 ?? DL 0:00.15 [vnlru]
19 ?? DL 0:03.90 [syncer]
20 ?? DL 0:00.19 [softdepflush]
208 ?? DL 0:00.00 [g_mp_kt]
855 ?? DL 0:00.00 [ftcleanup]
1540 ?? Ss 0:00.02 /sbin/devd
1887 ?? I 0:00.00 /usr/local/sbin/syslog-ng -p /var/run/syslog.pid
1888 ?? Ss 0:05.64 /usr/local/sbin/syslog-ng -p /var/run/syslog.pid
1919 ?? DL 0:00.00 [g_eli0 vtbd1p1]
1920 ?? DL 0:00.00 [g_eli1 vtbd1p1]
1921 ?? DL 0:00.00 [g_eli2 vtbd1p1]
1922 ?? DL 0:00.00 [g_eli3 vtbd1p1]
2020 ?? DL 0:00.00 [Timer]
2301 ?? Ss 0:01.31 /usr/sbin/ntpd -g -c /etc/ntp.conf -p /var/run/ntpd.pid -f /var/db/ntpd.drift
2469 ?? Ss 0:00.55 proftpd: (accepting connections) (proftpd)
2556 ?? Ss 0:00.31 /usr/local/sbin/nmbd --daemon --configfile=/usr/local/etc/smb4.conf
2559 ?? Ss 0:00.62 /usr/local/sbin/smbd --daemon --configfile=/usr/local/etc/smb4.conf
2562 ?? Is 0:00.02 /usr/local/sbin/winbindd --daemon --configfile=/usr/local/etc/smb4.conf
2567 ?? S 0:00.07 /usr/local/sbin/winbindd --daemon --configfile=/usr/local/etc/smb4.conf
2711 ?? I 3:09.61 /usr/local/bin/python -R /usr/local/www/freenasUI/manage.py runfcgi method=threaded host=127.0.0.1 port=9042 pidfile=/var/run/django.pid (python2.7)
2823 ?? Is 0:00.00 nginx: master process /usr/local/sbin/nginx
2842 ?? Is 0:00.15 /usr/local/sbin/mdnsd
2846 ?? I 0:00.72 /usr/local/sbin/netatalk
2861 ?? I 0:00.16 /usr/local/sbin/afpd -d -F /usr/local/etc/afp.conf
2862 ?? I 0:00.00 /usr/local/sbin/cnid_metad -d -F /usr/local/etc/afp.conf
2886 ?? Is 0:00.00 /usr/local/bin/dbus-daemon --system
3087 ?? Is 0:00.00 /usr/sbin/sshd
3172 ?? Is 0:00.00 daemon: /usr/local/libexec/nas/register_mdns.py35087 (daemon)
5250 ?? Is 0:00.15 /usr/sbin/cron -s
19710 ?? Ss 0:37.74 /usr/local/sbin/collectd
35085 ?? S 0:02.54 nginx: worker process (nginx)
35087 ?? I 0:01.00 /usr/local/bin/python /usr/local/libexec/nas/register_mdns.py (python2.7)
47912 ?? Ss 0:00.18 sshd: root@pts/0,pts/1 (sshd)
53097 ?? IN 0:00.07 /bin/sh /usr/local/sbin/pbid
58016 ?? IN 0:00.00 sleep 300
60264 ?? SsJ 0:00.00 /usr/sbin/syslogd -s
60319 ?? IsJ 0:00.00 /usr/sbin/cron -s
60543 ?? IJ 0:00.60 /usr/pbi/transmission-amd64/bin/python2.7 /usr/pbi/transmission-amd64/control.py start 192.168.10.204 12346
5408 v0 Is+ 0:00.90 python /etc/netcli (python2.7)
5409 v1 Is+ 0:00.00 /usr/libexec/getty Pc ttyv1
5410 v2 Is+ 0:00.00 /usr/libexec/getty Pc ttyv2
5411 v3 Is+ 0:00.00 /usr/libexec/getty Pc ttyv3
5412 v4 Is+ 0:00.00 /usr/libexec/getty Pc ttyv4
5413 v5 Is+ 0:00.00 /usr/libexec/getty Pc ttyv5
5414 v6 Is+ 0:00.00 /usr/libexec/getty Pc ttyv6
5415 v7 Is+ 0:00.00 /usr/libexec/getty Pc ttyv7
47914 0 Is 0:00.01 -bash (bash)
47970 0 I+ 0:00.00 tail -f /var/log/messages
55273 1 Ss 0:00.05 -bash (bash)
60645 1 R+ 0:00.00 ps ax

nas# warden stop transmission_1
jexec 4 /usr/pbi/transmission-amd64/control stop
Stoppingthejail....192.168.10.204 (192.168.10.204) deleted
Stopping jail with: /etc/rc.shutdown
.Terminating on signal 15
..Done
@

Thank you.

EDIT:
I forgot: the installed plugins are not displayed in the left tree.
In the log this message is found:
nas manage.py: [plugins.utils:92] Couldn't retrieve http://192.168.10.3/plugins/transmission/1/_s/status: No JSON object could be decoded

My problem can be related to this bug: https://bugs.freenas.org/issues/6641.
I'm running the os under qemu with storage controller passthrough and the network card is virtio.

#11 Updated by Alex Mad almost 6 years ago

Hello,

I also have problems with the jails.
First i upgraded from 9.2.1.7 to 9.3-STABLE, and installed plugins worked fine. But i cannot start a new one. Then I checked for updates in GUI and performed an update. After that all plugins falls in trouble. Rollback did not helped.
They does not starts or stops at all, auto or manually. No errors in logs when starting or stoping a plugin.
The plugins that was started and configured earlier are up and running (with no possibility to stop them).
All of the installed plugins are not displayed in the left tree. So there is no possibility to configure them.
In the log messages like this is found:
Dec 10 13:18:02 nas01 manage.py: [freeadmin.navtree:599] An error occurred while unserializing from https://[XXXX:1::241]/plugins/xdm/6/_s/treemenu: No JSON object could be decoded
This XDM plugin is up and runnig, but i cannot stop it.

#12 Updated by chu rnd almost 6 years ago

Add me to the list of people affected by this:

Dec 10 09:29:09 FreeNAS manage.py: [freeadmin.navtree:545] Couldn't retrieve http://192.168.1.30/plugins/couchpotato/1/_s/treemenu: timed out
Dec 10 09:31:40 FreeNAS manage.py: [plugins.utils:92] Couldn't retrieve http://192.168.1.30/plugins/couchpotato/1/_s/status: No JSON object could be decoded

Using proxmox with storage controller passthrough to FreeNAS VM & the VM network card is virtio. Seems to be related to bug 6641.

#13 Updated by Alex Mad almost 6 years ago

It seems to be an ipv6 jail connectivity issue in my case.
Here is the error message from my freenas (example)
https://[XXXX:1::241]/plugins/transmission/8/_s/treemenu

When i am clicking this link it shows me an error

URLError at /plugins/transmission/8/_s/treemenu
<urlopen error [Errno 50] Network is down>

Request Method: GET
Request URL: https://[XXXX:1::241]/plugins/transmission/8/_s/treemenu
Django Version: 1.6.1
Exception Type: URLError
Exception Value:

<urlopen error [Errno 50] Network is down>

Exception Location: /usr/pbi/transmission-amd64/lib/python2.7/urllib2.py in do_open, line 1184
Python Executable: /usr/pbi/transmission-amd64/bin/python2.7
Python Version: 2.7.6

....ommited

I am trying to run dual stack (ipv4/ipv6) on my FreeNAS.

XXXX:1::241 - is an IPv6 address of FreeNAS gui
XXXX:1::201 - is an IPv6 address of transmission jail

There ara 2 issues.
1. I configured XXXX:1:1::201/64 for a jail manualy, but after a startup i have no ipv6 connectivity from inside of a jail. Ipv6 address is on an interface but

root@transmission_1:/ # ifconfig
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
inet 127.0.0.1 netmask 0xff000000
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
epair0b: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 02:14:4a:00:10:0b
inet 172.24.100.201 netmask 0xffffff00 broadcast 172.24.100.255
inet6 XXXX:1::201 prefixlen 64
nd6 options=9<PERFORMNUD,IFDISABLED>
media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
status: active

I have to execute a command ifconfig epair0b inet6 XXXX:1:1::201 prefixlen 64 to get an ipv6 connectivity. After that i can reach Ipv6 network (facebook.com for example).
And
root@transmission_1:/ # ifconfig
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
inet 127.0.0.1 netmask 0xff000000
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
epair0b: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 02:14:4a:00:10:0b
inet 172.24.100.201 netmask 0xffffff00 broadcast 172.24.100.255
inet6 XXXX:1::201 prefixlen 64
nd6 options=1<PERFORMNUD>
media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
status: active

2. I have no Ipv6 connectivity between XXXX:1::241 (freenas) and XXXX:1::201 (jail). There is ipv4 connectivity between them and ip4/6 connectivity to other networks, but not IPv6 connectivity to each other

So i think that when we fix this we probably will be able to control plugins via gui.

UPD. That is an IPv6 issue. When i deleted an ipv6 config from freenas interface (lagg0 in my case) and reloaded a box i could configure a plugins and start/stop them? but IPv6 in jails is still not operational.
After configuring IPv6 addrees on freenas (lagg0) i loose ability to configure plugins and control them (with the same errors in log)

#14 Updated by Jordan Hubbard almost 6 years ago

  • Has duplicate Bug #7166: Jails do not autostart added

#15 Updated by John Hixson over 5 years ago

This ticket is the same as #7155. Jails don't start automagically after unlocking a pool. See that ticket for minimal description as to why.

#16 Updated by John Hixson over 5 years ago

  • Status changed from Screened to Closed: Duplicate

#17 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from Unspecified to N/A

Also available in: Atom PDF