Project

General

Profile

Bug #69933

Fix key error for NFS exports paths

Added by Stephen Cunningham 9 months ago. Updated 7 months ago.

Status:
Done
Priority:
No priority
Assignee:
Andrew Walker
Category:
Services
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

This showed up a few days ago in the nightlies. I can connect to Freenas but the shares are not displayed. I cannot access a share directly.

History

#1 Updated by Stephen Cunningham 9 months ago

  • File debug-freenas-20190114191553.txz added
  • Private changed from No to Yes

#2 Updated by Stephen Cunningham 9 months ago

  • Seen in changed from Unspecified to Master - FreeNAS Nightlies

#3 Updated by Stephen Cunningham 9 months ago

  • Status changed from Unscreened to Closed

seen in FreeNAS-11.3-MASTER-201901140913.

To reproduce add smb share and enable smb. 
Smb share is confirmed accessible. 
Reboot freenas smb share is still accessible. 
Add nfs share reboot freenas. 
Smb share is NOT accessible. 
Delete nfs share and reboot freenas.
Smb share is accessible. 

#4 Updated by Stephen Cunningham 9 months ago

  • Subject changed from Smb shares not reachable on client to Smb shares not reachable on client after NFS share is added

#5 Updated by Stephen Cunningham 9 months ago

please reopen this is still an active issue

#6 Updated by Dru Lavigne 9 months ago

  • Status changed from Closed to Unscreened
  • Assignee changed from Release Council to William Grzybowski

#7 Updated by William Grzybowski 9 months ago

  • Assignee changed from William Grzybowski to Andrew Walker

#9 Updated by Andrew Walker 9 months ago

  • File smb4_share.conf added

I think this is a side-effect of a breakage I introduced. Try replacing /usr/local/lib/python3.7/site-packages/middlewared/etc_files/local/smb4_share.conf with attached and the issue "midclt call etc.generate smb_share".

Issue is tracked here: https://github.com/freenas/freenas/pull/2400

#10 Updated by Andrew Walker 9 months ago

  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#11 Updated by Dru Lavigne 9 months ago

  • File deleted (debug-freenas-20190114191553.txz)

#12 Updated by Dru Lavigne 9 months ago

  • File deleted (smb4_share.conf)

#13 Updated by Dru Lavigne 9 months ago

  • Subject changed from Smb shares not reachable on client after NFS share is added to Fix key error for NFS exports paths
  • Status changed from Unscreened to Ready for Testing
  • Target version changed from Backlog to 11.3-BETA1
  • Private changed from Yes to No

#14 Updated by Stephen Cunningham 9 months ago

This seems to be fixed now with a nightly update

#15 Updated by Dru Lavigne 8 months ago

  • Status changed from Ready for Testing to Done
  • Needs QA changed from Yes to No

#16 Updated by Dru Lavigne 7 months ago

  • Target version changed from 11.3-BETA1 to 11.3-ALPHA1

Also available in: Atom PDF