Project

General

Profile

Bug #6999

Djanpo pid not found when restarting nginx

Added by Dr K K almost 7 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
No priority
Assignee:
Suraj Ravichandran
Category:
GUI (new)
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Changed the web GUI mode from http only to https only. Everything starts up fine, but there is the following odd message that appears in the /var/log/messages when it attempts to restart the nginx daemon:


Dec  8 00:47:31 freenas notifier: nginx: the configuration file /usr/local/etc/n
ginx/nginx.conf syntax is ok                                                    
Dec  8 00:47:31 freenas notifier: nginx: configuration file /usr/local/etc/nginx
/nginx.conf test is successful                                                  
Dec  8 00:47:31 freenas notifier: Stopping nginx.                               
Dec  8 00:47:32 freenas notifier: Waiting for PIDS: 4666.                       
Dec  8 00:47:32 freenas notifier: Performing sanity check on nginx configuration
:                                                                               
Dec  8 00:47:32 freenas notifier: nginx: the configuration file /usr/local/etc/n
ginx/nginx.conf syntax is ok                                                    
Dec  8 00:47:32 freenas notifier: nginx: configuration file /usr/local/etc/nginx
/nginx.conf test is successful                                                  
Dec  8 00:47:32 freenas notifier: Starting nginx.                               
Dec  8 00:47:32 freenas notifier: cat: /var/run/django.pid: No such file or dire
ctory                                                                           
Dec  8 00:47:32 freenas notifier: usage: kill [-s signal_name] pid ...          
Dec  8 00:47:32 freenas notifier:        kill -l [exit_status]                  
Dec  8 00:47:32 freenas notifier:        kill -signal_name pid ...              
Dec  8 00:47:32 freenas notifier:        kill -signal_number pid ...            
[root@freenas ~]#                                                              

I had done this http changeover to https in previous 9.3 beta versions, and I know I didn't get this notification. It looks like it's trying to kill a django pid that's already been killed...?

Note: Everyone DOES appear to start up correctly with respect to nginx, python, and django. So whatever the problem is, it's not causing any issue that I can see, except the error in the log.

Associated revisions

Revision 6f30f50c (diff)
Added by Suraj Ravichandran almost 7 years ago

Add a custom function for restarting django (now that we use the rc.d verb 'restart' for django). The default midlleware/notifier.py method first issues a service blah forcestop and subsequently issues a service blah restart. This resulted in a django.pid not found message to be logged to syslog /var/log/messages each time, thus overiding that. Ticket: #6999

History

#1 Updated by Jordan Hubbard almost 7 years ago

  • Assignee set to Suraj Ravichandran

#2 Updated by Alexander Motin almost 7 years ago

  • Status changed from Unscreened to Resolved

Changing on Suraj request.

#3 Updated by Dru Lavigne almost 4 years ago

  • Target version set to Master - FreeNAS Nightlies

Also available in: Atom PDF