Project

General

Profile

Bug #70426

Adjust size of entity tables in new UI

Added by Dennis Mullen almost 3 years ago. Updated over 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Dennis Mullen
Category:
GUI (new)
Target version:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

ACCEPTANCE CRITERIA
Check some regular entity tables (Accounts/User, Accounts/Groups) and the ones with extra stuff at the top - Jails, Plugin-available, Boot Env. Assuming the tables have sufficient rows, the table should display pretty much to the bottom of the screen, with no more empty space than a row height plus a little more for margin.

ORIGINAL POST
Some entity tables are too short because their height was set before the nice UI update - especially Users, Jails, Plugins (available and used).

History

#1 Updated by Dennis Mullen almost 3 years ago

  • Target version changed from Backlog to 11.2-U3

11.2 STABLE: https://github.com/freenas/webui/pull/1785
MASTER - https://github.com/freenas/webui/pull/1788

Testing: Look at any entity tables, but especially Jails, Plugins (available and installed), Boot Environments, Users. If there are lots of rows, table should go nearly to the bottom of the screen if browser is at full height. A row-sized empty space is about all there should be. The tables are also supposed to get shorter (about two rows less than max size) if you shorten the height of the browser.

#2 Updated by Anonymous almost 3 years ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#3 Updated by Dru Lavigne almost 3 years ago

  • Subject changed from Some tables have too few rows for the screen size to Adjust size of entity tables in new UI
  • Needs Doc changed from Yes to No

#4 Updated by Dennis Mullen over 2 years ago

  • Description updated (diff)

#7 Avatar?id=55038&size=24x24 Updated by Zackary Welch over 2 years ago

  • Status changed from Ready for Testing to Passed Testing

Confirmed fixed in U3.

#9 Updated by Dru Lavigne over 2 years ago

  • Status changed from Passed Testing to Done
  • Needs QA changed from Yes to No

Also available in: Atom PDF