Project

General

Profile

Bug #7045

Plex PBI not transcoding mkv's post upgrade to 9.3 release

Added by Joshua Johnson almost 6 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
John Hixson
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

So I upgrade to 9.3 release last night with no issues but now I get a "could not play error" for now determined to be mkv's files which played prior to upgrade with no issues. I understand this may be a plugin issue and not a FreeNAS issue, but from the log output I wanted to check if something had changed blocking access to using 127.x.x.x now in 9.3 that could be causing this and what is a workaround for me to test.
This is the Plex Server Log Output from the attempt. I see it repeated several times. Did something change in FreeNas 9.3 to block access to local ip?
*Currently FreeNAS available PBI's are not showing up in FreeNAS to see if there is a PBI plugin upgrade.

FreeNas version FreeNAS-9.3-STABLE-201412090314
Plex PBI version plexmediaserver-0.9.11.1.678-amd64

Dec 09, 2014 09:35:35 [0x808cd4000] DEBUG - Request: [10.1.10.209:49122] GET /photo/:/transcode?url=http%3A%2F%2F127.0.0.1%3A32400%2Flibrary%2Fmetadata%2F84728%2Fthumb%2F1418103038%3FX-Plex-Token%3DbWrj9DpPwTELMNhQ9TGA&width=214&height=306&format=jpeg&background=1f1f1f&X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&X-Plex-Token=bWrj9DpPwTELMNhQ9TGA (5 live)
Dec 09, 2014 09:35:35 [0x808cd4000] DEBUG - * url => http://127.0.0.1:32400/library/metadata/84728/thumb/1418103038?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx
Dec 09, 2014 09:35:35 [0x808cd4000] DEBUG - * width => 214
Dec 09, 2014 09:35:35 [0x808cd4000] DEBUG - * height => 306
Dec 09, 2014 09:35:35 [0x808cd4000] DEBUG - * format => jpeg
Dec 09, 2014 09:35:35 [0x808cd4000] DEBUG - * background => 1f1f1f
Dec 09, 2014 09:35:35 [0x808cd4000] DEBUG - * X-Plex-Token => xxxxxxxxxxxxxxxxxxxx
Dec 09, 2014 09:35:35 [0x808cd4000] DEBUG - * X-Plex-Token => xxxxxxxxxxxxxxxxxxxx
Dec 09, 2014 09:35:35 [0x808cd4000] DEBUG - We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
Dec 09, 2014 09:35:35 [0x808cd4000] DEBUG - Came in with a super-token, authorization succeeded.
Dec 09, 2014 09:35:35 [0x808cd4000] DEBUG - Photo transcoder: Request for url [http://127.0.0.1:32400/library/metadata/84728/thumb/1418103038?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx] (is local: 0 upscaled: 0)
Dec 09, 2014 09:35:35 [0x808cd4000] DEBUG - HTTP requesting to: http://127.0.0.1:32400/library/metadata/84728/thumb/1418103038?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx
Dec 09, 2014 09:35:35 [0x808cd4000] ERROR - Error issuing curl_easy_perform(handle): 7
Dec 09, 2014 09:35:35 [0x808cd4000] WARN - Error issuing request to: http://127.0.0.1:32400/library/metadata/84728/thumb/1418103038?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx (7, Couldn't connect to server) (Failed to connect to 127.0.0.1: Can't assign requested address)
Dec 09, 2014 09:35:35 [0x808cdbc00] DEBUG - Request: [10.1.10.209:49123] GET /photo/:/transcode?url=http%3A%2F%2F127.0.0.1%3A32400%2Flibrary%2Fmetadata%2F84728%2Fthumb%2F1418103038%3FX-Plex-Token%3DbWrj9DpPwTELMNhQ9TGA&width=214&height=306&format=jpeg&background=1f1f1f&X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&X-Plex-Token=bWrj9DpPwTELMNhQ9TGA (5 live)
Dec 09, 2014 09:35:35 [0x808cdbc00] DEBUG - * url => http://127.0.0.1:32400/library/metadata/84728/thumb/1418103038?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx
Dec 09, 2014 09:35:35 [0x808cdbc00] DEBUG - * width => 214
Dec 09, 2014 09:35:35 [0x808cdbc00] DEBUG - * height => 306
Dec 09, 2014 09:35:35 [0x808cdbc00] DEBUG - * format => jpeg
Dec 09, 2014 09:35:35 [0x808cdbc00] DEBUG - * background => 1f1f1f
Dec 09, 2014 09:35:35 [0x808cdbc00] DEBUG - * X-Plex-Token => xxxxxxxxxxxxxxxxxxxx
Dec 09, 2014 09:35:35 [0x808cdbc00] DEBUG - * X-Plex-Token => xxxxxxxxxxxxxxxxxxxx
Dec 09, 2014 09:35:35 [0x808cdbc00] DEBUG - We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
Dec 09, 2014 09:35:35 [0x808cdbc00] DEBUG - Came in with a super-token, authorization succeeded.
Dec 09, 2014 09:35:35 [0x808cdbc00] DEBUG - Photo transcoder: Request for url [http://127.0.0.1:32400/library/metadata/84728/thumb/1418103038?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx] (is local: 0 upscaled: 0)
Dec 09, 2014 09:35:35 [0x808cdbc00] DEBUG - HTTP requesting to: http://127.0.0.1:32400/library/metadata/84728/thumb/1418103038?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx
Dec 09, 2014 09:35:35 [0x808cdbc00] ERROR - Error issuing curl_easy_perform(handle): 7
Dec 09, 2014 09:35:35 [0x808cdbc00] WARN - Error issuing request to: http://127.0.0.1:32400/library/metadata/84728/thumb/1418103038?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx (7, Couldn't connect to server) (Failed to connect to 127.0.0.1: Can't assign requested address)

Screen Shot 2014-12-09 at 3.08.51 PM.png (183 KB) Screen Shot 2014-12-09 at 3.08.51 PM.png Working plugins UI Jordan Hubbard, 12/09/2014 03:06 PM
1661

Associated revisions

Revision dd0e94a0 (diff)
Added by John Hixson over 5 years ago

Have a jail ID before running jail commands Ticket: #7045

Revision cdeec45e (diff)
Added by John Hixson over 5 years ago

Have a jail ID before running jail commands Ticket: #7045

History

#1 Updated by Sean Fagan almost 6 years ago

  • Assignee changed from Sean Fagan to Jordan Hubbard

I don't know anything about plex, unfortunately, even though I use it. I will try to remember to test tonight when I get home.

Jordan, I don't know wha to do about this.

#2 Updated by Jordan Hubbard almost 6 years ago

  • Status changed from Unscreened to 15

We did a fairly major upgrade to the Plex server right around the same time. Perhaps they disabled support for these things? I am still able to play audio files and movies from my 9.3-RELEASE/plex instances (multiple ones), so this certainly suggests that the plex plugin still works from our perspective (at least, inasmuch as we control it). Do other types of files still work on this plex jail?

#3 Updated by Joshua Johnson almost 6 years ago

YEs I can play mp4 files and stuff just fine. Its the mkv which requires transcoding that doesnt work. From the log output it looks like its sending the request to transcode to 127.0.0.1 instead of the actual IP address assigned to the Plex plugin jail 10.1.10.24, wasn't sure if there was extra security in 9.3 that now blocked this. And when I go to list the current availble plugins under 9.3 it shows nothing so I cannot see if there is a Plex upgrade to the plugin to possible fix the issue.

#4 Updated by Joshua Johnson almost 6 years ago

Ok I went directly to http://download.freenas.org and was able to browse to /plugins and see there is a newer version of the plex server for upgrade as of dec 5 than what I have. The pbi-repo.rpo file is there and updated as of dec 5 but i verified in my configuration that the link is correct pointing to the repo. But still doesn't give me a listing of plugins when I refresh the list of availible. Is the repo possible corrupt?

#5 Updated by Jordan Hubbard almost 6 years ago

1661

Nope, the plugin repo is working just fine - see attached screenshot of a freenas 9.3-stable machine I just took.

Are you going to the Configured plugins tab to update the Plex plugin?

#6 Updated by Martin Grabner almost 6 years ago

Had the same problem with manually installed plex media server via ports. Temporary fix is to add 127.0.0.1 to loopback interface

ifconfig lo0 127.0.0.1

#7 Updated by Jordan Hubbard almost 6 years ago

  • Assignee changed from Jordan Hubbard to John Hixson
  • Target version set to Unspecified

Well, if the workaround is that simple - I don't know why lo0 in a jail doesn't have the loopback configured in any case. John?

#8 Updated by Joshua Johnson almost 6 years ago

Not sure why but a reboot cleared the not able to access the plugin repo. Updating to latest plugin to see if it corrects it. If not will try loopback workaround. Am I adding the loopback address to global or inside the jail?

#9 Updated by Joshua Johnson almost 6 years ago

I upgraded to the latest Plex plugin 0.9.11.4.739_1 and still no joy on the transcoding. I added the loopback0 127.0.0.1 to the Plex jail and retried and the transcoding started working. So that is the temp fix.

#10 Updated by Joshua Johnson almost 6 years ago

So i also started noticing errors in my flexget log which I manually install into my transmission plugin.

2014-12-09 18:53 CRITICAL plugin download-rss Error connecting to transmission: Can't assign requested address

I added the same lo0 127.0.0.1 to the transmission jail

2014-12-09 18:55 INFO ipc server started on [127.0.0.1]:63074

So let me know if I need to write a different bug for that but it seems to all be something related to removal or blocking of the 127.0.0.1 loopback address in 9.3 jails.

#11 Updated by John Hixson almost 6 years ago

Jordan Hubbard wrote:

Well, if the workaround is that simple - I don't know why lo0 in a jail doesn't have the loopback configured in any case. John?

I don't know why either. The jail setup code specifically sets up the loopback interface. If it isn't, then something is wrong. Is this jail not a VIMAGE jail?

#12 Updated by John Hixson almost 6 years ago

I'm unable to reproduce this. Can you reproduce this? When you install the plugin, can you do this:

jexec ${JAILID} ifconfig -a # where ${JAILID} is the ID of the plex jail

and paste the output here?

#13 Updated by Joshua Johnson almost 6 years ago

I checked both my bit_1 and plex_1 jails which were installed on previous versions of freenas like a year ago or so have the vimage checked and were installed by the plugin code at that time. So maybe the plugin code at that time didn't have the loopback0?

#14 Updated by John Hixson almost 6 years ago

Joshua Johnson wrote:

I checked both my bit_1 and plex_1 jails which were installed on previous versions of freenas like a year ago or so have the vimage checked and were installed by the plugin code at that time. So maybe the plugin code at that time didn't have the loopback0?

The plugin code doesn't handle the jail networking.

"I'm unable to reproduce this. Can you reproduce this? When you install the plugin, can you do this:

jexec ${JAILID} ifconfig -a # where ${JAILID} is the ID of the plex jail

and paste the output here?"

#15 Updated by Joshua Johnson almost 6 years ago

I created a 2nd plex plugin for the test. So it appears the current jail creation script does make the

[root@orbiterNAS ~]# jls
JID IP Address Hostname Path
2 10.1.10.22 calibre /mnt/NASshare/jails/calibre
3 - mineos_1 /mnt/NASshare/jails/mineos_1
4 10.1.10.25 murmur /mnt/NASshare/jails/murmur
5 - plex_1 /mnt/NASshare/jails/plex_1
6 - subsonic_1 /mnt/NASshare/jails/subsonic_1
16 - bit_1 /mnt/NASshare/jails/bit_1
17 - plexmediaserver_1 /mnt/NASshare/jails/plexmediaserver_1
[root@orbiterNAS ~]# jexec 17 ifconfig -a
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
inet 127.0.0.1 netmask 0xff000000
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
epair4b: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 02:14:61:00:0f:0b
inet 10.1.10.27 netmask 0xffffff00 broadcast 10.1.10.255
nd6 options=9<PERFORMNUD,IFDISABLED>
media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
status: active
[root@orbiterNAS ~]#

So then I went ahead and checked the rest and now my bit_1 jail which had an loopback0 ip of 127.0.0.1 assigned the other day, no longer does. Calibre and murmur were created jails. Everything else was created during plugin install.

's password:
Last login: Tue Dec 9 17:05:48 2014 from 10.1.10.39
FreeBSD 9.3-RELEASE-p5 (FREENAS.amd64) #0 3b4abc3: Mon Dec 8 15:09:41 PST 2014

FreeNAS (c) 2009-2014, The FreeNAS Development Team
All rights reserved.
FreeNAS is released under the modified BSD license.
For more information, documentation, help or support, go here:
http://freenas.org
Welcome to the OrbiterNAS running on FreeNAS 9
[josh.johnson@orbiterNAS ~]$ jls
JID IP Address Hostname Path
2 10.1.10.22 calibre /mnt/NASshare/jails/calibre
3 - mineos_1 /mnt/NASshare/jails/mineos_1
4 10.1.10.25 murmur /mnt/NASshare/jails/murmur
5 - plex_1 /mnt/NASshare/jails/plex_1
6 - subsonic_1 /mnt/NASshare/jails/subsonic_1
16 - bit_1 /mnt/NASshare/jails/bit_1
17 - plexmediaserver_1 /mnt/NASshare/jails/plexmediaserver_1
[josh.johnson@orbiterNAS ~]$ su - root
Password:
[root@orbiterNAS] ~# jexec 2 ifconfig -a
re0: flags=8943&lt;UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
options=82099&lt;RXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE&gt;
ether d4:3d:7e:b5:b2:10
inet 10.1.10.22 netmask 0xffffff00 broadcast 10.1.10.255
media: Ethernet autoselect (1000baseT &lt;full-duplex&gt;)
status: active
ipfw0: flags=8801&lt;UP,SIMPLEX,MULTICAST&gt; metric 0 mtu 65536
lo0: flags=8049&lt;UP,LOOPBACK,RUNNING,MULTICAST&gt; metric 0 mtu 16384
options=600003&lt;RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6&gt;
bridge0: flags=8843&lt;UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
ether 02:c9:ed:ff:a0:00
id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200
root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
member: epair4a flags=143&lt;LEARNING,DISCOVER,AUTOEDGE,AUTOPTP&gt;
ifmaxaddr 0 port 14 priority 128 path cost 2000
member: epair0a flags=143&lt;LEARNING,DISCOVER,AUTOEDGE,AUTOPTP&gt;
ifmaxaddr 0 port 10 priority 128 path cost 2000
member: epair3a flags=143&lt;LEARNING,DISCOVER,AUTOEDGE,AUTOPTP&gt;
ifmaxaddr 0 port 13 priority 128 path cost 2000
member: epair2a flags=143&lt;LEARNING,DISCOVER,AUTOEDGE,AUTOPTP&gt;
ifmaxaddr 0 port 12 priority 128 path cost 2000
member: epair1a flags=143&lt;LEARNING,DISCOVER,AUTOEDGE,AUTOPTP&gt;
ifmaxaddr 0 port 11 priority 128 path cost 2000
member: re0 flags=143&lt;LEARNING,DISCOVER,AUTOEDGE,AUTOPTP&gt;
ifmaxaddr 0 port 1 priority 128 path cost 20000
epair1a: flags=8943&lt;UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
options=8&lt;VLAN_MTU&gt;
ether 02:74:10:00:0b:0a
media: Ethernet 10Gbase-T (10Gbase-T &lt;full-duplex&gt;)
status: active
epair2a: flags=8943&lt;UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
options=8&lt;VLAN_MTU&gt;
ether 02:71:0c:00:0c:0a
media: Ethernet 10Gbase-T (10Gbase-T &lt;full-duplex&gt;)
status: active
epair3a: flags=8943&lt;UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
options=8&lt;VLAN_MTU&gt;
ether 02:9b:1c:00:0d:0a
media: Ethernet 10Gbase-T (10Gbase-T &lt;full-duplex&gt;)
status: active
epair0a: flags=8943&lt;UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
options=8&lt;VLAN_MTU&gt;
ether 02:ca:39:00:0a:0a
media: Ethernet 10Gbase-T (10Gbase-T &lt;full-duplex&gt;)
status: active
epair4a: flags=8943&lt;UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
options=8&lt;VLAN_MTU&gt;
ether 02:14:61:00:0e:0a
media: Ethernet 10Gbase-T (10Gbase-T &lt;full-duplex&gt;)
status: active
[root@orbiterNAS] ~# jexec 3 ifconfig -a
lo0: flags=8049&lt;UP,LOOPBACK,RUNNING,MULTICAST&gt; metric 0 mtu 16384
options=600003&lt;RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6&gt;
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
inet 127.0.0.1 netmask 0xff000000
nd6 options=21&lt;PERFORMNUD,AUTO_LINKLOCAL&gt;
epair1b: flags=8843&lt;UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
options=8&lt;VLAN_MTU&gt;
ether 02:53:c5:00:13:0b
inet 10.1.10.26 netmask 0xffffff00 broadcast 10.1.10.255
nd6 options=9&lt;PERFORMNUD,IFDISABLED&gt;
media: Ethernet 10Gbase-T (10Gbase-T &lt;full-duplex&gt;)
status: active
[root@orbiterNAS] ~# jexec 4 ifconfig -a
re0: flags=8943&lt;UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
options=82099&lt;RXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE&gt;
ether d4:3d:7e:b5:b2:10
inet 10.1.10.25 netmask 0xffffff00 broadcast 10.1.10.255
media: Ethernet autoselect (1000baseT &lt;full-duplex&gt;)
status: active
ipfw0: flags=8801&lt;UP,SIMPLEX,MULTICAST&gt; metric 0 mtu 65536
lo0: flags=8049&lt;UP,LOOPBACK,RUNNING,MULTICAST&gt; metric 0 mtu 16384
options=600003&lt;RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6&gt;
bridge0: flags=8843&lt;UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
ether 02:c9:ed:ff:a0:00
id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200
root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
member: epair4a flags=143&lt;LEARNING,DISCOVER,AUTOEDGE,AUTOPTP&gt;
ifmaxaddr 0 port 14 priority 128 path cost 2000
member: epair0a flags=143&lt;LEARNING,DISCOVER,AUTOEDGE,AUTOPTP&gt;
ifmaxaddr 0 port 10 priority 128 path cost 2000
member: epair3a flags=143&lt;LEARNING,DISCOVER,AUTOEDGE,AUTOPTP&gt;
ifmaxaddr 0 port 13 priority 128 path cost 2000
member: epair2a flags=143&lt;LEARNING,DISCOVER,AUTOEDGE,AUTOPTP&gt;
ifmaxaddr 0 port 12 priority 128 path cost 2000
member: epair1a flags=143&lt;LEARNING,DISCOVER,AUTOEDGE,AUTOPTP&gt;
ifmaxaddr 0 port 11 priority 128 path cost 2000
member: re0 flags=143&lt;LEARNING,DISCOVER,AUTOEDGE,AUTOPTP&gt;
ifmaxaddr 0 port 1 priority 128 path cost 20000
epair1a: flags=8943&lt;UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
options=8&lt;VLAN_MTU&gt;
ether 02:74:10:00:0b:0a
media: Ethernet 10Gbase-T (10Gbase-T &lt;full-duplex&gt;)
status: active
epair2a: flags=8943&lt;UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
options=8&lt;VLAN_MTU&gt;
ether 02:71:0c:00:0c:0a
media: Ethernet 10Gbase-T (10Gbase-T &lt;full-duplex&gt;)
status: active
epair3a: flags=8943&lt;UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
options=8&lt;VLAN_MTU&gt;
ether 02:9b:1c:00:0d:0a
media: Ethernet 10Gbase-T (10Gbase-T &lt;full-duplex&gt;)
status: active
epair0a: flags=8943&lt;UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
options=8&lt;VLAN_MTU&gt;
ether 02:ca:39:00:0a:0a
media: Ethernet 10Gbase-T (10Gbase-T &lt;full-duplex&gt;)
status: active
epair4a: flags=8943&lt;UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
options=8&lt;VLAN_MTU&gt;
ether 02:14:61:00:0e:0a
media: Ethernet 10Gbase-T (10Gbase-T &lt;full-duplex&gt;)
status: active
[root@orbiterNAS] ~# jexec 5 ifconfig -a
lo0: flags=8049&lt;UP,LOOPBACK,RUNNING,MULTICAST&gt; metric 0 mtu 16384
options=600003&lt;RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6&gt;
inet 127.0.0.1 netmask 0xff000000
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
nd6 options=21&lt;PERFORMNUD,AUTO_LINKLOCAL&gt;
epair2b: flags=8843&lt;UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
options=8&lt;VLAN_MTU&gt;
ether 02:56:65:00:10:0b
inet 10.1.10.24 netmask 0xffffff00 broadcast 10.1.10.255
nd6 options=1&lt;PERFORMNUD&gt;
media: Ethernet 10Gbase-T (10Gbase-T &lt;full-duplex&gt;)
status: active
[root@orbiterNAS] ~# jexec 6 ifconfig -a
lo0: flags=8049&lt;UP,LOOPBACK,RUNNING,MULTICAST&gt; metric 0 mtu 16384
options=600003&lt;RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6&gt;
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
inet 127.0.0.1 netmask 0xff000000
nd6 options=21&lt;PERFORMNUD,AUTO_LINKLOCAL&gt;
epair3b: flags=8843&lt;UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
options=8&lt;VLAN_MTU&gt;
ether 02:e5:92:00:0f:0b
inet 10.1.10.21 netmask 0xffffff00 broadcast 10.1.10.255
nd6 options=9&lt;PERFORMNUD,IFDISABLED&gt;
media: Ethernet 10Gbase-T (10Gbase-T &lt;full-duplex&gt;)
status: active
[root@orbiterNAS] ~# jexec 16 ifconfig -a
lo0: flags=8008&lt;LOOPBACK,MULTICAST&gt; metric 0 mtu 16384
options=600003&lt;RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6&gt;
nd6 options=21&lt;PERFORMNUD,AUTO_LINKLOCAL&gt;
epair0b: flags=8843&lt;UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
options=8&lt;VLAN_MTU&gt;
ether 02:71:3f:00:0c:0b
inet 10.1.10.23 netmask 0xffffff00 broadcast 10.1.10.255
nd6 options=1&lt;PERFORMNUD&gt;
media: Ethernet 10Gbase-T (10Gbase-T &lt;full-duplex&gt;)
status: active
[root@orbiterNAS] ~# jexec 17 ifconfig -a
lo0: flags=8049&lt;UP,LOOPBACK,RUNNING,MULTICAST&gt; metric 0 mtu 16384
options=600003&lt;RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6&gt;
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
inet 127.0.0.1 netmask 0xff000000
nd6 options=21&lt;PERFORMNUD,AUTO_LINKLOCAL&gt;
epair4b: flags=8843&lt;UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST&gt; metric 0 mtu 1500
options=8&lt;VLAN_MTU&gt;
ether 02:14:61:00:0f:0b
inet 10.1.10.27 netmask 0xffffff00 broadcast 10.1.10.255
nd6 options=9&lt;PERFORMNUD,IFDISABLED&gt;
media: Ethernet 10Gbase-T (10Gbase-T &lt;full-duplex&gt;)
status: active
[root@orbiterNAS] ~#

#16 Updated by John Hixson almost 6 years ago

So all your vimage jails with the exception of bit_1, have the loop back configured. Can you do this from the CLI:

service ix-jails stop
service ix-jails start

And verify if all looks good afterwards?

#17 Updated by Joshua Johnson almost 6 years ago

So this was the attempt

[root@orbiterNAS] ~# service ix-jails stop
ix-jails does not exist in /etc/rc.d or the local startup
directories (/etc/ix.rc.d /usr/local/etc/rc.d)
[root@orbiterNAS] ~#

#18 Updated by John Hixson almost 6 years ago

Joshua Johnson wrote:

So this was the attempt

[root@orbiterNAS] ~# service ix-jails stop
ix-jails does not exist in /etc/rc.d or the local startup
directories (/etc/ix.rc.d /usr/local/etc/rc.d)
[root@orbiterNAS] ~#

Ooops. It should be "ix-jail".

#19 Updated by Joshua Johnson almost 6 years ago

So as you can see from the output only the subsonic jail has 127.0.0.1 assigned to the loopback0. The rest cleared.

Using username "josh.johnson".
's password:
Last login: Sat Dec 13 01:06:53 2014 from 166.170.48.11
FreeBSD 9.3-RELEASE-p5 (FREENAS.amd64) #0 3b4abc3: Mon Dec 8 15:09:41 PST 2014

FreeNAS (c) 2009-2014, The FreeNAS Development Team
All rights reserved.
FreeNAS is released under the modified BSD license.
For more information, documentation, help or support, go here:
http://freenas.org
Welcome to the OrbiterNAS running on FreeNAS 9
[josh.johnson@orbiterNAS ~]$ su - root
Password:
[root@orbiterNAS] ~# service ix-jail stop
jexec 16 /usr/pbi/transmission-amd64/control stop
Stoppingthejail....10.1.10.23 (10.1.10.23) deleted
Unmounting user-supplied file-systems
Stopping jail with: /etc/rc.shutdown
.Terminating on signal 15
..DoneStoppingthejail....Unmounting user-supplied file-systems
umount: unmount of /mnt/NASshare/jails/calibre/media/calibreLibrary failed: Device busy
Stopping jail with: /etc/rc.shutdown
...Donejexec 3 /usr/pbi/mineos-amd64/control stop
Stoppingthejail....10.1.10.26 (10.1.10.26) deleted
Stopping jail with: /etc/rc.shutdown
.Terminating on signal 15
..DoneStoppingthejail....Stopping jail with: /etc/rc.shutdown
...Donejexec 5 /usr/pbi/plexmediaserver-amd64/control stop
Stoppingthejail....10.1.10.24 (10.1.10.24) deleted
Unmounting user-supplied file-systems
Stopping jail with: /etc/rc.shutdown
.Terminating on signal 15
..Donejexec 6 /usr/pbi/subsonic-amd64/control stop
Stoppingthejail....10.1.10.21 (10.1.10.21) deleted
Unmounting user-supplied file-systems
Stopping jail with: /etc/rc.shutdown
.Terminating on signal 15
..Done[root@orbiterNAS] ~# service ix-jail start
Mounting user-supplied file-systems
jail -c path=/mnt/NASshare/jails/bit_1 name=bit_1 host.hostname=bit_1 allow.raw_sockets=true persist vnet=new
jexec: jail "ifconfig" not found
Setting IPv4 address: 10.1.10.23/24
inet6_enable: YES -> YES
ip6addrctl_enable: YES -> YES
add net default: gateway 10.1.10.254
route: writing to routing socket: File exists
add net default: gateway 10.1.10.254: route already in table
Starting jail with: /etc/rc
jexec 18 /usr/pbi/transmission-amd64/control start 10.1.10.23 12347
Mounting user-supplied file-systems
jail -c path=/mnt/NASshare/jails/calibre ip4.addr=10.1.10.22/24 host.hostname=calibre allow.raw_sockets=true persist
Starting jail with: /etc/rc
Mounting user-supplied file-systems
jail -c path=/mnt/NASshare/jails/mineos_1 name=mineos_1 host.hostname=mineos_1 allow.raw_sockets=true persist vnet=new
jexec: jail "ifconfig" not found
Setting IPv4 address: 10.1.10.26/24
inet6_enable: YES -> YES
ip6addrctl_enable: YES -> YES
add net default: gateway 10.1.10.254
route: writing to routing socket: File exists
add net default: gateway 10.1.10.254 fib 0: route already in table
Starting jail with: /etc/rc
jexec 20 /usr/pbi/mineos-amd64/control start 10.1.10.26 12356
Mounting user-supplied file-systems
jail -c path=/mnt/NASshare/jails/murmur ip4.addr=10.1.10.25/24 host.hostname=murmur allow.raw_sockets=true persist
Starting jail with: /etc/rc
Mounting user-supplied file-systems
jail -c path=/mnt/NASshare/jails/plex_1 name=plex_1 host.hostname=plex_1 allow.raw_sockets=true persist vnet=new
jexec: jail "ifconfig" not found
Setting IPv4 address: 10.1.10.24/24
inet6_enable: YES -> YES
ip6addrctl_enable: YES -> YES
add net default: gateway 10.1.10.254
route: writing to routing socket: File exists
add net default: gateway 10.1.10.254: route already in table
Starting jail with: /etc/rc
jexec 22 /usr/pbi/plexmediaserver-amd64/control start 10.1.10.24 12348
Mounting user-supplied file-systems
jail -c path=/mnt/NASshare/jails/subsonic_1 name=subsonic_1 host.hostname=subsonic_1 allow.raw_sockets=true persist vnet=new
jexec: jail "ifconfig" not found
Setting IPv4 address: 10.1.10.21/24
inet6_enable: YES -> YES
ip6addrctl_enable: YES -> YES
add net default: gateway 10.1.10.254
route: writing to routing socket: File exists
add net default: gateway 10.1.10.254 fib 0: route already in table
Starting jail with: /etc/rc
jexec 23 /usr/pbi/subsonic-amd64/control start 10.1.10.21 12355
[root@orbiterNAS] ~# jsh

CORRECT>sh (y|n|e|a)?
[root@orbiterNAS] ~# jls
JID IP Address Hostname Path
18 - bit_1 /mnt/NASshare/jails/bit_1
19 10.1.10.22 calibre /mnt/NASshare/jails/calibre
20 - mineos_1 /mnt/NASshare/jails/mineos_1
21 10.1.10.25 murmur /mnt/NASshare/jails/murmur
22 - plex_1 /mnt/NASshare/jails/plex_1
23 - subsonic_1 /mnt/NASshare/jails/subsonic_1
[root@orbiterNAS] ~# jexec 18 ifconfig -a
lo0: flags=8008<LOOPBACK,MULTICAST> metric 0 mtu 16384
options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
epair0b: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 02:71:3f:00:0c:0b
inet 10.1.10.23 netmask 0xffffff00 broadcast 10.1.10.255
nd6 options=1<PERFORMNUD>
media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
status: active
[root@orbiterNAS] ~# jexec 19 ifconfig -a
re0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=82099<RXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
ether d4:3d:7e:b5:b2:10
inet 10.1.10.22 netmask 0xffffff00 broadcast 10.1.10.255
media: Ethernet autoselect (1000baseT <full-duplex>)
status: active
ipfw0: flags=8801<UP,SIMPLEX,MULTICAST> metric 0 mtu 65536
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
ether 02:c9:ed:ff:a0:00
id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200
root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
member: epair3a flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
ifmaxaddr 0 port 13 priority 128 path cost 2000
member: epair2a flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
ifmaxaddr 0 port 12 priority 128 path cost 2000
member: epair1a flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
ifmaxaddr 0 port 11 priority 128 path cost 2000
member: epair0a flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
ifmaxaddr 0 port 10 priority 128 path cost 2000
member: re0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
ifmaxaddr 0 port 1 priority 128 path cost 20000
epair0a: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 02:95:ad:00:0a:0a
media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
status: active
epair1a: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 02:ca:61:00:0b:0a
media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
status: active
epair2a: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 02:fc:87:00:0c:0a
media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
status: active
epair3a: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 02:60:ef:00:0d:0a
media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
status: active
[root@orbiterNAS] ~# jexec 20 ifconfig -a
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
inet 127.0.0.1 netmask 0xff000000
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
epair1b: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 02:53:c5:00:13:0b
inet 10.1.10.26 netmask 0xffffff00 broadcast 10.1.10.255
nd6 options=9<PERFORMNUD,IFDISABLED>
media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
status: active
[root@orbiterNAS] ~# jexec 21 ifconfig -a
re0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=82099<RXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
ether d4:3d:7e:b5:b2:10
inet 10.1.10.25 netmask 0xffffff00 broadcast 10.1.10.255
media: Ethernet autoselect (1000baseT <full-duplex>)
status: active
ipfw0: flags=8801<UP,SIMPLEX,MULTICAST> metric 0 mtu 65536
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
ether 02:c9:ed:ff:a0:00
id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200
root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
member: epair3a flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
ifmaxaddr 0 port 13 priority 128 path cost 2000
member: epair2a flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
ifmaxaddr 0 port 12 priority 128 path cost 2000
member: epair1a flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
ifmaxaddr 0 port 11 priority 128 path cost 2000
member: epair0a flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
ifmaxaddr 0 port 10 priority 128 path cost 2000
member: re0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
ifmaxaddr 0 port 1 priority 128 path cost 20000
epair0a: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 02:95:ad:00:0a:0a
media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
status: active
epair1a: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 02:ca:61:00:0b:0a
media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
status: active
epair2a: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 02:fc:87:00:0c:0a
media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
status: active
epair3a: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 02:60:ef:00:0d:0a
media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
status: active
[root@orbiterNAS] ~# jexec 22 ifconfig -a
lo0: flags=8008<LOOPBACK,MULTICAST> metric 0 mtu 16384
options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
epair2b: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 02:56:65:00:10:0b
inet 10.1.10.24 netmask 0xffffff00 broadcast 10.1.10.255
nd6 options=1<PERFORMNUD>
media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
status: active
[root@orbiterNAS] ~# jexec 23 ifconfig -a
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
inet 127.0.0.1 netmask 0xff000000
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
epair3b: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=8<VLAN_MTU>
ether 02:e5:92:00:0f:0b
inet 10.1.10.21 netmask 0xffffff00 broadcast 10.1.10.255
nd6 options=9<PERFORMNUD,IFDISABLED>
media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
status: active
[root@orbiterNAS] ~#

#20 Updated by Joshua Johnson almost 6 years ago

I also after this tried to play the same mkv files in plex and they wouldn't play until I went back and added ifconfig lo0 127.0.0.1 to the plex jail. Then they worked.

#21 Updated by John Hixson over 5 years ago

  • Status changed from 15 to Fix In Progress

#22 Updated by Jordan Hubbard over 5 years ago

Is there more to this? Just wondering if Status is correct.

#23 Updated by John Hixson over 5 years ago

  • Status changed from Fix In Progress to Ready For Release

#24 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Ready For Release to Resolved

#25 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

Also available in: Atom PDF