Project

General

Profile

Bug #70878

"Not an Integer" error on bhyve VM edit

Added by Derek Edwards 6 months ago. Updated 5 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Cannot Reproduce
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No
Tags:

Description

This affects both legacy and new WebUI in version FreeNAS-11.2-RELEASE-U1. If I go into the VM and attempt to save the VM, with or without changes, there is the above error thrown. Let me know what I can do to help move this forward.

Capture.PNG (12.6 KB) Capture.PNG Derek Edwards, 02/12/2019 05:15 PM
54184

Related issues

Is duplicate of FreeNAS - Bug #69159: Increase SQLite retry timeout to prevent locking on slow USB devicesDone

History

#1 Updated by Dru Lavigne 6 months ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Derek: please reproduce then attach a debug (System -> Advanced -> Save debug) to this ticket.

#2 Updated by Derek Edwards 6 months ago

  • File debug-freenas-20190120215553.tgz added

There is the debug log(s). I attempted to change it right before I ran this and it threw the error again.

#3 Updated by Dru Lavigne 6 months ago

  • Category changed from Services to Middleware
  • Assignee changed from Release Council to William Grzybowski
  • Reason for Blocked deleted (Need additional information from Author)

#4 Updated by William Grzybowski 6 months ago

  • Assignee changed from William Grzybowski to Brandon Schneider
  • Target version changed from Backlog to 11.2-U3

#5 Updated by Derek Edwards 6 months ago

Is there anyway to edit a Bhyve via CLI temporarily? I've searched around and only found that people say it's not possible...

#6 Updated by Brandon Schneider 6 months ago

  • Status changed from Unscreened to Not Started

#7 Updated by Brandon Schneider 5 months ago

  • Is duplicate of Bug #69159: Increase SQLite retry timeout to prevent locking on slow USB devices added

#8 Updated by Brandon Schneider 5 months ago

  • Status changed from Not Started to Closed
  • Reason for Closing set to Duplicate Issue
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

Duplicate of 69159, closing. Should be fixed in U2

#9 Updated by Brandon Schneider 5 months ago

  • File deleted (debug-freenas-20190120215553.tgz)

#10 Updated by Brandon Schneider 5 months ago

  • Private changed from Yes to No

#11 Updated by Brandon Schneider 5 months ago

  • Status changed from Closed to Blocked
  • Reason for Closing deleted (Duplicate Issue)
  • Reason for Blocked set to Need additional information from Author

So before we close this out completely are you able to supply a screenshot showing this? The errors in your logs don’t include this information, so that would help a great deal!

Thanks!

#12 Updated by Derek Edwards 5 months ago

54184

This is the only error that is shown on the Legacy WebUI. Also, currently not able to start my VM at all for some reason -- https://forums.freenas.org/index.php?threads/bhyve-rancheros-vm-wont-boot-up.73751/ (I know probably completely unrelated)

#13 Updated by Vladimir Vinogradenko 5 months ago

  • Assignee changed from Brandon Schneider to Vladimir Vinogradenko

Derek, would you please be able to upload a debug (System → Advanced → Save Debug in Legacy UI) taken right after you get that error in freenas forum?

#14 Updated by Derek Edwards 5 months ago

Debug log is included in comment #2

#15 Updated by Vladimir Vinogradenko 5 months ago

Derek, I want to debug an issue you've posted on a forum ("unsupported operand type(s) for +: 'bool' and 'str'"), there is no such record in that debug log you've posted above, you probably didn't have that issue at the time you were taking it. Please, try to start failed vm again (to get that error) and then save new debug. Thank you.

#16 Updated by Derek Edwards 5 months ago

I might have just solved this as it looks like comparing VMs created in the new UI and legacy helped. For some reason if there is no "Order" set in the VM or RAW size of the VM it will cause an issue. Interesting thing is that I hadn't changed anything in that for some time. So maybe there is some cross-over there that is not allowing the new UI to boot without that "Order" defined?

#17 Updated by Vladimir Vinogradenko 5 months ago

  • Status changed from Blocked to Closed
  • Reason for Closing set to Cannot Reproduce
  • Reason for Blocked deleted (Need additional information from Author)

Can't guess what's been there without a debug and was not unable to reproduce myself

#18 Updated by Dru Lavigne 5 months ago

  • Target version changed from 11.2-U3 to N/A

Also available in: Atom PDF