Project

General

Profile

Bug #71169

Add load spinner to new UI user page

Added by IT IGP almost 3 years ago. Updated over 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Dennis Mullen
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

ACCEPTANCE CRITERIA:
Open Accounts / Users, select the 'three-dot' actions icon at the end of any row, click edit. A spinner should appear at the top of the form, until the Aux groups field is filled in. Some users have experienced a delay on this data loading, so the spinner shows that the form is still waiting.

Opening a user account with "edit", it takes sometimes up to 10seconds until the user information is populated into the UI. furthermore the UI shows the default field data until the actual data has been fetched in the background and shown. There is no feedback to the user there is still something going to happen, data is being fetched.
a) wait until data is there, then draw the UI
b) indicate to the user data is being fetched


Related issues

Has duplicate FreeNAS - Bug #71185: UI User: auxiliary groups not populated even after user information has been loadedClosed

History

#1 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Unscreened to Blocked
  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

It sounds like something else may be happening on your system to cause the slowdown. Please reproduce then attach a debug (System -> Advanced -> Save debug) to this ticket.

#2 Updated by IT IGP almost 3 years ago

  • File debug-samba-20190122005506.tgz added

i just reproduced it, same problem. .
there is almost 0 load on the system. granted the opteron is not the fastest, but 8-15 sec loading time...

#3 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Blocked to Unscreened
  • Assignee changed from Release Council to Anonymous
  • Target version changed from Backlog to 11.2-U3
  • Reason for Blocked deleted (Need additional information from Author)

#4 Updated by Anonymous almost 3 years ago

  • Assignee changed from Anonymous to Vaibhav Chauhan

#5 Updated by Anonymous almost 3 years ago

  • Assignee changed from Vaibhav Chauhan to Dennis Mullen

#6 Updated by Dennis Mullen almost 3 years ago

  • Related to Bug #71185: UI User: auxiliary groups not populated even after user information has been loaded added

#7 Updated by Dennis Mullen almost 3 years ago

  • Status changed from Unscreened to Screened

I see a small delay for user info loading, slightly longer for groups. Both delays seem to be in data coming back from the web socket call.

#8 Updated by Dennis Mullen almost 3 years ago

MASTER: https://github.com/freenas/webui/pull/1982
STABLE: https://github.com/freenas/webui/pull/1981

This PR puts a simple progress spinner on user form until group ws call comes back (which consistently takes the longest). The UI seems to display the credentials immediately once the ws call gets a response. The spinner doesn't interfere with using the form. I have seen a small but noticeable delay in waiting for the user and especially group websocket call to return. If others are seeing a long delay, as the original poster is, it seems to be in the response from middleware.

#9 Updated by Dennis Mullen almost 3 years ago

  • Status changed from Screened to In Progress

#10 Updated by Dennis Mullen almost 3 years ago

  • Related to deleted (Bug #71185: UI User: auxiliary groups not populated even after user information has been loaded)

#11 Updated by Dennis Mullen almost 3 years ago

  • Has duplicate Bug #71185: UI User: auxiliary groups not populated even after user information has been loaded added

#12 Updated by Dennis Mullen almost 3 years ago

  • Subject changed from UI user: edit: loading a user account's data happens with no feedback and can takes ages to UI user page: User and group data loads slowly with no feedback

#13 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-samba-20190122005506.tgz)

#14 Updated by Dru Lavigne almost 3 years ago

  • Private changed from Yes to No

#15 Updated by Anonymous almost 3 years ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

Testing criteria: Users page now has a loader while it is loading the data

#16 Updated by Dru Lavigne almost 3 years ago

  • Subject changed from UI user page: User and group data loads slowly with no feedback to Add load spinner to new UI user page
  • Needs Doc changed from Yes to No

#17 Updated by Dennis Mullen over 2 years ago

  • Description updated (diff)

#19 Updated by Jeff Ervin over 2 years ago

59529

Test Passed FreeNAS-11.2-U2-INTERNAL95

Screenshot shows a glimpse of the spinner. My system is smaller, less data to collect etc., but the spinner does display while gathering data.

#20 Updated by Dru Lavigne over 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF