Project

General

Profile

Bug #71281

Allow . as valid character in username field of new UI

Added by IT IGP almost 3 years ago. Updated over 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Vaibhav Chauhan
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

1. there is no error message as why to the button stays greyed out. Trial and error flipping field data.
And maybe it should be up to the admin what "Full Name" should be, maybe a first name should suffice?

2. Once you enter the lastname additionally to the firstname, the save button is enabled.
3. If you then remove the lastname , the button stays enabled ^^

Screenshot_16.png (56.4 KB) Screenshot_16.png IT IGP, 01/22/2019 03:50 PM
50339

Related issues

Related to FreeNAS - Bug #79779: don't popup an error message when the username field has a period in it in the new GUIClosed

Associated revisions

Revision 7a1ce662 (diff)
Added by Erin Clark almost 3 years ago

Move validators back to helptext Ticket: #71281

Revision 4d0d7fef (diff)
Added by Erin Clark almost 3 years ago

Move validators back to helptext Ticket: #71281 (cherry picked from commit 7a1ce662041dbdbeaa457ca98e7353e89dd31ff5)

History

#1 Updated by Anonymous almost 3 years ago

  • Assignee changed from Release Council to Anonymous

Which version did you see this on?

#2 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

#3 Updated by IT IGP almost 3 years ago

50339

after trying around quite around this seems to be much more complex problem.

i attached a screenshot with reproduction steps for 1 problem. but thats not all.

i could also get a case where after entering fullname, username, password twice, the save button was greyed out, and after a few sec got enabled. is there stuff being checkedd in the background?

i get these issues with "add user dialog" in two separate 11.2-u1 systems. one was installed fresh, the other is upgraded from 11.1u6.

offtopic: is it possible to get the entries in "seen in" in this bug tracker sorted?

#4 Updated by Dru Lavigne almost 3 years ago

offtopic: Redmine sorts these by date, but I've pruned out some of the older ones.

#5 Updated by Anonymous almost 3 years ago

  • Status changed from Blocked to Unscreened
  • Assignee changed from Anonymous to Vaibhav Chauhan
  • Target version changed from Backlog to 11.2-U3

it seems you found a way to mess with the validation and/or username generation, the form attempts to create a username for you so that it won't be greyed out (since that is a required field). It may be that the regex isn't doing the right thing with that . or something, thanks for getting back to us with some reproduction steps.

#6 Updated by Vaibhav Chauhan almost 3 years ago

  • Subject changed from Accounts: Users: Create: missing lastname in "Full Name" causes "save" button to stay greyed out to add . as valid char in username field

#7 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Unscreened to In Progress
  • Reason for Blocked deleted (Need additional information from Author)

#8 Updated by Anonymous almost 3 years ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#9 Updated by Anonymous almost 3 years ago

Testing criteria: . should now work as a valid character in the username field

#10 Updated by Dru Lavigne almost 3 years ago

  • Subject changed from add . as valid char in username field to Allow . as valid character in username field of new UI
  • Needs Doc changed from Yes to No

#13 Updated by Bonnie Follweiler over 2 years ago

  • Related to Bug #79779: don't popup an error message when the username field has a period in it in the new GUI added

#14 Updated by Dru Lavigne over 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF