Project

General

Profile

Bug #72057

If domain controller is enabled, use the DNS forwarder when installing a plugin

Added by Bug Clerk almost 3 years ago. Updated over 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Brandon Schneider
Category:
Middleware
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

My FreeNAS server is configured as an Active Directory DC.

When I try to install any plugins the install fails at the DNS check with the message:

Install
[EFAULT] Exception: CallError:[EFAULT] pkg.cdn.trueos.org could not be reached via DNS, check your network occured, destroyed emby.

The underlying cause is resolv.conf on the server is pointing to 127.0.0.1, which I believe is correct for AD DC, but when this is copied into the jail obviously it cannot resolve anything.

There is an option to override the resolv.conf when creating a jail, but cannot see the same for plugins.

Workaround is to connect into the iocage jail and edit resolv.conf before the UI gets to checking access.


Related issues

Has duplicate FreeNAS - Bug #64449: Iocage plugin creation failsClosed
Copied from FreeNAS - Bug #71083: Plugin installation fails with DNS error when FreeNAS is configured as Active Directory DCDone

History

#1 Updated by Bug Clerk almost 3 years ago

  • Copied from Bug #71083: Plugin installation fails with DNS error when FreeNAS is configured as Active Directory DC added

#2 Updated by Bug Clerk almost 3 years ago

  • Status changed from Unscreened to In Progress

#3 Updated by Dru Lavigne almost 3 years ago

  • Target version changed from Master - FreeNAS Nightlies to 11.2-U3

#4 Updated by Dru Lavigne almost 3 years ago

  • Has duplicate Bug #64449: Iocage plugin creation fails added

#5 Updated by Bug Clerk almost 3 years ago

  • Status changed from In Progress to Ready for Testing

#6 Updated by Dru Lavigne almost 3 years ago

  • Subject changed from Plugin installation fails with DNS error when FreeNAS is configured as Active Directory DC to If domain controller is enabled, use the DNS forwarder when installing a plugin
  • Needs Merging changed from Yes to No

#7 Updated by Brandon Schneider over 2 years ago

Test case
---
Enable DC, set a DNS forwarder in that and create a jail. The jails resolver property should reflect that after the jail has been created

#11 Avatar?id=55038&size=24x24 Updated by Zackary Welch over 2 years ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Confirmed fixed in 11.2-U3.

Testing Steps:
0. Created a jail with 11.2-RELEASE so it could be pre-fetched, since my Domain Controller is not functional. Then deleted the jail.
1. Enabled Services->Domain Controller with:
Realm: AD
Domain: FREENAS
DNS Forwarder: 10.10.205.1
These values are junk.
2. Created a new jail and ran 'iocage get resolver JAIL'. Returned 'nameserver 10.10.205.1' as expected.

#12 Updated by Dru Lavigne over 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF