Project

General

Profile

Bug #7264

Missing critical hardware requirement for FreeNAS 9.3 in the documentation

Added by Sebastian Larsen almost 6 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Dru Lavigne
Category:
Documentation
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After going through this issue here: https://bugs.freenas.org/issues/7130 it has become clear that FreeNAS is dropping some hardware support.
However, there is no indication of this in the current 9.3 documentation I found: http://doc.freenas.org/9.3/freenas_intro.html#hardware-recommendations

The problem is that FreeNAS 9.3 REQUIRES an EFI BIOS that is required to boot from a GPT partition which is the new standard, however that isn't mentioned anywhere in the documentation and causes issues when you try to install it on hardware that is affected.
In short what I can tell of the top of my head, current hardware that isn't supported is All socket 775 based machines, (Core 1 and Core 2 series) as all I have seen were BIOS based.
99% of the Socket 1366 lineup, as all the BIOSes weren't EFI based.
And some of the first gen Core i5 lineup as not all manufacturers did a shift to EFI.

History

#1 Updated by Dru Lavigne almost 6 years ago

  • Status changed from Unscreened to Screened

#2 Updated by Dru Lavigne almost 6 years ago

  • Status changed from Screened to Resolved

Fixed in dae7b9f. Note that FreeBSD (and thus FreeNAS) does not require EFI as it also supports GPT booting from BIOS legacy mode.

#3 Updated by Dru Lavigne almost 3 years ago

  • Target version set to Master - FreeNAS Nightlies

Also available in: Atom PDF