Project

General

Profile

Bug #72964

11.2 bootloader broken, gptzfsboot error 32, now incompatible on previous running hardware

Added by IT IGP 19 days ago. Updated 5 days ago.

Status:
Blocked
Priority:
No priority
Assignee:
Ryan Moeller
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Need additional information from Author
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Bascially pretty much Bug #52647, which has been imho erroneously closed, more info:

Issue arose after upgrading 11.1u6.3 to 11.2, boot failed after another voluntary reboot(!) after upgrade cycle completed successfully and system could already be used(!). (Old hardware Asus KGPE-D16, worked fine with 11.1, no UEFI support, yet).

Can confirm that 11.2 upgrade bootloader made freenas-boot media incompatible with the old hardware, moving USB boot media to new hardware the boot works fine.

Just confirmed with fresh install of 11.2u1 on the old board: Install worked, but cannot boot into it afterwards. It is based in 11.2-U1 bootloader, not connected to the upgrade procedure.

See screenshots.

Especially for some older hardware in production which is still to receive an update to 11.2 this could end in desaster.

Screenshot_23.png (17.5 KB) Screenshot_23.png IT IGP, 01/30/2019 05:37 PM
Screenshot_24.png (22.7 KB) Screenshot_24.png IT IGP, 01/30/2019 05:37 PM
Screenshot_27.png (38.1 KB) Screenshot_27.png IT IGP, 01/31/2019 09:31 AM
Screenshot_29.png (104 KB) Screenshot_29.png IT IGP, 01/31/2019 09:31 AM
51580
51589
51724
51726

Related issues

Related to FreeNAS - Bug #52647: Broken bootloader - gptzfsboot errorClosed
Related to FreeNAS - Bug #65517: gptzfsboot errors and BTX halted on fresh FreeNAS-11.2-RELEASE install to USBIn Progress

History

#1 Updated by IT IGP 19 days ago

  • File deleted (Screenshot_21.png)

#2 Updated by Dru Lavigne 19 days ago

  • Related to Bug #52647: Broken bootloader - gptzfsboot error added

#3 Updated by Dru Lavigne 19 days ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

Please do a fresh install of 11.1-U6.3 on the problematic system in order to grab a debug to attach to this ticket (System -> Advanced -> Save debug).

Also, can you confirm if the BIOS is at its latest revision?

#4 Updated by IT IGP 19 days ago

51724
51726

yes, BIOS is always on latest revision, also on the Asus KGPE-D16. i will perform more tests on it in the future.

the problem is getting more complex, but it seems to be an issue with the bootloader:

on the NEW system (SM-X11SCA-F, onboard 5xSATA HDD + 2xSSD, 2xUSB-16GB freenas-boot, boot NON-UEFI) now running the moved upgraded system (11.1u6.3=>11.2u1):
connecting 6 more disks SATA disks to a SAS9340-8i (crossflash to P16 IT-mode, with EFI+BIOS) the boot from either USB fails. see new screenshots. reproducible. removing the disks boot works again. leaving the controller plugged in is not an issue.

previously i used this board as test system for 11.2u1 and i could boot (fresh 11.2u1 UEFI-based install/boot) WITH those 6 disks on the controller (but without those onboard disks). so its likely it is related to old non-UEFI boot?

#5 Updated by Dru Lavigne 18 days ago

  • Assignee changed from Release Council to Alexander Motin

#7 Updated by Alexander Motin 8 days ago

  • Status changed from Blocked to Unscreened
  • Assignee changed from Alexander Motin to Ryan Moeller

IT IGP, what USB sticks are you using? Have you tried to boot from some other disn, like SATA?

Ryan, here is in collection of your boot issues. Please look whether it is a duplicate of something.

#8 Updated by IT IGP 7 days ago

after testing a variety of vendors we found sandisk and samsung USB sticks to be most compatible and fast (mostly used/tested on our older hardware Asus KGPE-D16 and Supermicro X10SLH-F). we have not yet tested with install on SATA disks.

currently it seems to me that the problems are related to non-UEFI boot/install and we also try to move to UEFI with new hardware.

#9 Updated by Ryan Moeller 7 days ago

  • Status changed from Unscreened to Blocked

There have been many issues with some SanDisk USB sticks that have been resolved by switching to a different brand or newer device. In particular, the SanDisk Ultra Fit USB 3.0 sticks are frequently causing problems. Something about the combination of particular devices with particular BIOS is upset by the bsdloader, because the same sticks will work in different machines and different sticks will work in the same machines, and the same sticks in the same machines worked with GRUB.

So far this seems to match the information you have provided.

I have some ideas being looked in to, but for now can you report the output of diskinfo -v DISKDEV for the affected sticks, for example diskinfo -v da0 if the USB stick is da0 in your system.

#10 Updated by Ryan Moeller 7 days ago

  • Related to Bug #65517: gptzfsboot errors and BTX halted on fresh FreeNAS-11.2-RELEASE install to USB added

#11 Updated by IT IGP 5 days ago

these are the 2 sticks used for non-UEFI boot (which failed somehow after reboot 11.2 on old asus board, and then had the boot problem when disks were attached to SAS controller on SM-X11SCA-F).
if you need more, just ask ;)

[root@samba ~]# camcontrol devlist
<Intenso Speed Line 1.00>          at scbus10 target 0 lun 0 (pass7,da0)
<SanDisk Ultra 1.00>               at scbus12 target 0 lun 0 (pass9,da2)

[root@samba ~]# diskinfo -v da0
da0
        512             # sectorsize
        15977152512     # mediasize in bytes (15G)
        31205376        # mediasize in sectors
        0               # stripesize
        0               # stripeoffset
        1942            # Cylinders according to firmware.
        255             # Heads according to firmware.
        63              # Sectors according to firmware.
        Intenso Speed Line      # Disk descr.
        000000000000000269      # Disk ident.
        No              # TRIM/UNMAP support
        0               # Rotation rate in RPM
        Not_Zoned       # Zone Mode

[root@samba ~]# diskinfo -v da2
da2
        512             # sectorsize
        15376000000     # mediasize in bytes (14G)
        30031250        # mediasize in sectors
        0               # stripesize
        0               # stripeoffset
        1869            # Cylinders according to firmware.
        255             # Heads according to firmware.
        63              # Sectors according to firmware.
        SanDisk Ultra   # Disk descr.
        4C530001181013103554    # Disk ident.
        No              # TRIM/UNMAP support
        Unknown         # Rotation rate in RPM
        Not_Zoned       # Zone Mode

Also available in: Atom PDF