Project

General

Profile

Bug #73146

ad failed to bind to domain error message

Added by Caleb St. John over 2 years ago. Updated over 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Caleb St. John
Category:
Middleware
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

In the event we have configured only the active controller to be joined to the domain, the passive controller will create a file in /tmp/ named ".adalert" because the passive controller has been configured to not join the domain. (This is expected behavior in this scenario)

On failover, the passive controller doesn't remove that file even though it successfully joins the domain so the alert in the webUI is false.

This ticket is to fix that behavior.


Related issues

Related to FreeNAS - Bug #72145: Fix AD bind error messages in alert system on TrueNAS failoverReady for Testing

History

#1 Updated by Caleb St. John over 2 years ago

  • Related to Bug #72145: Fix AD bind error messages in alert system on TrueNAS failover added

#2 Updated by Caleb St. John over 2 years ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#3 Updated by Caleb St. John over 2 years ago

  • Target version changed from N/A to 11.3

#4 Updated by Dru Lavigne over 2 years ago

#5 Updated by Dru Lavigne over 2 years ago

  • Status changed from Ready for Testing to Done
  • Target version changed from 11.3 to Master - FreeNAS Nightlies
  • Needs QA changed from Yes to No

Also available in: Atom PDF