Project

General

Profile

Bug #73389

Cannot edit crontabs created before 11.1 U7

Added by Claas Lisowski 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Andrew Walker
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I updated from 11.1-U6.3 to U7 and was unable to enable/disable any existing crontab via ui (haven't tried API).
The error message is "The user root is not valid.".
I tried root user and other users but same result.
This happened for crontabs which existed before the update to U7.
I haven't created new crontab - If I revert back to U6.3 all works fine (tried that and updated again to U7 with the same bug).


Related issues

Is duplicate of FreeNAS - Bug #76000: Fix regression with user/group validation in AD environmentsDone

History

#1 Updated by Claas Lisowski 4 months ago

  • File debug-freenas-20190202114438.txz added
  • Private changed from No to Yes

#2 Updated by Claas Lisowski 4 months ago

  • File debug-freenas-20190202113033.tgz added

#3 Updated by Claas Lisowski 4 months ago

  • File Screenshot 2019-02-01 at 21.33.46.png added

#4 Updated by Dru Lavigne 4 months ago

  • Assignee changed from Release Council to Vladimir Vinogradenko

#5 Updated by William Grzybowski 3 months ago

  • Assignee changed from Vladimir Vinogradenko to Andrew Walker
  • Target version changed from Backlog to 11.1-U8

Andrew, this seems to be somewhat related to directory services. Could you investigate, please?

Feel free to pass it back to me if thats not the case (I didnt investigate too deeply).

#6 Updated by Andrew Walker 3 months ago

Does it succeed if you turn off the "AD" service, then edit the cronjob?

#8 Updated by Andrew Walker 3 months ago

Okay. I see that the full name of your domain is AD.LIS.LOCAL, and the short form is LIS. Is this correct?

#9 Updated by Claas Lisowski 3 months ago

The AD infos are correct and are working fine in the previous patch level U6.
Unfortunately I cannot do the test with switching off AD as I don’t have time the next 2-3 weeks. But I’ll try as soon as possible.
Thanks

#10 Updated by Andrew Walker 3 months ago

That's not a problem. I think I have identified the cause of the regression. I will provide a patched file shortly for testing.

#11 Updated by Andrew Walker 3 months ago

Confirmed fix with other affected user.
PR for 11.2-stable: https://github.com/freenas/freenas/pull/2636
11.1 and master are coming soon.

#13 Updated by Andrew Walker 3 months ago

  • Status changed from Unscreened to Closed
  • Reason for Closing set to Duplicate Issue
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

Closing this ticket as duplicate. Issue followed in: https://redmine.ixsystems.com/issues/76000

#14 Updated by Andrew Walker 3 months ago

  • File deleted (debug-freenas-20190202114438.txz)

#15 Updated by Andrew Walker 3 months ago

  • File deleted (debug-freenas-20190202113033.tgz)

#16 Updated by Andrew Walker 3 months ago

  • File deleted (Screenshot 2019-02-01 at 21.33.46.png)

#17 Updated by Dru Lavigne 3 months ago

  • Is duplicate of Bug #76000: Fix regression with user/group validation in AD environments added

#18 Updated by Dru Lavigne 3 months ago

  • Target version changed from 11.1-U8 to N/A
  • Private changed from Yes to No

Also available in: Atom PDF