Project

General

Profile

Bug #73657

Fix ordering issue to allow recycle bin across ZFS datasets

Added by John Smith almost 3 years ago. Updated over 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Andrew Walker
Category:
Services
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Imagine this setup

Volume
-Dataset1
-Dataset2
-Dataset3

If you create a share for "Volume" and enable recycle bin, there won't be any recycle bin at all.
If you create a share from each dataset and enable recycle bin, there will be a recycle bin. But who wants to have multiple shares from each dataset? Certainly not me. This is definitely a bug, as the recycle bin does not work for a share with several datasets.


Related issues

Copied to FreeNAS - Bug #75910: SAMBA's Recycle bin does not work if there are several datasetsDone

History

#1 Updated by Dru Lavigne almost 3 years ago

  • Assignee changed from Release Council to Andrew Walker

#3 Updated by Andrew Walker almost 3 years ago

[2019/02/06 06:47:48.411709,  3] ../source3/modules/vfs_recycle.c:642(recycle_unlink)
  recycle: Move error 18 (Cross-device link), purging file Test/New Text Document.txt (.recycle/smbuser/Test/New Text Document.txt)

We're trying to rename across filesystem boundaries, which fails. You will need to stack with vfs_crossrename, which will allow "rename" VFS operations to traverse said boundaries. Unfortunately, it looks like we're not ordering the VFS correctly for this. Patch is on its way.

#4 Updated by Bug Clerk almost 3 years ago

  • Status changed from Unscreened to In Progress

#5 Updated by Andrew Walker almost 3 years ago

Steps to test:
1) Create SMB share with "recycle" checkbox checked.
2) Use "testparm" to verify that "crossrename" and "recycle" are both present as "vfs objects".
2) Create dataset inside SMB share
3) Set permissions correctly
4) Create file in nested dataset then delete it.
5) Verify that file is created inside the .recycle/user/<dataset> directory

Edit: revised test to reflect change to enable crossrename by default when recycle is enabled.

#6 Updated by Dru Lavigne almost 3 years ago

  • Target version changed from Backlog to 11.2-U3

#7 Updated by Bug Clerk almost 3 years ago

  • Status changed from In Progress to Ready for Testing

#8 Updated by Bug Clerk almost 3 years ago

  • Copied to Bug #75910: SAMBA's Recycle bin does not work if there are several datasets added

#9 Updated by Dru Lavigne almost 3 years ago

  • Subject changed from SAMBA's Recycle bin does not work if there are several datasets to Fix ordering issue to allow recycle bin across ZFS datasets
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#12 Avatar?id=55038&size=24x24 Updated by Zackary Welch over 2 years ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Confirmed fixed in 11.2-U3.

#14 Updated by Dru Lavigne over 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF