Project

General

Profile

Bug #73695

Password fix for Dynamic DNS

Added by Bug Clerk almost 3 years ago. Updated over 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Waqar Ahmed
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Related issues

Related to FreeNAS - Bug #73191: Bug fix for Dynamic DNSDone
Copied from FreeNAS - Bug #73587: Password fix for Dynamic DNSDone

History

#1 Updated by Bug Clerk almost 3 years ago

  • Copied from Bug #73587: Password fix for Dynamic DNS added

#2 Updated by Bug Clerk almost 3 years ago

  • Status changed from Unscreened to In Progress

#3 Updated by Waqar Ahmed almost 3 years ago

  • Related to Bug #73191: Bug fix for Dynamic DNS added

#4 Updated by Waqar Ahmed almost 3 years ago

Acceptance Criteria
First password value should be checked by

midclt call dyndns.config

Then we should enter domains only in Dynamic DNS form in legacy UI making sure that nothing else is changed. Being done with those, we now repeat the above call and it should display the same password as before making changes to the form in legacy UI.

#5 Updated by Dru Lavigne almost 3 years ago

  • Target version changed from Master - FreeNAS Nightlies to 11.2-U3

#7 Updated by Waqar Ahmed almost 3 years ago

  • Status changed from In Progress to Ready for Testing

#8 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Ready for Testing to Done
  • Target version changed from 11.2-U3 to Master - FreeNAS Nightlies
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#9 Updated by Bug Clerk almost 3 years ago

  • Status changed from Done to Ready for Testing

#10 Updated by Dru Lavigne almost 3 years ago

  • Description updated (diff)
  • Target version changed from Master - FreeNAS Nightlies to 11.2-U3

#11 Updated by Dru Lavigne almost 3 years ago

  • Needs QA changed from No to Yes

#13 Avatar?id=55038&size=24x24 Updated by Zackary Welch over 2 years ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Confirmed fixed in 11.2-U3.

Testing Steps:
1. 'midclt call dyndns.config' in shell. Password value is "freenas", the default. This is expected, since I haven't touched Dynamic DNS yet.
2. Went in the legacy UI in Services->Dynamic DNS and only set provider, didn't set password. Checked 'midclt call dyndns' and saw password was still "freenas".

That's all. The issue previously was that the password was being replaced with garbage. Cannot test in the new UI since setting the password is required. I also tested changing the password in the old and new UI and it works fine, but that's outside the scope of the ticket.

#14 Updated by Dru Lavigne over 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF