Project

General

Profile

Bug #73917

Remove setting vm.kmem_size from autotuner and purge previously set values

Added by Alexander Motin almost 3 years ago. Updated over 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Ryan Moeller
Category:
OS
Target version:
Seen in:
Severity:
Low
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Since about FreeBSD 11.1 ZFS ARC started use 4KB memory allocations (ABD). Since it matches x86 page size, it triggers kernel optimization, using direct map of physical RAM instead of KVA on 64-bit platforms. As result, we have now much lower KVA pressure and also much lower fragmentation, that means we don't need to additionally increase KVA size and should be fine with default value.

Also, since every other tunables set by autotuner are sysctl's, we may now avoid additional reboot after inetall/upgrade in number of cases, previously needed to set this tunable.


Related issues

Copied to FreeNAS - Bug #77610: Remove setting vm.kmem_size from autotuner and purge previously set valuesReady for Testing

Associated revisions

Revision 991c5550 (diff)
Added by Ryan Moeller almost 3 years ago

[autotune] Don't touch vm.kmem_size The default value should be optimal since about FreeBSD 11.1. Ticket: #73917

Revision 362cbaff (diff)
Added by Ryan Moeller almost 3 years ago

[autotune] Don't touch vm.kmem_size The default value should be optimal since about FreeBSD 11.1. Ticket: #73917

Revision db8ea13b (diff)
Added by Ryan Moeller almost 3 years ago

[migrations] Remove autotuned vm.kmem_size tunable We don't need to additionally increase KVA size and should be fine with default value. Purge previously set values. Ticket: #73917

Revision e67dc464 (diff)
Added by Ryan Moeller almost 3 years ago

[migrations] Fix migration location/dependency This migration applies to a system model, not services. It depends only on the initial schema. Ticket: #73917

Revision 8906f6d5 (diff)
Added by Ryan Moeller almost 3 years ago

[migrations] Fix migration location/dependency This migration applies to a system model, not services. It depends only on the initial schema. Unfortunately we can't easily remove the other migration, but at least it is harmless to leave there. Ticket: #73917

Revision 384f8e3f (diff)
Added by Ryan Moeller almost 3 years ago

[system/migrations] Remove autotuned vm.kmem_size Since about FreeBSD 11.1 ZFS ARC started use 4KB memory allocations (ABD). This allows it to bypass KVA, so we don't need to increase KVA size and should be fine with the default value. Purge previously set values. Ticket: #73917

Revision 4341bdc4 (diff)
Added by Ryan Moeller almost 3 years ago

[system/migrations] Remove autotuned vm.kmem_size Since about FreeBSD 11.1 ZFS ARC started use 4KB memory allocations (ABD). This allows it to bypass KVA, so we don't need to increase KVA size and should be fine with the default value. Purge previously set values. Ticket: #73917

Revision 13802eac (diff)
Added by Ryan Moeller almost 3 years ago

[system/migrations] Remove autotuned vm.kmem_size Since about FreeBSD 11.1 ZFS ARC started use 4KB memory allocations (ABD). This allows it to bypass KVA, so we don't need to increase KVA size and should be fine with the default value. Purge previously set values. Ticket: #73917

Revision 7b50c0d6 (diff)
Added by Ryan Moeller almost 3 years ago

[system/migrations] Merge migration Ticket: #73917

Revision 6ccb0a35 (diff)
Added by Ryan Moeller almost 3 years ago

[system/migrations] Remove autotuned vm.kmem_size Since about FreeBSD 11.1 ZFS ARC started use 4KB memory allocations (ABD). This allows it to bypass KVA, so we don't need to increase KVA size and should be fine with the default value. Purge previously set values. Ticket: #73917

Revision d8c05cce (diff)
Added by Ryan Moeller almost 3 years ago

[system/migrations] Merge migration Ticket: #73917

Revision 53a2f02d (diff)
Added by Ryan Moeller almost 3 years ago

[system/migrations] Merge migrations inception Ticket: #73917

Revision 5cbfeaa9 (diff)
Added by Ryan Moeller almost 3 years ago

[autotune] Don't touch vm.kmem_size The default value should be optimal since about FreeBSD 11.1. Ticket: #73917

Revision e16b9308 (diff)
Added by Ryan Moeller almost 3 years ago

[autotune] Don't touch vm.kmem_size The default value should be optimal since about FreeBSD 11.1. Ticket: #73917

History

#1 Updated by Alexander Motin almost 3 years ago

  • Description updated (diff)

#2 Updated by Ryan Moeller almost 3 years ago

  • Status changed from Unscreened to Screened

#3 Updated by Ryan Moeller almost 3 years ago

  • Status changed from Screened to In Progress

#4 Updated by Bug Clerk almost 3 years ago

  • Status changed from In Progress to Ready for Testing

#5 Updated by Bug Clerk almost 3 years ago

  • Target version changed from 11.2-U3 to 11.3-BETA1

#6 Updated by Ryan Moeller almost 3 years ago

  • Target version changed from 11.3-BETA1 to 11.2-U3
  • Needs Merging changed from Yes to No

Thanks Bug Clerk but I've got this one.

#8 Updated by Ryan Moeller almost 3 years ago

  • Status changed from Ready for Testing to In Progress
  • Needs Merging changed from No to Yes

#9 Updated by Ryan Moeller almost 3 years ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#10 Updated by Dru Lavigne almost 3 years ago

  • Copied to Bug #77610: Remove setting vm.kmem_size from autotuner and purge previously set values added

#14 Avatar?id=55038&size=24x24 Updated by Zackary Welch over 2 years ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Confirmed fixed in 11.2-U3.

#16 Updated by Dru Lavigne over 2 years ago

  • Status changed from Passed Testing to Done
  • Needs Doc changed from Yes to No

Also available in: Atom PDF