Project

General

Profile

Bug #73935

Allow non-word characters in pool/dataset/zvol names in APIv1

Added by Bug Clerk almost 3 years ago. Updated over 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Trying to unlock a pool through the new GUI in 11.2 gives the following JSON errors:

Error: SyntaxError: Unexpected end of JSON input
at JSON.parse (<anonymous>)
at e.t.json (http://192.168.0.10/ui/main.5e0d25dfb19b1248661c.bundle.js:1:1952335)
at e.t.handleError [as selector] (http://192.168.0.10/ui/main.5e0d25dfb19b1248661c.bundle.js:1:1963205)
at e.error (http://192.168.0.10/ui/main.5e0d25dfb19b1248661c.bundle.js:1:1842088)
at e._error (http://192.168.0.10/ui/main.5e0d25dfb19b1248661c.bundle.js:1:3737084)
at e.error (http://192.168.0.10/ui/main.5e0d25dfb19b1248661c.bundle.js:1:3736778)
at XMLHttpRequest.a (http://192.168.0.10/ui/main.5e0d25dfb19b1248661c.bundle.js:1:1954495)
at XMLHttpRequest.i (http://192.168.0.10/ui/main.5e0d25dfb19b1248661c.bundle.js:1:853535)
at t.invokeTask (http://192.168.0.10/ui/polyfills.4e42ab25a6112b333361.bundle.js:1:44121)
at Object.onInvokeTask (http://192.168.0.10/ui/main.5e0d25dfb19b1248661c.bundle.js:1:2610127)
at t.invokeTask (http://192.168.0.10/ui/polyfills.4e42ab25a6112b333361.bundle.js:1:44042)
at n.runTask (http://192.168.0.10/ui/polyfills.4e42ab25a6112b333361.bundle.js:1:39299)
at n.invokeTask [as invoke] (http://192.168.0.10/ui/polyfills.4e42ab25a6112b333361.bundle.js:1:45211)
at m (http://192.168.0.10/ui/polyfills.4e42ab25a6112b333361.bundle.js:1:55907)
at XMLHttpRequest.b (http://192.168.0.10/ui/polyfills.4e42ab25a6112b333361.bundle.js:1:56137)

It is one of three pools in my system, where the other two pools unlocked with no issues. The offending pool unlocked with no issues in the legacy GUI. The passphrase and recovery file were ok and correct.

The only difference between the three pools is that the offending pool's name contains a dot: "Mirror_1.5TB_backup" compared to "Red_3-6TB" and "WD_3TB_backup"

my_pool.png (54.5 KB) my_pool.png Bonnie Follweiler, 03/08/2019 10:21 AM
60060

Related issues

Has duplicate FreeNAS - Bug #77800: Unlocking a pool gives JSON errorsClosed
Has duplicate FreeNAS - Bug #78052: disk online/offline/replace rest call not work for pool with multipath disksClosed
Copied from FreeNAS - Bug #65943: Unlocking a pool gives JSON errorsDone

History

#1 Updated by Bug Clerk almost 3 years ago

  • Copied from Bug #65943: Unlocking a pool gives JSON errors added

#2 Updated by Bug Clerk almost 3 years ago

  • Status changed from Unscreened to In Progress

#3 Updated by Dru Lavigne almost 3 years ago

  • Target version changed from Master - FreeNAS Nightlies to 11.2-U3

#4 Updated by Bug Clerk almost 3 years ago

  • Status changed from In Progress to Ready for Testing

#5 Updated by Dru Lavigne almost 3 years ago

  • Subject changed from Unlocking a pool gives JSON errors to Allow non-word characters in pool/dataset/zvol names in APIv1
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#7 Updated by Dru Lavigne almost 3 years ago

  • Has duplicate Bug #77800: Unlocking a pool gives JSON errors added

#8 Updated by Lola Yang almost 3 years ago

  • Has duplicate Bug #78052: disk online/offline/replace rest call not work for pool with multipath disks added

#9 Updated by Vladimir Vinogradenko over 2 years ago

Acceptance Criteria

You should be able to perform operations on pools, datasets and zvols that contain a whitespace in their names via New UI.

E.g. you should be able to unlock pool "my pool" or delete dataset "my dataset"

#12 Updated by Bonnie Follweiler over 2 years ago

  • Status changed from Ready for Testing to Failed Testing

Tested in FreeNAS-11.2-U2-INTERNAL97
I could create a dataset with a space and delete it
When I try to create a pool with a space in it's name I get an error message (see screenshot) and I can't create the pool

#13 Updated by Bonnie Follweiler over 2 years ago

60060

#14 Updated by Bonnie Follweiler over 2 years ago

  • Status changed from Failed Testing to Passed Testing
  • Needs QA changed from Yes to No

By design there is no longer a way to create a pool with a space in the name per Vladimir so I am marking this ticket as Test Passed

#16 Updated by Dru Lavigne over 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF