Project

General

Profile

Bug #7402

two installs, two different usb key and same corruption errors

Added by Big Phil over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Sean Fagan
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I just installed two different versions (one from dec 31st, one from 24th I believe) on my system. I installed and started setting some things up and after a few days, after a reboot, it stopped working.

attached, you will find what is on the screen when it won't boot.

I was able to boot back into freenas, selecting freenas DEFAULT on the grub menu.

when booted in, there was a critical error. I checked zpool status and there were 6-12 corrupted files, one of them I remmember was a freenas .db file. I assumed the key was bad, so I went on to reinstall all.

I then reinstalled a later version, on a different USB Key (although same company, bought two at same time)

Both time, I DD'ed the installation image onto a usb key, then booted on that key to install on the other usb key. removed the key, rebooted on the install.

worked fine, applied updates, rebooted, used the nas again it worked fine. after some tweaks, I would no longer be able to connect to CIFS from my XBMC and couldn't connect either to SMB from my mac, although AFP from the mac worked fine. I tried stopping CIFS, restarting it, same old thing. I figured a reboot would help so I did.

When I booted back, I was stuck with the errors on the screen like on the attached png.

I rebooted back into freenas default, same errors on the boot pool.

first time I ra zpool status -v, I got one error , DB file again.

I started writing this ticket, then thought I'd do a scrub of the boot pool. then redid a zpool status -v, now two files were corrupted. here is the output.

[root@freenas ~]# zpool status -v
pool: freenas-boot
state: ONLINE
status: One or more devices has experienced an error resulting in data
corruption. Applications may be affected.
action: Restore the file in question if possible. Otherwise restore the
entire pool from backup.
see: http://illumos.org/msg/ZFS-8000-8A
scan: scrub repaired 0 in 0h0m with 2 errors on Mon Jan 5 21:06:27 2015
config:

NAME        STATE     READ WRITE CKSUM                                                                                      
freenas-boot ONLINE 0 0 2
da6p2 ONLINE 0 0 4

errors: Permanent errors have been detected in the following files:

freenas-boot/ROOT/FreeNAS-9.3-STABLE-201412312006@2015-01-01-17:45:45:/usr/local/lib/X11/fonts/dejavu/DejaVuSans-Bold.ttf   
freenas-boot/ROOT/FreeNAS-9.3-STABLE-201412312006:/data/freenas-v1.db

maybe it's because I booted the default in grub, but reporting is not showing anything (db corruption maybe?)

I attached a debug as well

let me know if there is a way I can rebuild or fix the corruption?
is there a way I can do a backup of all next install so that if this happens again I can set everything back up AS IS (I know I can save/reload ocnfig, but looking perhaps for quicker DD copy solution?
is this caused by two faulty key in your opinion? if so I will buy new ones and try again (any suggestions on good brands / recomendations?)

Windows_7.png (952 KB) Windows_7.png Big Phil, 01/05/2015 05:58 PM
1908

History

#1 Updated by tomekada scientiam over 5 years ago

Big Phil,

Here is a KB article that will help, at least in regards to checking your database for consistency.

Checking the FreeNAS/TrueNAS database for consistency

https://support.ixsystems.com/index.php?/Knowledgebase/Article/View/254/1/checking-the-freenastruenas-database-for-consistency

#2 Updated by Jordan Hubbard over 5 years ago

  • Category set to 1
  • Assignee set to Sean Fagan
  • Target version set to Unspecified

Thanks for the detailed information. This is weird!

#3 Updated by Sean Fagan over 5 years ago

  • Status changed from Unscreened to 15

I don't see what's weird about it -- this is a flaky thumb drive, and is giving bad bits (without errors) on reads. Or perhaps it's trashing them on the write; that's also possible. Either way, I don't see it as being anything we can do anything about.

What thumb drives are you using?

#4 Updated by Big Phil over 5 years ago

hey Guys! Sorry for the delays, I was unavailable...

Kingston 8GB USB3.0 DataTraveler 100 G3 USB Flash Drive

so you think it's simply a case of bad mem stick? I tried two of the same brand.... figured if it did it twice it would be something else...

I'll try different sticks and do another fresh install and see.

Otherwize, what are recommended usb sticks ? I might just purchase a new one to rule that out

#5 Updated by Cyber Jock over 5 years ago

I have used Corsair Voyagers without problems for more than 2 years (got about 10 machines for friends and such running on them with no failures to date).

#6 Updated by Big Phil over 5 years ago

So far so good guys, goodl old voyagers doing the job ;)

I will re-open ticket if need be, you can close!

#7 Updated by Jordan Hubbard over 5 years ago

  • Status changed from 15 to Resolved

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

#9 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-freenas-20150105211118.tgz)

Also available in: Atom PDF