Project

General

Profile

Bug #7414

Mount failed with error #2

Added by Michael Dunn almost 6 years ago. Updated almost 6 years ago.

Status:
Closed: Cannot reproduce
Priority:
Nice to have
Assignee:
Xin Li
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I know this issue is out there and it is reported as solved with some looping delay, but i don't think the work around works. The error I get is "Mounting from zfs:freenas-boot/ROOT/default failed with error 2"

I just spent a better part of a day trying to install 9.3 on a Sandisk ultra 3.0 32 GB. I can install 9.2 fine. However when I try to upgrade, it boots fine, then when it tries to mount, i get the error. I installed the latest stable GUI upgrade file and it loops for a while and then stops. It won't find the USB stick. It is a USB 3 stick. I have disable USB 3 in the bios. I plug the stick into a USB 2 slot (If i plug into the USB 3 slot, even 9.2 won't boot).

I think this error needs to be relooked at and not "worked around" with some looping that only fixed it for slow drives. My stick is not slow and it is brand new.

My latest build was with FreeNAS-9.3-STABLE-201412312006.GUI_Upgrade.txz

History

#1 Updated by Jordan Hubbard almost 6 years ago

Why are the Seen in / Target versions set for Milestone 3 of 9.3? It's already released! Is the bug reporter really testing such old code?

We also need a lot more information about their HW config (motherboard, BIOS, chipset, etc) since we can't fix what we can't reproduce, and while we've been "looking at it" for weeks now, we still have no idea what is going on.

#2 Updated by 4M8 l93 almost 6 years ago

From time to time I also get "Mouting from zfs:freenas-boot/ROOT/$FREENAS_VERSION failed with error 2". Right now I am using FreeNAS-9.3-STABLE-201412312006 but I already saw that error in older versions of FreeNAS 9.3 - even already before it was released.
I couldn't figure out how I can reproduce it yet but it looks a lot like a race condition to me because on the next reboot, FreeNAS boots just fine.
The weird thing is that when I see the error message on the screen, all usb devices - including the thumb drive I want to boot FreeNAS from - seem to be powered off!

The contents of the screen when boot fails:
SMP: AP CPU #1 Launched!
Timecounter "TSC-low" frequency 1649553728 Hz quality 1000
Trying to mount root from zfs:freenas-boot/ROOT/FreeNAS-9.3-STABLE-201412312006
[]...
Mouting from zfs:freenas-boot/ROOT/FreeNAS-9.3-STABLE-201412312006 failed with
error 2.

Loader variables:
vfs.root.mountfrom=zfs:freenas-boot/ROOT/FreeNAS-9.3-STABLE-201412312006

Manual root filesystem specification:
<fstype>:<device> [options]
Mount <device> using filesystem <fstype>
and with the specified (optional) option list
...
mountroot>

#3 Updated by 4M8 l93 almost 6 years ago

Oh, and concerning my hardware config, I've got an ASRock H97M Pro4 Mainboard with a Core i5, 4 HDDs and a 8GB USB thumb drive. Do you have a simliar configuration, Michael Dunn?

#4 Updated by Michael Dunn almost 6 years ago

I don't really think it's a hardware issue and maybe an issue with FreeBSD as I've seen similar posts on their site.

I am sorry if I listed in the wrong target as that confused me. I tried to pick what I thought was the latest.

My MB is an also an ASRock but with H61M/U3S3 chipset & a celeron chip.

I see some stable builds on January 8. I will try those and see if it fixes the problem.

#5 Updated by Jordan Hubbard almost 6 years ago

  • Status changed from Unscreened to Closed: Cannot reproduce

Also available in: Atom PDF