Project

General

Profile

Bug #7438

Dtrace is unhappy

Added by Jordan Hubbard almost 6 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Important
Assignee:
Jordan Hubbard
Category:
-
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

[root@z30ref-a] ~# zilstat -p tank
dtrace: invalid probe specifier

ok....

[root@z30ref-a] /usr/local# dtrace -s ./libexec/freenas-debug/dtrace/disklatencycmd.d
dtrace: failed to compile script ./libexec/freenas-debug/dtrace/disklatencycmd.d: line 34: operator -> cannot be applied to a forward declaration: no struct devstat definition is available

Something is unhappy

Associated revisions

Revision 92c1d8e5 (diff)
Added by Sean Fagan almost 6 years ago

Change how the new boot environment is set up, so that grub-install can be run. This is more fragile, as it could potentially end up with a broken grub setup. I've hopefully error-checked that enough. Also change the post-upgrade script for base-os to re-install grub. Right now, this is going to do it on every update, which certainly isn't ideal, but it's the best I can do for the moment. I've tested this, but we should revert it if there are problems reported by it. Ticket: #7438

Revision 8e4a89cc (diff)
Added by Sean Fagan almost 6 years ago

Cherry-pick three changes: 92c1d8e5ab68b8d0834dd6fae9d822adb7b0559d Ticket: #7438 cfe2857df84274dca18dfad86845f55d310336ea Ticket: #7448 f93a668a0b81c6933b84d806c6006a107c65be23 Ticket: #7495

History

#1 Updated by Jordan Hubbard almost 6 years ago

  • Copied from Bug #6521: Dtrace is unhappy added

#2 Updated by Jordan Hubbard almost 6 years ago

  • Assignee changed from Xin Li to Sean Fagan

This is actually in Sean's queue now, waiting for him to figure out a way of updating grub on a live system.

#3 Updated by Sean Fagan almost 6 years ago

  • Blocked by Bug #7490: grub-install fails if /boot/grub is a nullfs mount added

#4 Updated by Sean Fagan almost 6 years ago

Did I not file bugs on the two issues? I thought I had, but can't find them now.

#5 Updated by Sean Fagan almost 6 years ago

  • Related to Bug #7491: Cannot unmount devfs if it is mounted inside a chrooted environment added

#6 Updated by Sean Fagan almost 6 years ago

Until this is resolved, one way or the other, with the current nightlies and stable builds, you can still manually install grub. This is basically just:

grub-install --modules="zfs part_gpt" /dev/${disk}

The problem is finding ${disk}. If "zpool status freenas-boot" does not list the gptids, you can just use those names. If it does, what I've done is:

foreach a (`sysctl -n kern.disks`)
gpart show ${a} | grep -q bios-boot && grub-install --modules="zfs part_gpt" /dev/$a
end

#7 Updated by Sean Fagan almost 6 years ago

92c1d8e5ab68b8d0834dd6fae9d822adb7b0559d

Note that I'm really not thrilled with this, due to some fragility, but I'm not sure we can get better.

This will not update grub until the second update that has it, since it changes the update code.

#8 Updated by Sean Fagan almost 6 years ago

  • Assignee changed from Sean Fagan to Jordan Hubbard

I cannot set this to Ready for Release. Over to Jordan to deal with.

#9 Updated by Jordan Hubbard almost 6 years ago

  • Status changed from Fix In Progress to Unscreened

#10 Updated by Jordan Hubbard almost 6 years ago

  • Status changed from Unscreened to Fix In Progress

#11 Updated by Jordan Hubbard almost 6 years ago

  • Target version changed from Unspecified to 49

I can't close it either. Something is seriously wrong with this bug! I'm... mystified. I'll at least change its Target Version so it doesn't show up in the queries.

#12 Updated by Jordan Hubbard almost 6 years ago

  • Target version changed from 49 to Unspecified

#13 Updated by Jordan Hubbard almost 6 years ago

  • Blocked by deleted (Bug #7490: grub-install fails if /boot/grub is a nullfs mount)

#14 Updated by Jordan Hubbard almost 6 years ago

  • Related to deleted (Bug #7491: Cannot unmount devfs if it is mounted inside a chrooted environment)

#15 Updated by Jordan Hubbard almost 6 years ago

  • Copied from deleted (Bug #6521: Dtrace is unhappy)

#16 Updated by Jordan Hubbard almost 6 years ago

  • Status changed from Fix In Progress to Resolved

#17 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

Also available in: Atom PDF