Project

General

Profile

Bug #7448

Let's try avoiding an extra reboot on updating

Added by Sean Fagan over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Sean Fagan
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When doing an update to either base-os or freenasUI, it touches the sentinel files to indicate ix-update should, um, update. This then requires another reboot.

Per conversation with Josh, when doing an update, I believe I can instead do:

yes | /usr/local/bin/python /usr/local/www/freenasUI/manage.py migrate --all --merge --delete-ghost-migrations

So let's try it. (I've done an update using it, and it seems to have worked. But I'd tried this before, and it didn't work, but I was not doing it at the right times, I think.)


Related issues

Related to FreeNAS - Bug #7495: Updating incorrectly indicates it failedResolved2015-01-13

Associated revisions

Revision cfe2857d (diff)
Added by Sean Fagan over 5 years ago

Remove the update scripts I never used. When doing an update for base-os and freenasUI, do the database migration in the chroot'ed environment. Ticket: #7448

Revision 8e4a89cc (diff)
Added by Sean Fagan over 5 years ago

Cherry-pick three changes: 92c1d8e5ab68b8d0834dd6fae9d822adb7b0559d Ticket: #7438 cfe2857df84274dca18dfad86845f55d310336ea Ticket: #7448 f93a668a0b81c6933b84d806c6006a107c65be23 Ticket: #7495

History

#1 Updated by Sean Fagan over 5 years ago

cfe2857df84274dca18dfad86845f55d310336ea

I'm leaving this as "Fix In Progress" for a while; I want to see if anyone runs into problems. At which point I'll revert this as quick as I can.

#2 Updated by Cyber Jock over 5 years ago

So let me ask this silly question... assuming I have some tunables and sysctls set in the WebGUI, can I expect that without the "extra reboot" they would be properly applied? I thought back in 8.x this was one of the reasons for the extra reboots. So that the user-experience would be such that once the box was "up" for good that all of the WebGUI settings would be properly applied.

#3 Updated by Sean Fagan over 5 years ago

It should. Otherwise it's not working.

#4 Updated by Sean Fagan over 5 years ago

  • Related to Bug #7495: Updating incorrectly indicates it failed added

#5 Updated by Sean Fagan over 5 years ago

  • Status changed from Fix In Progress to Ready For Release

#6 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Ready For Release to Resolved

#7 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

Also available in: Atom PDF