Project

General

Profile

Bug #74515

freenas web vnc truncates ipv6 addresses

Added by Inq . 6 months ago. Updated 5 months ago.

Status:
Done
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Seen in:
Severity:
Low Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

If a freenas 11.2 U1 system is configured with an ipv6 alias (dual stack) the web vnc defaults to the ipv6 address but fails to correctly parse the whole address to the browser.

vnc.png (92.5 KB) vnc.png Inq ., 02/08/2019 02:42 PM
53608

Related issues

Copied to FreeNAS - Bug #77206: Properly display vnc web url when host uses an IPv6 addressDone

Associated revisions

Revision 45127a3e (diff)
Added by William Grzybowski 6 months ago

fix(vm): vnc web url when host is an ipv6 address

Ticket: #74515

Revision 9d5c2ab4 (diff)
Added by William Grzybowski 6 months ago

fix(vm): vnc web url when host is an ipv6 address

Ticket: #74515

Revision d721b526 (diff)
Added by William Grzybowski 6 months ago

fix(vm): vnc web url when host is an ipv6 address

Ticket: #74515

History

#1 Updated by Dru Lavigne 6 months ago

  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-U3

#2 Updated by Erin Clark 6 months ago

  • Assignee changed from Erin Clark to Lola Yang

#3 Updated by William Grzybowski 6 months ago

  • Category changed from GUI (new) to Middleware
  • Assignee changed from Lola Yang to William Grzybowski
  • Severity changed from New to Low Medium

#4 Updated by Bug Clerk 6 months ago

  • Status changed from Unscreened to In Progress

#5 Updated by Bug Clerk 6 months ago

  • Status changed from In Progress to Ready for Testing

#6 Updated by Bug Clerk 6 months ago

  • Target version changed from 11.2-U3 to 11.3-BETA1

#7 Updated by Bug Clerk 6 months ago

  • Copied to Bug #77206: Properly display vnc web url when host uses an IPv6 address added

#8 Updated by Dru Lavigne 6 months ago

  • Status changed from Ready for Testing to Done
  • Target version changed from 11.3-BETA1 to Master - FreeNAS Nightlies
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#10 Updated by Inq . 5 months ago

The issue is still present after upgrading to 11.2 U3. Tested with Chrome 73 and Microsoft Edge.

#11 Updated by Dru Lavigne 5 months ago

Inq . wrote:

The issue is still present after upgrading to 11.2 U3. Tested with Chrome 73 and Microsoft Edge.

Please create a new ticket that includes a screenshot of the truncation from the U3 system.

#12 Updated by Dru Lavigne 5 months ago

It was supposed to be fixed for U3 on the related ticket so I'll relate your new ticket to #77206. Thanks!

Also available in: Atom PDF