Project

General

Profile

Bug #74551

Regression: Allow SMB to use the same path for multiple shares in 11.2

Added by Joshua Sirrine 2 months ago. Updated about 2 months ago.

Status:
Done
Priority:
No priority
Assignee:
Andrew Walker
Category:
Middleware
Seen in:
Severity:
High
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When attempting to use the same path for multiple shares I get the message "A share with this path already exists." in the GUI. Please fix as this is a legitimate configuration and is required for TrueNAS customers.

I have 2 shares for the same path, one that is writeable (named docs) and one that is readonly (named docs_readonly). Unfortunately, the GUI will not let you do this (this has worked on all builds up to 11.2). In my particular test environment, the shares have been setup and working for a long time, but I cannot edit either share because I get denied due to the error.


Related issues

Copied to FreeNAS - Bug #76386: Allow multiple SMB shares to have same path but prevent multiple shares with same nameDone

History

#1 Updated by Dru Lavigne 2 months ago

  • Assignee changed from Bill O'Hanlon to Andrew Walker

#2 Updated by William Grzybowski 2 months ago

  • Category changed from GUI (new) to Middleware
  • Target version changed from Backlog to 11.2-U3

#3 Updated by Bug Clerk about 2 months ago

  • Status changed from Unscreened to In Progress

#4 Updated by Bug Clerk about 2 months ago

  • Status changed from In Progress to Ready for Testing

#5 Updated by Bug Clerk about 2 months ago

  • Target version changed from 11.2-U3 to 11.3-BETA1

#6 Updated by Bug Clerk about 2 months ago

  • Copied to Bug #76386: Allow multiple SMB shares to have same path but prevent multiple shares with same name added

#7 Updated by Dru Lavigne about 2 months ago

  • Status changed from Ready for Testing to Done
  • Target version changed from 11.3-BETA1 to Master - FreeNAS Nightlies
  • Needs QA changed from Yes to No
  • Needs Merging changed from Yes to No

Also available in: Atom PDF