Project

General

Profile

Feature #74659

Request to add oce driver support

Added by Sajeev Ramasamy 2 months ago. Updated 2 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Alexander Motin
Category:
Hardware
Target version:
Estimated time:
Severity:
New
Reason for Closing:
Third Party to Resolve
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

I have an emulex chipset HP NC550SFP 10gbe nic which i would like to use in my freenas build. The current version doesn't seem to include the drivers for it. Can you guys add it to the latest build?

84438d48-0d15-4cf3-94fb-6da1e1f412ea.jpg (187 KB) 84438d48-0d15-4cf3-94fb-6da1e1f412ea.jpg Fatal 12 error Sajeev Ramasamy, 02/11/2019 08:36 AM
53797

Related issues

Related to FreeNAS - Bug #45622: Update oce(4) Emulex driver Done

History

#1 Updated by Dru Lavigne 2 months ago

  • Assignee changed from Release Council to Alexander Motin

#2 Updated by Alexander Motin 2 months ago

  • Related to Bug #45622: Update oce(4) Emulex driver added

#3 Updated by Alexander Motin 2 months ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

FreeNAS includes oce(4) driver for last 3 years. In FreeNAS 11.2 we updated it to the latest version from FreeNAS head (#45622), make sure you've tried it. If that is not enough, I am not sure what else we can do. Please tell more about the problem or direct it to upstream FreeBSD or the hardware vendor.

#4 Updated by Sajeev Ramasamy 2 months ago

53797

Alexander Motin wrote:

FreeNAS includes oce(4) driver for last 3 years. In FreeNAS 11.2 we updated it to the latest version from FreeNAS head (#45622), make sure you've tried it. If that is not enough, I am not sure what else we can do. Please tell more about the problem or direct it to upstream FreeBSD or the hardware vendor.

I got a Fatal trap 12 on boot when i added the nic, someone on the forum adviced me that the oce driver is missing and that's what's causing this error. I have attached a copy of the error.

#5 Updated by Alexander Motin 2 months ago

  • Status changed from Blocked to Closed
  • Reason for Closing set to Third Party to Resolve
  • Reason for Blocked deleted (Need additional information from Author)

This definitely does not tell that the driver is missing, it tells opposite, plus it tells that the driver identified the hardware enough to attach to it. Unfortunately something after that went wrong. Since we don't use/sell these NICs we can not even reproduce the issue, so I don't think we can help with this. You may try 11.3-nightly build to see whether it help (though I am skeptical about it). Then I'd recommend you to report it to FreeBSD upstream or the respective hardware vendor, and if there will be fixes, we'll happily integrate them.

#6 Updated by Dru Lavigne 2 months ago

  • Target version changed from Backlog to N/A

#7 Updated by Sajeev Ramasamy 2 months ago

Alexander Motin wrote:

This definitely does not tell that the driver is missing, it tells opposite, plus it tells that the driver identified the hardware enough to attach to it. Unfortunately something after that went wrong. Since we don't use/sell these NICs we can not even reproduce the issue, so I don't think we can help with this. You may try 11.3-nightly build to see whether it help (though I am skeptical about it). Then I'd recommend you to report it to FreeBSD upstream or the respective hardware vendor, and if there will be fixes, we'll happily integrate them.

The driver in FreeNAS 11.1 U7 works fine, so i thought of copying it to 11.2, but i'm not able to find if_oce.ko in /boot/kernel nor /boot/modules. Can you tell me where it might be located? And if i do replace this working driver with the problematic one, do you think this option is feesable?

#8 Updated by Alexander Motin 2 months ago

The driver is statically linked into the kernel, so you can not replace it easily. In 11.2 the driver was updated, but I guess that is what caused the problem. The driver is developed and provided as-is by Emulex/Broadcom, so please bring their attention to the problem.

#9 Updated by Sajeev Ramasamy 2 months ago

Alexander Motin wrote:

The driver is statically linked into the kernel, so you can not replace it easily. In 11.2 the driver was updated, but I guess that is what caused the problem. The driver is developed and provided as-is by Emulex/Broadcom, so please bring their attention to the problem.

ok thanks

Also available in: Atom PDF