Project

General

Profile

Bug #7517

Unable to write to boot-environment.

Added by Ryan Hunt over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Sean Fagan
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I'm using a HP N54L setup, with 16gb Ram (ECC) and 7x 2tb Sata disks.

I am booting from USB (front of the case).
I installed the latest stable release (FreeNAS-9.3-STABLE-201501150211)

I installed by copying the ISO to a 4GB USB stick, and installed FreeNAS to a separate 8GB USB stick.
Rebooted, system boots up fine.

When I try to do a system update from the WebUI, I get the error "Error: Unable to mount boot-environment FreeNAS-9.3-STABLE-20150115021"
When I try the same via the terminal (option 10) I get a similar error.

PHOTO_20150115_173657.jpg (1.98 MB) PHOTO_20150115_173657.jpg Roman Khavr, 01/15/2015 07:40 AM
PHOTO_20150115_173734.jpg (2.6 MB) PHOTO_20150115_173734.jpg Roman Khavr, 01/15/2015 07:40 AM
1970
1971

Related issues

Has duplicate FreeNAS - Bug #7527: 201501151844 Update FailsClosed: Duplicate2015-01-15
Has duplicate FreeNAS - Bug #7549: Unable to mount boot-environment FreeNAS-9.3-STABLE-201501162230Closed: Not To Be Fixed2015-01-16
Copied to FreeNAS - Bug #7521: Update process gets EOPNOTSUPP in mounted /devResolved2015-01-15

Associated revisions

Revision cc10c988 (diff)
Added by Sean Fagan over 5 years ago

Typo in the Update code. *Stupid* typo. Ticket: #7517

Revision 8962012d (diff)
Added by Sean Fagan over 5 years ago

Typo in the Update code. *Stupid* typo. Ticket: #7517

History

#1 Updated by Roman Khavr over 5 years ago

1970
1971

Hi!
I have this bug too... clean install freenas on 2 hdd

Ryan Hunt wrote:

I'm using a HP N54L setup, with 16gb Ram (ECC) and 7x 2tb Sata disks.

I am booting from USB (front of the case).
I installed the latest stable release (FreeNAS-9.3-STABLE-201501150211)

I installed by copying the ISO to a 4GB USB stick, and installed FreeNAS to a separate 8GB USB stick.
Rebooted, system boots up fine.

When I try to do a system update from the WebUI, I get the error "Error: Unable to mount boot-environment FreeNAS-9.3-STABLE-20150115021"
When I try the same via the terminal (option 10) I get a similar error.

#2 Updated by Jordan Hubbard over 5 years ago

  • Category set to 1
  • Assignee set to Sean Fagan
  • Target version set to Unspecified

#3 Updated by Sean Fagan over 5 years ago

We need /var/log/debug.log that corresponds to when the update was attempted.

Alternately, you could do from the shell:

freenas-update -C /tmp/update check && freenas-update -C /tmp/update update

and get the output from that.

#4 Updated by Christoph Franke over 5 years ago

  • File debug.log added

Here is the output of a "tail -f /var/log/debug.log" while trying to update via the web interface. Hope it helps.

#5 Updated by Sean Fagan over 5 years ago

  • Status changed from Unscreened to Ready For Release

cc10c9882c8c971fa23a0bb5ad2927b0ee1c52d8

When this update is available, it may require going to the previous boot environment (that is, the one before FreeNAS-9.3-STABLE-201501150211) to work, since the error is in the update code. Alternately, one can edit /usr/local/lib/freenasOS/Update.py and change "arts" to "args".

#6 Updated by Christoph Franke over 5 years ago

  • File debug.log added

Manually updated Update.py that way and fixed the typo "arts" to "args". Update did not work either, got a different error message: [Errno 45] Operation not supported: '/tmp/tmpJbDOJr/dev/ufsid'

#7 Updated by Christoph Franke over 5 years ago

  • File debug.log added

#8 Updated by Sean Fagan over 5 years ago

This looks like it got an error between these two actions:

Jan 15 18:15:58 freenas updated.py: [freenasOS.Installer:641] Updated package base-os from 9.3-STABLE-82d7111-feea378-569ec27 to 9.3-STABLE-10199d3-2930742-97f6b5a in database
Jan 15 18:15:59 freenas updated.py: [freenasOS.Update:38] RunCommand(/sbin/umount, ['-f', '/tmp/tmpJbDOJr/boot/grub'])

The unmount is part of the cleanup when the installer failed. is there anything in /var/log/messages from 18:15:58 indicating an error?

#9 Updated by Christoph Franke over 5 years ago

Here is the the requested part of /var/log/messages.

Jan 15 18:15:04 freenas manage.py: [middleware.exceptions:38] [MiddlewareError: [Errno 45] Operation not supported: '/tmp/tmpfeSpOC/dev/pts']
Jan 15 18:15:59 freenas updated.py: [freenasOS.Update:741] Update got exception during update: [Errno 45] Operation not supported: '/tmp/tmpJbDOJr/dev/ufsid'
Jan 15 18:17:04 freenas manage.py: [middleware.exceptions:38] [MiddlewareError: [Errno 45] Operation not supported: '/tmp/tmpJbDOJr/dev/ufsid']

#10 Updated by Sean Fagan over 5 years ago

I'm flabbergasted. Something is doing something with entries in /dev in the mounted space, and it shouldn't be.

Note that it's not just the update code:
Jan 15 18:15:04 freenas manage.py: [middleware.exceptions:38] [MiddlewareError: [Errno 45] Operation not supported: '/tmp/tmpfeSpOC/dev/pts']

I'm copying this to a new bug.

#11 Updated by Sean Fagan over 5 years ago

  • Copied to Bug #7521: Update process gets EOPNOTSUPP in mounted /dev added

#12 Updated by Christoph Franke over 5 years ago

Do I need to be scared? This is a production machine, hope I did not break it by updating using the stable train ...

#13 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Ready For Release to Resolved

#14 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Resolved to Investigation

#15 Updated by Jordan Hubbard over 5 years ago

BRB: If the upgrade has failed, you are on your previous boot environment and should be OK. We are investigating the upgrade failure now.

#16 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Investigation to Resolved

BRB: Note that we are investigating in the related bug. This specific bug is resolved.

#17 Updated by Alexandre Trevizoli over 5 years ago

I tried from different machines and different usb sticks(all made from scratch) - same error. Tried on Virtual Box too, same error.
I think the problem is with FreeNAS-9.3-STABLE-201501150211
Follow complete trace:

[root@freenas] /# freenas-update -C /tmp/update check && freenas-update -C /tmp/update update
TryGetNetworkFile(http://update.freenas.org/FreeNAS/FreeNAS-9.3-STABLE/LATEST)
TryGetNetworkFile(http://update.freenas.org/FreeNAS/FreeNAS-9.3-STABLE/LATEST):  Read 4629 bytes total
TryGetNetworkFile(https://web.ixsystems.com/updates/ix_crl.pem)
TryGetNetworkFile(https://web.ixsystems.com/updates/ix_crl.pem):  Read 1028 bytes total
Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/freenas-update.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'bxrpTPJSjNIXFmPSFhr3AKxzNyEKsUKmyCwV9BOnRTO9zqA4gwjlioB5hHMBbQbR5oP2znyq7Dc5baXCG6ZHqb1OpGvsroTdUV+a+Lz6gM9sBeObnhhLUSQSfSwaf5d2A9g40mhFEX9L5rN3fpIQARQUe2eTWaTy9b1EDrx+E6xpgj+OV56W0Jy71ySK9u6pIrfAFqFYss+XKU+Gv8kmz7gkcNI9MGLienVXLQETFlxfjw+mF+C8UpeiLGjTnPQO7UgzP5Hre2TrVOqLE/RvT7VfZlnxlAQEZk2OjWkModbZe9fT3JdXNoQUAX2HrNry7HXXfSS8dFez842XCd4aRA==', '-R', '/tmp/tmpZgk185.pem']
Signature check succeeded
TryGetNetworkFile(https://web.ixsystems.com/updates/ix_crl.pem)
TryGetNetworkFile(https://web.ixsystems.com/updates/ix_crl.pem):  Read 1028 bytes total
Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/freenas-update.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'Wm6n+l1YaQp+sLaN1bHXoI6SN32Rl+a9oQ04pIlQnbTelViE9jKLPmWio5QOrr+7bqRqS1xhaiWkNIKZgndyMDyql90HeCwW/28bNHArGJa1L1CQJwjqxYSNZj4FoVCrYZA4ZYFciWqRW3fz7AmA6YTcV8Sp5cHRBm9GS68LHG2K7bGATMR3BJO0IWMeMNPCDatl9UKpJl3OWR94xdTM2EpOm07IW2KAmbrxXaWziwEdk9xBtuEp2yxGvHap6yzrdp+4DsqHcVHQ4YhLsSHGVJPcfVSBq0ryI3XinNCBxYhwFAtd50bwbyzPByzTrVoNoPRR69IW/sFi9sEKdJnYsA==', '-R', '/tmp/tmpCYDEJ9.pem']
Signature check succeeded
TryGetNetworkFile(https://web.ixsystems.com/updates/ix_crl.pem)
TryGetNetworkFile(https://web.ixsystems.com/updates/ix_crl.pem):  Read 1028 bytes total
Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/freenas-update.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'Wm6n+l1YaQp+sLaN1bHXoI6SN32Rl+a9oQ04pIlQnbTelViE9jKLPmWio5QOrr+7bqRqS1xhaiWkNIKZgndyMDyql90HeCwW/28bNHArGJa1L1CQJwjqxYSNZj4FoVCrYZA4ZYFciWqRW3fz7AmA6YTcV8Sp5cHRBm9GS68LHG2K7bGATMR3BJO0IWMeMNPCDatl9UKpJl3OWR94xdTM2EpOm07IW2KAmbrxXaWziwEdk9xBtuEp2yxGvHap6yzrdp+4DsqHcVHQ4YhLsSHGVJPcfVSBq0ryI3XinNCBxYhwFAtd50bwbyzPByzTrVoNoPRR69IW/sFi9sEKdJnYsA==', '-R', '/tmp/tmpEO5_5U.pem']
Signature check succeeded
Removing invalid or incomplete cached update
DownloadUpdate:  Will upgrade package base-os
DownloadUpdate:  Will upgrade package FreeNASUI
DownloadUpdate:  Will upgrade package freenas-pkg-tools
Searching for base-os-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz
Searching for base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz)
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 1048576 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 2097152 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 3145728 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 4194304 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 5242880 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 6291456 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 7340032 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 8388608 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 9437184 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 10485760 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 11534336 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 12582912 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 13631488 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 14680064 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 15728640 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 16777216 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 17825792 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 18874368 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 19922944 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 20971520 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 22020096 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 23068672 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 24117248 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 25165824 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 26214400 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 27262976 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 28311552 bytes
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/base-os-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 29190140 bytes total
Searching for FreeNASUI-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz
Searching for FreeNASUI-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/FreeNASUI-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz)
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/FreeNASUI-9.3-STABLE-10199d3-2930742-97f6b5a-9.3-STABLE-10594d6-cf4f77e-97f6b5a.tgz):  Read 58991 bytes total
Searching for freenas-pkg-tools-9.3-STABLE-10594d6.tgz
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/freenas-pkg-tools-9.3-STABLE-10594d6.tgz)
TryGetNetworkFile(http://update.freenas.org/FreeNAS/Packages/freenas-pkg-tools-9.3-STABLE-10594d6.tgz):  Read 53374 bytes total
TryGetNetworkFile(http://update.freenas.org/FreeNAS/FreeNAS-9.3-STABLE/ChangeLog.txt)
TryGetNetworkFile(http://update.freenas.org/FreeNAS/FreeNAS-9.3-STABLE/ChangeLog.txt):  Read 8516 bytes total
TryGetNetworkFile(https://web.ixsystems.com/updates/ix_crl.pem)
TryGetNetworkFile(https://web.ixsystems.com/updates/ix_crl.pem):  Read 1028 bytes total
Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/freenas-update.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'bxrpTPJSjNIXFmPSFhr3AKxzNyEKsUKmyCwV9BOnRTO9zqA4gwjlioB5hHMBbQbR5oP2znyq7Dc5baXCG6ZHqb1OpGvsroTdUV+a+Lz6gM9sBeObnhhLUSQSfSwaf5d2A9g40mhFEX9L5rN3fpIQARQUe2eTWaTy9b1EDrx+E6xpgj+OV56W0Jy71ySK9u6pIrfAFqFYss+XKU+Gv8kmz7gkcNI9MGLienVXLQETFlxfjw+mF+C8UpeiLGjTnPQO7UgzP5Hre2TrVOqLE/RvT7VfZlnxlAQEZk2OjWkModbZe9fT3JdXNoQUAX2HrNry7HXXfSS8dFez842XCd4aRA==', '-R', '/tmp/tmpawtU6a.pem']
Signature check succeeded
TryGetNetworkFile(https://web.ixsystems.com/updates/ix_crl.pem)
TryGetNetworkFile(https://web.ixsystems.com/updates/ix_crl.pem):  Read 1028 bytes total
Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/freenas-update.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'bxrpTPJSjNIXFmPSFhr3AKxzNyEKsUKmyCwV9BOnRTO9zqA4gwjlioB5hHMBbQbR5oP2znyq7Dc5baXCG6ZHqb1OpGvsroTdUV+a+Lz6gM9sBeObnhhLUSQSfSwaf5d2A9g40mhFEX9L5rN3fpIQARQUe2eTWaTy9b1EDrx+E6xpgj+OV56W0Jy71ySK9u6pIrfAFqFYss+XKU+Gv8kmz7gkcNI9MGLienVXLQETFlxfjw+mF+C8UpeiLGjTnPQO7UgzP5Hre2TrVOqLE/RvT7VfZlnxlAQEZk2OjWkModbZe9fT3JdXNoQUAX2HrNry7HXXfSS8dFez842XCd4aRA==', '-R', '/tmp/tmpN89olC.pem']
Signature check succeeded
TryGetNetworkFile(https://web.ixsystems.com/updates/ix_crl.pem)
TryGetNetworkFile(https://web.ixsystems.com/updates/ix_crl.pem):  Read 1028 bytes total
Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/freenas-update.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'bxrpTPJSjNIXFmPSFhr3AKxzNyEKsUKmyCwV9BOnRTO9zqA4gwjlioB5hHMBbQbR5oP2znyq7Dc5baXCG6ZHqb1OpGvsroTdUV+a+Lz6gM9sBeObnhhLUSQSfSwaf5d2A9g40mhFEX9L5rN3fpIQARQUe2eTWaTy9b1EDrx+E6xpgj+OV56W0Jy71ySK9u6pIrfAFqFYss+XKU+Gv8kmz7gkcNI9MGLienVXLQETFlxfjw+mF+C8UpeiLGjTnPQO7UgzP5Hre2TrVOqLE/RvT7VfZlnxlAQEZk2OjWkModbZe9fT3JdXNoQUAX2HrNry7HXXfSS8dFez842XCd4aRA==', '-R', '/tmp/tmpbyqXXV.pem']
Signature check succeeded
TryGetNetworkFile(https://web.ixsystems.com/updates/ix_crl.pem)
TryGetNetworkFile(https://web.ixsystems.com/updates/ix_crl.pem):  Read 1028 bytes total
Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/freenas-update.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'bxrpTPJSjNIXFmPSFhr3AKxzNyEKsUKmyCwV9BOnRTO9zqA4gwjlioB5hHMBbQbR5oP2znyq7Dc5baXCG6ZHqb1OpGvsroTdUV+a+Lz6gM9sBeObnhhLUSQSfSwaf5d2A9g40mhFEX9L5rN3fpIQARQUe2eTWaTy9b1EDrx+E6xpgj+OV56W0Jy71ySK9u6pIrfAFqFYss+XKU+Gv8kmz7gkcNI9MGLienVXLQETFlxfjw+mF+C8UpeiLGjTnPQO7UgzP5Hre2TrVOqLE/RvT7VfZlnxlAQEZk2OjWkModbZe9fT3JdXNoQUAX2HrNry7HXXfSS8dFez842XCd4aRA==', '-R', '/tmp/tmpdrrNPv.pem']
Signature check succeeded
TryGetNetworkFile(https://web.ixsystems.com/updates/ix_crl.pem)
TryGetNetworkFile(https://web.ixsystems.com/updates/ix_crl.pem):  Read 1028 bytes total
Verify command = ['/usr/local/libexec/verify_signature', '-K', '/usr/local/share/certs/freenas-update.pem', '-C', '/usr/local/share/certs/iX-CA.pem', '-S', u'bxrpTPJSjNIXFmPSFhr3AKxzNyEKsUKmyCwV9BOnRTO9zqA4gwjlioB5hHMBbQbR5oP2znyq7Dc5baXCG6ZHqb1OpGvsroTdUV+a+Lz6gM9sBeObnhhLUSQSfSwaf5d2A9g40mhFEX9L5rN3fpIQARQUe2eTWaTy9b1EDrx+E6xpgj+OV56W0Jy71ySK9u6pIrfAFqFYss+XKU+Gv8kmz7gkcNI9MGLienVXLQETFlxfjw+mF+C8UpeiLGjTnPQO7UgzP5Hre2TrVOqLE/RvT7VfZlnxlAQEZk2OjWkModbZe9fT3JdXNoQUAX2HrNry7HXXfSS8dFez842XCd4aRA==', '-R', '/tmp/tmpFXs87T.pem']
Signature check succeeded
Upgrade package base-os-9.3-STABLE-10199d3-2930742-97f6b5a to base-os-9.3-STABLE-10594d6-cf4f77e-97f6b5a
Upgrade package FreeNASUI-9.3-STABLE-10199d3-2930742-97f6b5a to FreeNASUI-9.3-STABLE-10594d6-cf4f77e-97f6b5a
Upgrade package freenas-pkg-tools-9.3-STABLE-10199d3 to freenas-pkg-tools-9.3-STABLE-10594d6
RunCommand(/usr/local/sbin/beadm, ['create', u'FreeNAS-9.3-STABLE-201501151844'])
GRUB configuration updated successfully
Created successfully
RunCommand(/sbin/zfs, ['snapshot', u'freenas-boot/grub@Pre-Upgrade-FreeNAS-9.3-STABLE-201501151844'])
RunCommand(/usr/local/sbin/beadm, ['mount', u'FreeNAS-9.3-STABLE-201501151844', '/tmp/tmp5Z3LCH'])
Mounted successfully on '/tmp/tmp5Z3LCH'
RunCommand(/sbin/umount, ['mount', u'FreeNAS-9.3-STABLE-201501151844', '/tmp/tmp5Z3LCH'])
umount: mount: statfs: No such file or directory
umount: mount: unknown file system
umount: FreeNAS-9.3-STABLE-201501151844: statfs: No such file or directory
umount: FreeNAS-9.3-STABLE-201501151844: unknown file system
RunCommand(/usr/local/sbin/beadm, ['unmount', '-f', u'FreeNAS-9.3-STABLE-201501151844'])
Boot environment 'FreeNAS-9.3-STABLE-201501151844' is not mounted
Unable to mount boot-environment FreeNAS-9.3-STABLE-201501151844
RunCommand(/usr/local/sbin/beadm, ['destroy', '-F', u'FreeNAS-9.3-STABLE-201501151844'])
GRUB configuration updated successfully
Destroyed successfully
Update got exception during update: Unable to mount boot-environment FreeNAS-9.3-STABLE-201501151844
RunCommand(/usr/local/sbin/beadm, ['destroy', '-F', u'FreeNAS-9.3-STABLE-201501151844'])
ERROR: Boot environment 'FreeNAS-9.3-STABLE-201501151844' does not exist
Traceback (most recent call last):
  File "/usr/local/bin/freenas-update", line 168, in <module>
    sys.exit(main())
  File "/usr/local/bin/freenas-update", line 153, in main
    rv = Update.ApplyUpdate(download_dir)
  File "/usr/local/lib/freenasOS/Update.py", line 746, in ApplyUpdate
    raise e
Exception: Unable to mount boot-environment FreeNAS-9.3-STABLE-201501151844

#18 Updated by Sean Fagan over 5 years ago

Right, that particular one is because of the "arts" typo. See my comments about it early in the bug report.

#19 Updated by Sean Fagan over 5 years ago

  • Has duplicate Bug #7527: 201501151844 Update Fails added

#20 Updated by Christoph Franke over 5 years ago

I am stuck with a system now that can't be upgraded via the GUI any more. The only installed boot-environment is FreeNAS-9.3-STABLE-201501150016. How can I get a working system again?

#21 Updated by Sean Fagan over 5 years ago

You can update using an ISO.

At this point, however, we do not know why you are having those ENOTSUP problems; that is being investigated in 7521, I"m not sure if you were aware of that?

#22 Updated by Christoph Franke over 5 years ago

No, I wasn't, sorry. Manually updating using an ISO worked, thanks!

#23 Updated by Sean Fagan over 5 years ago

  • Has duplicate Bug #7549: Unable to mount boot-environment FreeNAS-9.3-STABLE-201501162230 added

#24 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

#25 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug.log)

#26 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug.log)

#27 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug.log)

Also available in: Atom PDF