Project

General

Profile

Bug #75361

Update dns/mDNSResponder_nss to fix proftpd crash

Added by Vladimir Vinogradenko almost 3 years ago. Updated over 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Related issues

Copied from FreeNAS - Bug #74973: proftpd crashing at connection attemptDone

History

#1 Updated by Vladimir Vinogradenko almost 3 years ago

  • Copied from Bug #74973: proftpd crashing at connection attempt added

#2 Updated by Vladimir Vinogradenko almost 3 years ago

  • Target version changed from 11.1-U8 to 11.2-U3

#3 Updated by Vladimir Vinogradenko almost 3 years ago

#4 Updated by Vladimir Vinogradenko almost 3 years ago

Acceptance Criteria

FTP server with "Perform Reverse DNS Lookups" checkbox checked should be functional

#6 Updated by Bug Clerk almost 3 years ago

  • Status changed from Unscreened to In Progress

#7 Updated by Bug Clerk almost 3 years ago

  • Status changed from In Progress to Ready for Testing

#8 Updated by Dru Lavigne almost 3 years ago

  • Subject changed from proftpd crashing at connection attempt to Update dns/mDNSResponder_nss to fix proftpd crash
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#11 Avatar?id=55038&size=24x24 Updated by Zackary Welch over 2 years ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Confirmed fixed in 11.2-U3.

Testing Steps:
0. Reproduced this in 11.2-U2 and saw that if "Perform Reverse DNS Lookups" is enabled and one tries to connect to the FTP server, a '421' error is returned and a stack trace appears in the console.
1. Went to Services->FTP. Enabled both "Allow root login" and "Perform Reverse DNS Lookups". Then enabled the service.
2. Typed 'ftp IP' on my working machine, then typed 'root', followed by my password, then I was connected to /root (shown by pwd). Connecting is technically unnecessary, since 'ftp IP' would fail if the error still occurred.

#12 Updated by Dru Lavigne over 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF