Project

General

Profile

Bug #75522

"Init/shutdown scripts" UI gets confused if an entrey changes from script to command

Added by Stilez y 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Erin Clark
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I created a postinit script, saved it in the boot pool, and created an entry for it as a postinit script (using the file browsing icons to pick the ".sh" file)

I later decided to replace it by a one line command, to avoid crewating a file. I edited the above "init/shutdown" entry, changing script to command and typing my command into the UI, then saved.

It was listed in the index page as both script and command.

When I returned to the editing page, it wrongly showed as a script, not a command. Even blanking the "script" path didn't help, I had to delete the entry and create another.

s1.png (7.28 KB) s1.png Select a valid choice. POSTINIT is not one of the available choices. Stilez y, 02/19/2019 09:17 PM
s2.png (48 KB) s2.png Bottom item shown as both a script and a command Stilez y, 02/19/2019 09:21 PM
55093
55102

Related issues

Is duplicate of FreeNAS - Bug #60936: Fix bug in Init/Shutdown scripts create and edit modesDone

History

#1 Updated by Dru Lavigne 6 months ago

  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-U3

#2 Updated by Erin Clark 6 months ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Waiting for feedback

I cannot seem to reproduce this on U2, can you try updating and see if you can still reproduce this behavior?

#3 Updated by Stilez y 6 months ago

55093
55102

#4 Updated by Stilez y 6 months ago

My bad - dup. of issue #60936 - I hadn't spotted the update from U1 to U2.

#5 Updated by Dru Lavigne 6 months ago

  • Is duplicate of Bug #60936: Fix bug in Init/Shutdown scripts create and edit modes added

#6 Updated by Dru Lavigne 6 months ago

  • Status changed from Blocked to Closed
  • Target version changed from 11.2-U3 to N/A
  • Reason for Closing set to Duplicate Issue
  • Reason for Blocked deleted (Waiting for feedback)

Also available in: Atom PDF