Project

General

Profile

Bug #75766

Fix "Change User & Group Ownership" WebDAV option in new UI

Added by Reewer Sys over 1 year ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Erin Clark
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Even if I have unchecked "Change User & Group Ownership" due to creation of new share, it will change ownership to webdav and save check status

Associated revisions

Revision a10cd9a2 (diff)
Added by Erin Clark over 1 year ago

Change user & group ownership should be enabled by default Ticket: #75766

Revision f2c11ca5 (diff)
Added by Erin Clark over 1 year ago

Change user & group ownership should be enabled by default Ticket: #75766 (cherry picked from commit a10cd9a273ce3ec0f021c2a8c8abd1563697064c)

History

#1 Updated by Dru Lavigne over 1 year ago

  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-U3

#3 Updated by Erin Clark over 1 year ago

  • Category changed from Services to GUI (new)
  • Status changed from Unscreened to In Progress

It seems that the middleware auto sets this value by default if nothing is passed in (which is the case of the checkbox being left unchecked by default as it currently is and not being checked and unchecked). An easy fix to this is to check the box by default (as the old UI does) and then when the user unchecks the box it sets the value to false.

Stable PR: https://github.com/freenas/webui/pull/1943
Master PR: https://github.com/freenas/webui/pull/1944

Testing criteria: the checkbox for "Change User & Group Ownership" in Webdav will be checked by default and when unchecked and saved it will result in a share that does not have this option enabled.

#4 Updated by Reewer Sys over 1 year ago

Fixed description:

I have left unchecked "Change User & Group Ownership" due to creation of new share, it has changed ownership to webdav user and webdav group for all affected files and folders under selected folder and saved this wrong checked status. This bug is file-ownership-modification-issue

#5 Updated by Erin Clark over 1 year ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#6 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Sharing WebDAV to Fix "Change User & Group Ownership" WebDAV option in new UI
  • Needs Doc changed from Yes to No

#10 Avatar?id=55038&size=24x24 Updated by Zackary Welch over 1 year ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Confirmed fixed in 11.2-U3.

#12 Updated by Dru Lavigne over 1 year ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF