Project

General

Profile

Bug #7577

AFP Settings Error

Added by Stefan Bleicker over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Binding AFP Service restlts in Error.
System has one NIC/IP:

Request Method: POST
Request URL: http://192.168.0.5/admin/services/afp/edit/1/
Software Version: FreeNAS-9.3-STABLE-201501151844
Exception Type: NameError
Exception Value:

global name 'ValidationError' is not defined

Exception Location: /usr/local/www/freenasUI/../freenasUI/freeadmin/models/fields.py in validate, line 162
Server time: Mon, 19 Jan 2015 20:40:53 +0100
Traceback
Environment: Software Version: FreeNAS-9.3-STABLE-201501151844 Request Method: POST Request URL: http://192.168.0.5/admin/services/afp/edit/1/ Traceback: File "/usr/local/lib/python2.7/site-packages/django/core/handlers/base.py" in get_response 105. response = middleware_method(request, callback, callback_args, callback_kwargs) File "/usr/local/www/freenasUI/../freenasUI/freeadmin/middleware.py" in process_view 157. return login_required(view_func)(request, *view_args, **view_kwargs) File "/usr/local/lib/python2.7/site-packages/django/contrib/auth/decorators.py" in wrapped_view 22. return view_func(request, *args, **kwargs) File "/usr/local/www/freenasUI/../freenasUI/freeadmin/options.py" in wrapper 210. return self._admin.admin_view(view)(*args, **kwargs) File "/usr/local/lib/python2.7/site-packages/django/utils/decorators.py" in _wrapped_view 99. response = view_func(request, *args, **kwargs) File "/usr/local/lib/python2.7/site-packages/django/views/decorators/cache.py" in _wrapped_view_func 52. response = view_func(request, *args, **kwargs) File "/usr/local/www/freenasUI/../freenasUI/freeadmin/site.py" in inner 142. return view(request, *args, **kwargs) File "/usr/local/www/freenasUI/../freenasUI/freeadmin/options.py" in edit 527. valid &= mf.is_valid(formsets=formsets) File "/usr/local/www/freenasUI/../freenasUI/common/forms.py" in is_valid 114. valid = super(ModelForm, self).is_valid() File "/usr/local/lib/python2.7/site-packages/django/forms/forms.py" in is_valid 129. return self.is_bound and not bool(self.errors) File "/usr/local/lib/python2.7/site-packages/django/forms/forms.py" in errors 121. self.full_clean() File "/usr/local/lib/python2.7/site-packages/django/forms/forms.py" in full_clean 275. self._post_clean() File "/usr/local/lib/python2.7/site-packages/django/forms/models.py" in _post_clean 413. validate_unique=False) File "/usr/local/lib/python2.7/site-packages/django/db/models/base.py" in full_clean 928. self.clean_fields(exclude=exclude) File "/usr/local/lib/python2.7/site-packages/django/db/models/base.py" in clean_fields 970. setattr(self, f.attname, f.clean(raw_value, self)) File "/usr/local/lib/python2.7/site-packages/django/db/models/fields/_init__.py" in clean 255. self.validate(value, model_instance) File "/usr/local/www/freenasUI/../freenasUI/freeadmin/models/fields.py" in validate 162. raise ValidationError( Exception Type: NameError at /admin/services/afp/edit/1/ Exception Value: global name 'ValidationError' is not defined

Request information
GET

No GET data
POST
Variable Value
form_id u'dialogForm_AFP'
afp_srv_global_aux u''
afp_srv_dbpath u''
afp_srv_connections_limit u'50'
afp_srv_bindip u'192.168.0.5'
afp_srv_guest u'on'
afp_srv_homedir u''
__all
u''
afp_srv_guest_user u'nobody'
FILES

No FILES data
COOKIES
Variable Value
sessionid '2rs5odz0tm8wget7fds79r8s8f8utym1'
csrftoken 'cUJISuZJKUbEuo36IdMVe8YvtfXKqBx3'
fntreeSaveStateCookie 'root%2Croot%2F1%2Croot%2F1%2F7%2Croot%2F1%2F8'
META
Variable Value
DOCUMENT_URI '/admin/services/afp/edit/1/'
wsgi.multiprocess False
SERVER_PORT '80'
PATH_INFO u'/admin/services/afp/edit/1/'
HTTP_CONNECTION 'keep-alive'
wsgi.version (1, 0)
CONTENT_TYPE 'application/x-www-form-urlencoded; charset=UTF-8'
HTTP_ACCEPT 'text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8'
HTTP_USER_AGENT 'Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:35.0) Gecko/20100101 Firefox/35.0'
HTTP_REFERER 'http://192.168.0.5/'
wsgi.input <flup.server.fcgi_base.InputStream object at 0x8132fa5d0>
HTTP_CONTENT_TYPE 'application/x-www-form-urlencoded; charset=UTF-8'
wsgi.run_once False
SERVER_NAME 'localhost'
CONTENT_LENGTH '185'
wsgi.errors <flup.server.fcgi_base.TeeOutputStream object at 0x8132faf90>
REQUEST_URI '/admin/services/afp/edit/1/'
wsgi.url_scheme 'http'
HTTP_CONTENT_LENGTH '185'
REQUEST_METHOD 'POST'
SERVER_SOFTWARE 'nginx/1.6.2'
SCRIPT_NAME u''
HTTP_ACCEPT_ENCODING 'gzip, deflate'
REDIRECT_STATUS '200'
HTTP_CACHE_CONTROL 'no-cache'
HTTP_PRAGMA 'no-cache'
HTTP_HOST '192.168.0.5'
HTTP_X_CSRFTOKEN 'cUJISuZJKUbEuo36IdMVe8YvtfXKqBx3'
REMOTE_PORT '64365'
HTTP_ACCEPT_LANGUAGE 'de,en-US;q=0.7,en;q=0.3'
HTTP_X_REQUESTED_WITH 'XMLHttpRequest'
HTTPS ''
SERVER_PROTOCOL 'HTTP/1.1'
HTTP_COOKIE 'csrftoken=cUJISuZJKUbEuo36IdMVe8YvtfXKqBx3; sessionid=2rs5odz0tm8wget7fds79r8s8f8utym1; fntreeSaveStateCookie=root%2Croot%2F1%2Croot%2F1%2F7%2Croot%2F1%2F8'
wsgi.multithread True
CSRF_COOKIE u'cUJISuZJKUbEuo36IdMVe8YvtfXKqBx3'
SERVER_ADDR '192.168.0.5'
DOCUMENT_ROOT '/usr/local/etc/nginx/html'
GATEWAY_INTERFACE 'CGI/1.1'
QUERY_STRING ''
REMOTE_ADDR '192.168.0.12'


Related issues

Is duplicate of FreeNAS - Bug #7379: ValidationError in AFP configurationClosed: Duplicate2015-01-03

Associated revisions

Revision 2e054af8 (diff)
Added by William Grzybowski over 5 years ago

Add missing import for the validation error Ticket: #7577

Revision 2731fbe3 (diff)
Added by William Grzybowski over 5 years ago

Add missing import for the validation error Ticket: #7577 (cherry picked from commit 2e054af89f1b827fe2cca28d49b2ae2b6da783c9)

History

#1 Updated by Jordan Hubbard over 5 years ago

  • Category set to 78
  • Assignee set to Josh Paetzel
  • Target version set to Unspecified

#2 Updated by Josh Paetzel over 5 years ago

  • Is duplicate of Bug #7379: ValidationError in AFP configuration added

#3 Updated by Josh Paetzel over 5 years ago

  • Status changed from Unscreened to Screened

#4 Updated by Josh Paetzel over 5 years ago

  • Status changed from Screened to Fix In Progress
  • Assignee changed from Josh Paetzel to William Grzybowski

#5 Updated by William Grzybowski over 5 years ago

  • Status changed from Fix In Progress to Ready For Release

#6 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Ready For Release to Resolved

#7 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

Also available in: Atom PDF