Project

General

Profile

Bug #76000

Fix regression with user/group validation in AD environments

Added by Tatsuro Ogawa over 1 year ago. Updated about 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Andrew Walker
Category:
Services
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

1. Join FreeNAS to Active Directory.
2. Update SMB settings from Web Administration.
3. I get an error saying "nobody" can not be used as a guest account.


Related issues

Has duplicate FreeNAS - Bug #73389: Cannot edit crontabs created before 11.1 U7Closed
Has duplicate FreeNAS - Bug #75846: Cron Job with local user problem "user root is not valid".Closed
Copied to FreeNAS - Bug #76558: Fix regression with user/group validation in AD environmentsReady for Testing
Copied to FreeNAS - Bug #76566: Samba WebAdmin Failure "nobody" UserDone

History

#1 Updated by Tatsuro Ogawa over 1 year ago

  • File debug-dynamo-20190220044035.txz added
  • Private changed from No to Yes

#2 Updated by Dru Lavigne over 1 year ago

  • Category changed from Middleware to Services
  • Assignee changed from Release Council to William Grzybowski

#3 Updated by William Grzybowski over 1 year ago

  • Assignee changed from William Grzybowski to Andrew Walker
  • Target version changed from Backlog to 11.2-U3

Andrew, do you think this is a duplicate of the other issues we have seen?

#4 Updated by Andrew Walker over 1 year ago

This is duplicate of previous issues. I should have fix ready for testing with affected users today.

#5 Updated by Andrew Walker over 1 year ago

  • File freenasldap.py added

Hello Tatsuro, I have a WIP fix for the issue in 11.2-U2. I have attached it to this ticket. If you don't mind can you do the following if you have a maintenance window today:
1) clone your boot environment(i.e make a backup of it in case we need to roll back). This can be done under System->Boot Environments
2) replace the /usr/local/www/freenasui/common/freenasldap.py with the patched copy of it in this ticket
3) restart django and middlewared

service django restart
service middlewared restart

#6 Updated by Tatsuro Ogawa over 1 year ago

Thanks.
There was no error.

#7 Updated by Bug Clerk over 1 year ago

  • Status changed from Unscreened to In Progress

#8 Updated by Bug Clerk over 1 year ago

  • Status changed from In Progress to Ready for Testing

#9 Updated by Bug Clerk over 1 year ago

  • Copied to Bug #76558: Fix regression with user/group validation in AD environments added

#10 Updated by Bug Clerk over 1 year ago

  • Copied to Bug #76566: Samba WebAdmin Failure "nobody" User added

#11 Updated by Dru Lavigne over 1 year ago

  • Has duplicate Bug #73389: Cannot edit crontabs created before 11.1 U7 added

#12 Updated by Dru Lavigne over 1 year ago

  • File deleted (debug-dynamo-20190220044035.txz)

#13 Updated by Dru Lavigne over 1 year ago

  • File deleted (freenasldap.py)

#14 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Samba WebAdmin Failure "nobody" User to Fix regression with user/group validation in AD environments
  • Private changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#15 Updated by Dru Lavigne over 1 year ago

  • Has duplicate Bug #75846: Cron Job with local user problem "user root is not valid". added

#16 Updated by Dru Lavigne over 1 year ago

  • Target version changed from 11.2-U3 to 11.2-U2.1

#17 Updated by Joe Maloney over 1 year ago

Andrew,
Please cherry-pick your fix and push it to this branch for 11.2-U2.1:

https://github.com/freenas/freenas/tree/freenas/11.2-u2.1

#18 Updated by Dru Lavigne over 1 year ago

  • Status changed from Ready for Testing to In Progress

#19 Updated by Bug Clerk over 1 year ago

  • Status changed from In Progress to Ready for Testing

#20 Updated by Bonnie Follweiler about 1 year ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

#22 Updated by Dru Lavigne about 1 year ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF