Project

General

Profile

Bug #76080

Use netstat -in in freenas-debug

Added by Bug Clerk almost 2 years ago. Updated almost 2 years ago.

Status:
Ready for Testing
Priority:
No priority
Assignee:
Caleb St. John
Category:
Middleware
Target version:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

In 11.1-U7, on a pre-production TrueNAS we were handed DNS IP addresses that were not working.

Since the TrueNAS was configured to use this DNS servers, this showed that netstat -i was taking a LONG time to run.

This caused the freenas-debug process from completing on the passive controller. This ticket is to change the netstat -i command to netstat -in so it only prints numeric IP addresses and stops trying to use the configured DNS servers.


Related issues

Copied from FreeNAS - Bug #75171: debug not capturing on passive controllerDone

History

#1 Updated by Bug Clerk almost 2 years ago

  • Copied from Bug #75171: debug not capturing on passive controller added

#2 Updated by Bug Clerk almost 2 years ago

  • Status changed from Unscreened to In Progress

#3 Updated by Bug Clerk almost 2 years ago

  • Status changed from In Progress to Ready for Testing

#4 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from debug not capturing on passive controller to Use netstat -in in freenas-debug
  • Target version changed from Master - FreeNAS Nightlies to 11.1-U8
  • Needs Merging changed from Yes to No

Also available in: Atom PDF