Project

General

Profile

Bug #76386

Allow multiple SMB shares to have same path but prevent multiple shares with same name

Added by Bug Clerk almost 2 years ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Andrew Walker
Category:
Middleware
Target version:
Severity:
High
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When attempting to use the same path for multiple shares I get the message "A share with this path already exists." in the GUI. Please fix as this is a legitimate configuration and is required for TrueNAS customers.

I have 2 shares for the same path, one that is writeable (named docs) and one that is readonly (named docs_readonly). Unfortunately, the GUI will not let you do this (this has worked on all builds up to 11.2). In my particular test environment, the shares have been setup and working for a long time, but I cannot edit either share because I get denied due to the error.


Related issues

Has duplicate FreeNAS - Bug #77458: SMB shareClosed
Copied from FreeNAS - Bug #74551: Regression: Allow SMB to use the same path for multiple shares in 11.2Done

History

#1 Updated by Bug Clerk almost 2 years ago

  • Copied from Bug #74551: Regression: Allow SMB to use the same path for multiple shares in 11.2 added

#2 Updated by Bug Clerk almost 2 years ago

  • Target version changed from Master - FreeNAS Nightlies to 11.2-U3

#3 Updated by Bug Clerk almost 2 years ago

  • Status changed from Unscreened to In Progress

#4 Updated by Bug Clerk almost 2 years ago

  • Status changed from In Progress to Ready for Testing

#5 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from Regression: Allow SMB to use the same path for multiple shares in 11.2 to Allow multiple SMB shares to have same path but prevent multiple shares with same name
  • Needs Doc changed from No to Yes
  • Needs Merging changed from Yes to No

#6 Updated by Dru Lavigne over 1 year ago

#12 Avatar?id=55038&size=24x24 Updated by Zackary Welch over 1 year ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Confirmed in 11.2-U3.

#14 Updated by Dru Lavigne over 1 year ago

  • Needs Doc changed from No to Yes

#16 Updated by Dru Lavigne over 1 year ago

  • Status changed from Passed Testing to Done
  • Needs Doc changed from Yes to No

Also available in: Atom PDF