Project

General

Profile

Bug #7653

'exceptions.IOError' object has no attribute 'encode'

Added by Dean Bergen over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Fresh install on 9.3 STABLE will not allow plugins to be installed, all attempts fail with:

Environment:

Software Version: FreeNAS-9.3-STABLE-201501212031
Request Method: POST
Request URL: http://192.168.1.5/plugins/plugin/install/cd63243d4208702043c688d0e48b3137410ecbccc505f357d140ab4d2bbcdb99/

Traceback:
File "/usr/local/lib/python2.7/site-packages/django/core/handlers/base.py" in get_response
105. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/middleware.py" in process_view
157. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python2.7/site-packages/django/contrib/auth/decorators.py" in wrapped_view
22. return view_func(request, *args, **kwargs)
File "/usr/local/www/freenasUI/../freenasUI/plugins/views.py" in install_available
284. raise MiddlewareError(e)
File "/usr/local/www/freenasUI/../freenasUI/middleware/exceptions.py" in init
38. log.warn(str(self))
File "/usr/local/www/freenasUI/../freenasUI/middleware/exceptions.py" in str
41. return "[%s: %s]" % (type(self).
_name__, self.value.encode('utf-8'))

Exception Type: AttributeError at /plugins/plugin/install/cd63243d4208702043c688d0e48b3137410ecbccc505f357d140ab4d2bbcdb99/
Exception Value: 'exceptions.IOError' object has no attribute 'encode'


Related issues

Is duplicate of FreeNAS - Bug #7686: Getting Error Uploading and Installing Plugins - 'exceptions.IOError' object has no attribute 'encode'Closed: Duplicate2015-01-26
Is duplicate of FreeNAS - Bug #8075: i cant install pluggin owncloud or plexClosed: Duplicate2015-02-18

Associated revisions

Revision bf302e4b (diff)
Added by William Grzybowski over 5 years ago

Handle IOError in plugin install Ticket: #7653

Revision c475cc99 (diff)
Added by William Grzybowski over 5 years ago

Handle IOError in plugin install Ticket: #7653 (cherry picked from commit bf302e4bd9222a5fb415a023cf29a67c5fa83948)

Revision a19664e4 (diff)
Added by William Grzybowski over 5 years ago

Handle IOError correctly Ticket: #7653

Revision 521bcfa4 (diff)
Added by William Grzybowski over 5 years ago

Handle IOError correctly Ticket: #7653 (cherry picked from commit a19664e40283c147b6d4a2e827c862bb0da76885)

History

#1 Updated by Joshua Ruehlig over 5 years ago

  • Assignee changed from Joshua Ruehlig to John Hixson

Seems more like a plugin system error then a specific plugin error. I think John is the one who handles these.

#2 Updated by Dean Bergen over 5 years ago

Joshua Ruehlig wrote:

Seems more like a plugin system error then a specific plugin error. I think John is the one who handles these.

I've reinstalled from scratch, same issue, I found other people reporting this problem as well over in the forums.

Thanks!

#3 Updated by Jordan Hubbard over 5 years ago

  • Assignee changed from John Hixson to William Grzybowski
  • Target version set to Unspecified

#4 Updated by RB RB over 5 years ago

I've the same issue with 9.3. I've installing from stratch

Version freenas: FreeNAS-9.3-STABLE-201501212031

#5 Updated by William Grzybowski over 5 years ago

  • Status changed from Unscreened to Screened

#6 Updated by William Grzybowski over 5 years ago

  • Status changed from Screened to Ready For Release

#7 Updated by William Grzybowski over 5 years ago

  • Is duplicate of Bug #7686: Getting Error Uploading and Installing Plugins - 'exceptions.IOError' object has no attribute 'encode' added

#8 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Ready For Release to Resolved

#9 Updated by Kirk Gleason over 5 years ago

For whatever it is worth, this still seems to be happening:

Environment:

Software Version: FreeNAS-9.3-STABLE-201501301837
Request Method: POST
Request URL: http://10.0.0.6/plugins/plugin/inst...b2317e31d56f87b0fb950952617b9cdc8e80126c67ba/

Traceback:
File "/usr/local/lib/python2.7/site-packages/django/core/handlers/base.py" in get_response
105. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/middleware.py" in process_view
157. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python2.7/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
22. return view_func(request, *args, **kwargs)
File "/usr/local/www/freenasUI/../freenasUI/plugins/views.py" in install_available
282. raise MiddlewareError(e.message)

Exception Type: UnboundLocalError at /plugins/plugin/install/95473cd8b8de9f049d17b2317e31d56f87b0fb950952617b9cdc8e80126c67ba/
Exception Value: local variable 'e' referenced before assignment

I'm admittedly new to this project, so I'm not certain if the resolution from 1/30/15 would have showed up in the STABLE release on 1/30/2015. I'm about to try the nightly from 1/30/2015

#10 Updated by William Grzybowski over 5 years ago

  • Status changed from Resolved to Ready For Release
  • Seen in changed from to

I have committed another fix.

#11 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Ready For Release to Resolved

#12 Updated by William Grzybowski over 5 years ago

  • Is duplicate of Bug #8075: i cant install pluggin owncloud or plex added

#13 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

Also available in: Atom PDF