Project

General

Profile

Bug #76891

file transfer with samba

Added by Giuseppe Pugliese over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Andrew Walker
Category:
Services
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Need additional information from Author
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No
Tags:

Description

Hello,

With last 2 release of FreeNas (11.2-U1 / 11.2-U2) I recorded several blocks during the transfer of large files around the giabyte to go up.

Windows 10 tells me about a network error reset. I tried to restart the server several times, check the ETH cables, and restart the machine I work on, without success.

The Blocks occur without apparent logical sense, on the machine with Windows 10 I did not install support to Samba 1.

Activating the FTP transfer service with no problem. I will run further tests from a Linux machine to see if the problem is attributable to Windows 10 1809.

debug-Spear_Of_Adun-20190223180639.txz (830 KB) debug-Spear_Of_Adun-20190223180639.txz Giuseppe Pugliese, 02/23/2019 10:06 AM

History

#1 Updated by Giuseppe Pugliese over 2 years ago

#2 Updated by Giuseppe Pugliese over 2 years ago

  • Private changed from Yes to No

#3 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to William Grzybowski
  • Private changed from No to Yes

#4 Updated by William Grzybowski over 2 years ago

  • Assignee changed from William Grzybowski to Andrew Walker
  • Target version changed from Backlog to 11.2-U4

#5 Updated by Andrew Walker over 2 years ago

You have several permissions problems:
There's a mismatch between your local domain sid "S-1-5-21-1271936739-3882587226-3867783591" and the ones in your group_mapping.tdb file "S-1-5-21-3217705719-330356844-1253540143-1005". This needs to be fixed. An easy way to do this is to perform the following series of commands:

service samba_server stop
rm /var/db/samba4/group_mapping.tdb
service ix-pre-samba start
service samba_server start

Your shares have permissions like this:

drwxrwxr-x  17 plexmediaserver  MagnetarMan  17 Jan 26 18:21 /mnt/Pool1/Media

# file: /mnt/Pool1/Media
# owner: plexmediaserver
# group: MagnetarMan
            owner@:rwxp--aARWcCos:-------:allow
            group@:rwxp--a-R-c--s:-------:allow
         everyone@:r-x---a-R-c--s:-------:allow


The above permissions set means that "MagnetarMan" lacks "delete", "delete child", "write attributes", "write extended attributes", "write permissions", and "change owner".
In this case it is probably a good idea to add an additional non-trivial ace for MagnetarMan to the share:
setfacl -a 0 u:MagnetarMan:full_set:fd:allow /mnt/Pool1/Media
winacl -a clone -r -p /mnt/Pool1/Media

Of course, you should review whether or not this is appropriate for your environment / data. Once you have done this try to reproduce the problem.

#6 Updated by Andrew Walker over 2 years ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

#7 Updated by Giuseppe Pugliese over 2 years ago

Ok Thanks for your help, but i think the problems is with Windows 10 Samba Share. In fact with Linux, no copy files problems detect.

Changes applied, with no Luck.

No problem detected even with the Torrent server, a Drobo 5N. Is it possible that it is a specific problem of the samba version included in the last updates?

Before moving to FreeNas version 11.2 I never had any problems. I will try to reboot the server with a previous version of FreeNas to check if the transfer problems cease. More information other information as soon as I have completed the tests,

UPDATE : Same Problem now with FTP protocol. Copy of two files from approximately 6GB each caused the same block of the transfer. Load a Live Linux Environment, copy same file in the same folder with no problem.

UPDATE II: After your permission changes, my Plex Jails not be able to delete Files in "Media" Dataset.

UPDATE III: After put the system under little pressure even Linux and the FTP protocol are crashed similarly to what was done with windows. Never had such problems with previous FreeNas releases. I'll roll back to version 11.1 that did not have any of these issues, hoping for your fix.

#8 Updated by Giuseppe Pugliese over 2 years ago

Giuseppe Pugliese wrote:

Hello,

With last 2 release of FreeNas (11.2-U1 / 11.2-U2) I recorded several blocks during the transfer of large files around the giabyte to go up.

Windows 10 tells me about a network error reset. I tried to restart the server several times, check the ETH cables, and restart the machine I work on, without success.

The Blocks occur without apparent logical sense, on the machine with Windows 10 I did not install support to Samba 1.

Activating the FTP transfer service with no problem. I will run further tests from a Linux machine to see if the problem is attributable to Windows 10 1809.

Good Morning,

After Many Days of Testing, FreeNas 11.2-U1 not show the problem with any service. For this Reasons, the problem may lie in the changes made or in the code added after the release of version 11.2-U1. Waiting to know if there is a possible solution, I believe I remain block in this version, which is quite stable. The possibility of easily updating the Plugins in the Jail is still lacking since the "update" button does not work, but for this we await updates.

Thanks again for the support.

#9 Updated by Giuseppe Pugliese over 2 years ago

  • Private changed from Yes to No

#10 Updated by Jaron Parsons over 2 years ago

  • Status changed from Blocked to Closed

Also available in: Atom PDF