Project

General

Profile

Bug #7722

"Windows Server's OU" does not exist in fresh Server 2012 R2 install

Added by DENNY VANDEMAELE over 5 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Dru Lavigne
Category:
Documentation
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hello,

Under 9.1.1. Troubleshooting Tips of the 9.3 documentation, we find this:

"Try creating a Computer entry on the Windows server’s OU. When creating this entry, enter the FreeNAS® hostname in the “name” field. Make sure that it is under 15 characters and that it is the same name as the one set in the “Hostname” field in Network ‣ Global Configuration and the “NetBIOS Name” in Directory Service ‣ Active Directory settings."

Note that there is no such OU as: "Windows Server's OU" on a fresh install of Windows Server 2012 R2 (not sure about others).

Associated revisions

Revision 9c460223 (diff)
Added by Dru Lavigne over 5 years ago

Clarify which versions have OU. Fixes #7722.

History

#1 Updated by Dru Lavigne over 5 years ago

  • Status changed from Unscreened to Closed: Behaves correctly

Then that means that that trouleshooting tip does not apply?

#2 Updated by DENNY VANDEMAELE over 5 years ago

The problem is that it adds confusion. People will look for the "Window's Server OU" and not find it. Then they may think they can just create one, however, a newly created OU (no matter what you name it) will have no special permissions/features.

I just confirmed that Server 2008 R2 out of the box does not have "Window's Server OU" either.

#3 Updated by Dru Lavigne over 5 years ago

  • Status changed from Closed: Behaves correctly to Screened

How would you suggest the wording?

#4 Updated by DENNY VANDEMAELE over 5 years ago

Hello,

I'm not sure of the intentions of the original writer of the documentation, so I think your SAMBA/AD programmer needs to be consulted.

It could be that there was a "Window's Server OU" in previous versions of windows server (below 2008 R2). All I know is that this part, "Try creating a Computer entry on the Windows server’s OU." is incorrect information for at least Server 2008 R2, Server 2012, and Server 2012 R2 (and possibly more).

#5 Updated by Dru Lavigne over 5 years ago

  • Status changed from Screened to Resolved

Fixed in 9c460223671895185592dea6a21a03c3eb554beb.

#6 Updated by Dru Lavigne almost 3 years ago

  • Target version set to Master - FreeNAS Nightlies

Also available in: Atom PDF