Project

General

Profile

Bug #7724

Proftpd won't start when using FTP with TLS

Added by Joop Worst over 5 years ago. Updated about 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
Nice to have
Assignee:
Suraj Ravichandran
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

FTP without encryption works fine but when I try to enable TLS I get the following error:

Jan 25 21:19:00 freenas notifier: Starting proftpd.
Jan 25 21:19:00 freenas notifier: 2015-01-25 21:19:00,848 freenas.local proftpd44543: fatal: TLSRSACertificateFile: '/etc/certificates/FTP' does not exist on line 52 of '/usr/local/etc/proftpd.conf'
Jan 25 21:19:00 freenas root: /usr/local/etc/rc.d/proftpd: WARNING: failed to start proftpd
Jan 25 21:19:00 freenas notifier: /usr/local/etc/rc.d/proftpd: WARNING: failed to start proftpd

I have generated one CA and one certificate and selected the certificate for the TLS function.

I am running: FreeNAS-9.3-STABLE-201501241715

History

#1 Updated by Jordan Hubbard over 5 years ago

  • Category set to 118
  • Assignee set to Suraj Ravichandran
  • Target version set to Unspecified

#2 Updated by Suraj Ravichandran over 5 years ago

  • Status changed from Unscreened to Screened

Something has gone wrong in the creation of your proftp.conf file.

as clearly the "TLSRSACertificateFile:" should point to a specific .crt file (as designed by freenas).

What is the name of the certificate that you created internal using the internally created CA.

Also could you please paste the output of "ls -lah /etc/certificates" in your reply.

Finally, please try to create a new certificate and see if that works.

Thanks.

#3 Updated by Joop Worst over 5 years ago

For some reason the bug is gone and I can start FTP with TLS without any errors. Maybe a reboot helped, I don't know.

This bug report can be closed.

#4 Updated by Josh Paetzel over 5 years ago

  • Status changed from Screened to Closed: Cannot reproduce

Bizarre. Let us know if it resurfaces.

#5 Updated by Joop Worst over 5 years ago

It resurfaced. It only happens when selecting another country, e.a the Netherland as origin when you create a certificate. It all works fine if you leave it to United States.

#6 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from Unspecified to N/A

Also available in: Atom PDF