Project

General

Profile

Bug #7744

Rsync tasks created before FreeNAS update cannot be edited

Added by Maciej Maczynski over 5 years ago. Updated about 3 years ago.

Status:
Closed: Duplicate
Priority:
Nice to have
Assignee:
Suraj Ravichandran
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I have four Rsync Tasks, which I created when my FreeNAS box was running version 9.2.

Now, after upgrade to 9.3, I cannot edit those Rsync Tasks any more: I load "Edit" form, change some parameters (actually all I want is to disable one task) and when I press "OK" button text changes to "Please wait..." for a while and reverts to "OK". "Edit" dialog does not disappear (as it does when everything is OK). When I finally close it, the change is not applied. I see no error messages neither in UI, nor in logs.

"Edit" works fine only for newly created rsync tasks.

Forum thread here: https://forums.freenas.org/index.php?threads/cannot-edit-old-rsync-task-any-more.27146/


Related issues

Related to FreeNAS - Bug #7594: Cannot Create or Edit RSync TaskResolved2015-01-20

History

#1 Updated by Jordan Hubbard over 5 years ago

  • Assignee set to Suraj Ravichandran
  • Target version set to Unspecified

#2 Updated by Maciej Maczynski over 5 years ago

I was totally wrong about the cause of this error: this has nothing to do with 9.2 -> 9.3 update. It is about "Validate Remote Path" option misbehavior.
All my old tasks has this option set and was configured with RSync module while new tasks used Rsync over SSH.
So - this is duplicate of #7594. I will add my notes there.

#3 Updated by Suraj Ravichandran over 5 years ago

  • Related to Bug #7594: Cannot Create or Edit RSync Task added

#4 Updated by Suraj Ravichandran over 5 years ago

  • Status changed from Unscreened to Closed: Duplicate

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from Unspecified to N/A

Also available in: Atom PDF