Project

General

Profile

Bug #7764

NUT does some strange UPS tests and reboots FreeNAS server

Added by Václav Bohata over 5 years ago. Updated about 3 years ago.

Status:
Closed: User Config Issue
Priority:
Nice to have
Assignee:
-
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After update to FreeNAS 9.3: sometimes (+- every two weeks) server reboots due to probably UPS NUT bug issue. For example:

1. 3:12pm - I receive an email with body: ONBATT - ups from FreeNAS
2. server reboots and becomes unreachable (or shuts down and then powers on - I do not know it exactly), zabbix monitoring sends me an email about it at 3:15pm
3. 3:18pm - I receive an email with body: LOWBATT - ups from FreeNAS
4. 3:18pm - I receive an email with body: ONLINE - ups from FreeNAS
5. zabbix monitoring can reach the server so it sends me an email about it at 3:23pm, battery charge is below 40 percent

[root@nas] ~# upsc ups
battery.alarm.threshold: 0
battery.charge: 097.0
*battery.charge.low: 15
battery.charge.restart: 00*
battery.date: 03/19/13
battery.packs: 000
battery.runtime: 540
battery.runtime.low: 120
battery.voltage: 27.38
battery.voltage.nominal: 024
device.mfr: APC
device.model: Smart-UPS 1500
device.serial: AS1312221926
device.type: ups
driver.name: apcsmart
driver.parameter.pollinterval: 2
driver.parameter.port: /dev/cuau0
driver.version: 2.7.2
driver.version.internal: 3.1
input.frequency: 50.00
input.quality: FF
input.sensitivity: H
input.transfer.high: 253
input.transfer.low: 208
input.transfer.reason: line voltage notch or spike
input.voltage: 243.3
input.voltage.maximum: 243.3
input.voltage.minimum: 243.3
output.current: 02.63
output.voltage: 241.9
output.voltage.nominal: 230
ups.delay.shutdown: 090
ups.delay.start: 240
ups.firmware: 651.2.I
ups.id: RACK
ups.load: 046.1
ups.mfr: APC
ups.mfr.date: 03/19/13
ups.model: Smart-UPS 1500
ups.serial: AS1312221926
ups.status: OL
ups.temperature: 025.2
ups.test.interval: 1209600
ups.test.result: NO

- please ignore the battery charge - I was just testing the UPS before reporting this bug

What is causing UPS to discharge? I can see "input.transfer.reason: simulated power failure or UPS test" after the FreeNAS reboot.

History

#1 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Unscreened to Closed: User Config Issue

The server is shutting down, as asked to by the UPS. Why your UPS is running down its battery and then signaling FreeNAS is anyone's guess. Perhaps the UPS has a defect of its own. Either way, maybe the best choice in this case is not to hook up this UPS's status to FreeNAS.

#2 Updated by Václav Bohata over 5 years ago

OK, maybe simulated power failure is initiated by the UPS instead of normal self test but FreeNAS should not shut down. I configured UPS service Shutdown mode to "ups reaches low battery" and Auxiliary parameters has "override.battery.charge.low = 15" option set.

#3 Updated by Václav Bohata over 5 years ago

... FreeNAS initiated shutdown when battery was near to 100 percent.

#4 Updated by Jordan Hubbard over 5 years ago

  • Target version changed from 150 to Unspecified

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from Unspecified to N/A

Also available in: Atom PDF