Project

General

Profile

Bug #77710

Avatar?id=55038&size=50x50

Duplicate plugin created after installation

Added by Zackary Welch over 1 year ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Brandon Schneider
Category:
Middleware
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

On the latest nightly, I found that whenever a plugin is installed (tested with Deluge and GitLab), two jails are created (pluginname and pluginname_2), with separate ips. Both jails are running after plugin install. Seems like a regression.


Related issues

Has duplicate FreeNAS - Bug #78456: Plugin installation seems to always create two instancesClosed
Copied to FreeNAS - Bug #79527: Do not create duplicate plugin during installationDone

Associated revisions

Revision 72821710 (diff)
Added by Brandon Schneider over 1 year ago

fix(jail/fetch): Check for existence of plugin_index before second run The second run only succeeds because the directory would have caused an EOF, but afterwards results in duplicate creation of plugins Ticket: #77710

Revision 95cb0463 (diff)
Added by Brandon Schneider over 1 year ago

tkt-77710: fix(jail/fetch): Check for existence of plugin_index before second run (#2727) * fix(jail/fetch): Check for existence of plugin_index before second run The second run only succeeds because the directory would have caused an EOF, but afterwards results in duplicate creation of plugins Ticket: #77710 * *cough*

Revision 916c9b53 (diff)
Added by Brandon Schneider over 1 year ago

fix(jail/fetch): Check for existence of plugin_index before second run The second run only succeeds because the directory would have caused an EOF, but afterwards results in duplicate creation of plugins Ticket: #77710 (cherry picked from commit 72821710f27f7ace669943119a83d95e068a0e91)

History

#1 Avatar?id=55038&size=24x24 Updated by Zackary Welch over 1 year ago

  • Subject changed from Two jails creation after a plugin is installed to Two jails created upon plugin install

#2 Avatar?id=55038&size=24x24 Updated by Zackary Welch over 1 year ago

There are two entries in Installed Plugins and two in Jails.

#3 Updated by Dru Lavigne over 1 year ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

Zack: please reproduce then attach a debug (System -> Advanced -> Save debug) to this ticket.

#4 Avatar?id=55038&size=24x24 Updated by Zackary Welch over 1 year ago

  • File debug-freenas-20190227155706.tgz added

#5 Updated by Dru Lavigne over 1 year ago

  • Status changed from Blocked to Unscreened
  • Assignee changed from Release Council to William Grzybowski
  • Reason for Blocked deleted (Need additional information from Author)

#6 Updated by William Grzybowski over 1 year ago

  • Assignee changed from William Grzybowski to Brandon Schneider
  • Target version changed from Backlog to 11.3-BETA1

Zackary, can you create that debug right after installing the plguin?

Brandon, my initial thought its maybe UI sending two calls, but passing to you for investigation.

#7 Avatar?id=55038&size=24x24 Updated by Zackary Welch over 1 year ago

  • File debug-freenas-20190228111528.tgz added

#8 Avatar?id=55038&size=24x24 Updated by Zackary Welch over 1 year ago

  • File deleted (debug-freenas-20190227155706.tgz)

#9 Avatar?id=55038&size=24x24 Updated by Zackary Welch over 1 year ago

  • Subject changed from Two jails created upon plugin install to Duplicate plugin created after installation

#10 Updated by Dru Lavigne over 1 year ago

  • Has duplicate Bug #78456: Plugin installation seems to always create two instances added

#11 Updated by Brandon Schneider over 1 year ago

  • Status changed from Unscreened to In Progress

#12 Updated by Bug Clerk over 1 year ago

  • Status changed from In Progress to Ready for Testing

#13 Updated by Bug Clerk over 1 year ago

  • Copied to Bug #79527: Do not create duplicate plugin during installation added

#14 Updated by Dru Lavigne over 1 year ago

  • Status changed from Ready for Testing to Done
  • Target version changed from 11.3-BETA1 to Master - FreeNAS Nightlies
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#16 Updated by Dru Lavigne over 1 year ago

  • File deleted (debug-freenas-20190228111528.tgz)

Also available in: Atom PDF