Project

General

Profile

Bug #7773

WARNING: The "acl check permissions" option is deprecated error

Added by Jailer Jailer over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Jordan Hubbard
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After the latest SU which included the Feature #7720 Samba update to 4.1.16 introduced an error in the console - WARNING: The "acl check permissions" option is deprecated.

This appears similar to a bug reported in the 9.3 beta seen here - https://bugs.freenas.org/issues/6071

Associated revisions

Revision 58717fbe (diff)
Added by John Hixson over 5 years ago

Apparently I fudged the patch. Ticket: #7773

Revision 1a903c88 (diff)
Added by John Hixson over 5 years ago

Apparently I fudged the patch. Ticket: #7773 (cherry picked from commit 58717fbe3d340ae7be33d87118ee0019759352e1)

History

#1 Updated by Jordan Hubbard over 5 years ago

  • Category set to 57
  • Assignee set to John Hixson
  • Target version set to Unspecified

#2 Updated by John Hixson over 5 years ago

  • Status changed from Unscreened to Ready For Release

When I updated the samba version, I fudged the patch. Fixed in commit:58717fbe3d340ae7be33d87118ee0019759352e1. It's not an error by the way, just a warning.

#3 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Ready For Release to Resolved

#4 Updated by Christoph Franke over 5 years ago

The warning is still present in the latest stable snapshot.

root@freenas] ~# cat /etc/version
FreeNAS-9.3-STABLE-201502040431
[root@freenas] ~# smbstatus
WARNING: The "acl check permissions" option is deprecated

Samba version 4.1.16

#5 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Resolved to Unscreened

#6 Updated by John Hixson over 5 years ago

  • Status changed from Unscreened to Ready For Release

This was fixed Saturday: ports|1a903c88b2067079fb6a66ca51aceed8af5b0595. Perhaps the samba binary in the build needs to be re-rolled? That was the problem I had before the deprecation errors went away.

#7 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Ready For Release to Resolved

#8 Updated by Christoph Franke over 5 years ago

The warning is still present in the latest stable snapshot.

Version

[root@freenas] ~# cat /etc/version
FreeNAS-9.3-STABLE-201502050159

smbstatus

[root@freenas] ~# smbstatus
WARNING: The "acl check permissions" option is deprecated

Samba version 4.1.16
PID     Username      Group         Machine
-------------------------------------------------------------------

Service      pid     machine       Connected at
-------------------------------------------------------

No locked files

testparm

[root@freenas] ~# testparm
Load smb config files from /usr/local/etc/smb4.conf
WARNING: The "acl check permissions" option is deprecated
Loaded services file OK.

#9 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Resolved to Unscreened

Sigh Back to unscreened.

#10 Updated by John Hixson over 5 years ago

  • Status changed from Unscreened to 15
  • Assignee changed from John Hixson to Jordan Hubbard

I'm not able to reproduce this. Nor am I able to see how this is possible with the commit that fixed it. Something is not right with the update or the old binary remains. I've built and installed via ISO several times since I've patched this and simply don't see it.

#11 Updated by Christoph Franke over 5 years ago

If I can help on the matter please let me know.

#12 Updated by Jordan Hubbard over 5 years ago

Christoph, can you paste in your system version? This should be fixed and John cannot reproduce your problem anymore.

#13 Updated by Roger Wilco over 5 years ago

Hi,

stumbled upon this too - it should have been fixed in

FreeNAS-9.3-STABLE-201502040431

but the warning still appears.

#14 Updated by Cyber Jock over 5 years ago

Several people are claiming the problem isn't fixed. But it is for me. No clue why it is for some and not for others.

https://forums.freenas.org/index.php?threads/warning-the-acl-check-permissions-option-is-deprecated.25273

#15 Updated by Christoph Franke over 5 years ago

Jordan, I am running FreeNAS-9.3-STABLE-201502050159. Or do you mean something different?

#16 Updated by Jordan Hubbard over 5 years ago

BRB: We are starting to wonder if this is a weird build problem. Trying a fresh update from cleaned sources to see if John and I can get the checksums for the smbd binary to match. Mine is older than his, and I just applied the same SU. :-/

#17 Updated by Christoph Franke over 5 years ago

After the update to the latest stable snapshot the warning is gone. Don't know if you already changed something in the build process, just wanted to let you know.

[root@freenas] ~# cat /etc/version
FreeNAS-9.3-STABLE-201502060108

#18 Updated by Jordan Hubbard over 5 years ago

  • Status changed from 15 to Resolved

Yep, it was a build issue that we fixed. Glad that mystery is solved!

#19 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

Also available in: Atom PDF